Accessing the app store - apps.mios.com

#1

While accessing the app store through my device (veraedge) - I get back an empty page of apps.

Seems like the server (https://apps.mios.com) is up… but returns a 403.

tail -f log.cgi-proxy 2019-01-02_13:55:34 -[24933]- Request OK 2019-01-02_13:55:34 -[24933]- END proxy.sh in 1 seconds 2019-01-02_13:55:38 -[25077]- START proxy.sh 2019-01-02_13:55:38 -[25077]- Start for URL: https://apps.mios.com/get_install_plugins_json.php 2019-01-02_13:55:38 -[25077]- Server OK, matches '.*.mios.com' 2019-01-02_13:55:38 -[25077]- Connect to url: (GET) https://apps.mios.com/get_install_plugins_json.php 2019-01-02_13:55:39 -[25077]- curl exit code: 0 2019-01-02_13:55:39 -[25077]- HTTP status: 403 MMSResponse: 2019-01-02_13:55:39 -[25077]- Request OK 2019-01-02_13:55:39 -[25077]- END proxy.sh in 1 seconds

Are others seeing this too? Trying to make sure “this isn’t me!”.

According to the status page there was a major outage 1h18m on Dec 31. I was not able to access it yesterday or today.
I guess we can’t put to much stock in their status page. :frowning:

I’ve sent FB pm’s and Twitter message to @veralovers - and so far …crickets.

#2

It’s been like this for a couple of days. As a developer, I also can’t upload new versions of files at the moment, and Vera also hasn’t approved any plugin updates for about two weeks.

Paging @Sorin!

#3

Blank Apps and Plug-in install page on the dashboard for me as well. Been that way since the 31st. Vera tech support does not appear to be open for business today either.

#4

Also seeing this issue with app store. I am trying to update Harmony App for get it back to life… no dice; not even with magic url.

#5

Same here. 403 is forbidden. Uncool :frowning:

C

#6

[quote=“rigpapa, post:2, topic:200348”]It’s been like this for a couple of days. As a developer, I also can’t upload new versions of files at the moment, and Vera also hasn’t approved any plugin updates for about two weeks.

Paging @Sorin![/quote]

Let’s hope this is related to the long-awaited firmware rewrite.

#7

At the risk of sounding terribly cynical, if I had to bet, I’d guess that for some time now the marketplace has been the red-headed stepchild of engineering (as evidenced by the fact that it’s still a UI5-era tool), and I can imagine one poor guy, maybe the most junior engineer, is assigned to care for it and do plugin approvals, and he’s been on holiday. Others can probably deal with it, but don’t think to because he normally does it, and they’d really rather not anyway.

Seriously, I think how the marketplace evolves and fits into the coming ecosystem will be very telling with respect to the future relationship Vera maintains with plugins and their developers, IMO.

#8

Same here as well, have also seen quite a few errors in the luaupnp log for apps looking to update (below is the Alexa plugin)

FileUtils::ReadURL 0/resp:403 user: pass: size 226 http://apps.mios.com/get_plugin_version2.php?plugin=8840&accesspoint=45200411&platform=mt7620a_Luup
&firmware=*1.7.4000*&oem=1 response: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /get_plugin_version2.php
on this server.</p>
</body></html>
#9

From a purely technical point of view, if one wanted to shut down the app store, making it just spew a 403 error would be an odd way to do it. Simply setting up a simple ‘App store no longer supported’ index page or similar would be much more elegant.

403 specifically is ‘forbidden’ i.e. you don’t have access to this resource (not ‘this resource does not exist’) so to me it feels like someone’s made an error, there’s been some kind of automated update on the underlying web servers or something’s just plain broken. It’s a bit worrying (increasingly) that the level of professionalism required to monitor and react to that kind of scenario is not (apparently) present.

C

#10

Hello guys,

Just stepped into the office after the holidays. As soon as I find out what’s happening I’ll keep you posted.

So sorry about this.

#11

Thanks very much @Sorin - Appreciated!

#12

Service should be restored now. It was just a file system error due to a backup replication issue which because of the reduced personnel over the Holidays period, it slipped out.

We’re sorry about that.

#13

Thanks Sorin! Looks good from here

C

#14

Thank you for the reports also. You guys are fast, as always :slight_smile:

#15

Perhaps you should implement some checks and balances so it does not occur.

Being on a reduced personnel is not an excuse.

[quote=“Sorin, post:12, topic:200348”]Service should be restored now. It was just a file system error due to a backup replication issue which because of the reduced personnel over the Holidays period, it slipped out.

We’re sorry about that.[/quote]

#16

Our networking team and architects are already on this. There are no excuses about such a situation, just my own words, and the sincerest apologies. :wink:

#17

I can still not access the app-store from Vera, just a blank page.
Edit: Works now

#18

Don’t know if its related but I installed the latest firmware yesterday and now when I go to the “Install apps” for my VeraPlus all I get is the header and a search bar. No apps are listed and a search does nothing. When I first go to the page I do get a spinning icon for maybe 30 seconds. is there a server problem again?

#19

I think you have to be logged in to see the apps in the apps store. At least that is my recent experience.

#20

Are you talking about being logged into my VeraPlus, or something else? Since you have to be logged into your device to even get to the apps page, I’m not sure what you are suggesting. Never had to be logged into anything but my device in the past.