Aeotec MultiSensor 6 (6-in-1) works with Vera - NOT

Since July 2019 I am struggling with Vera about a specific device support. Since I had an issue with Fibaro motion sensor (ghost devices) I decided to go for a “vera supported device”. According to the website:
https://getvera.com/search?view=alternate The Aeotec MultiSensor 6 “works with Vera”.

I start this topic for some reasons:

  • Discover if I am (not) Alone.
  • Ask the community if there are others with this device and do/do not have problems and do have UV reports/no ghost devices.
  • Let the community know that despite Vera support always comes back with an answer (sometime after days or even weeks) the problem is not solved and according to me the device is “NOT supported by Vera”.
  • I do have to say: Vera support is always willing to help! Despite they’re not so able (seen the results)

More than:

  • 6 months later.
  • 110 Emails further (110 received!!!).
  • 7 (7!) support representatives further (Alex Sescu, Radu Bojica, Bogdan M., Ionut Sinatovici, Omar Gonzalez, Leonardo Vergara, Sara).
  • 2 physical devices (6in1 sensors) further.

It still is not compatible!

What is tried:

  • numerous inculde/excludes.
  • numerous firmware levels for the aeotec.
  • numerous devices hided by support (I discovered they just hide ghost devices).
  • numerous support sessions with support (remote support).
  • numerous reconfigure device now’s.
  • connecting via battery/USB powered. (The device is now permanently USB powered).
  • numerous other things

What does work and does not:

  • Does: Motion detection seems reliable (as long as you do not plug and unplug the power)
  • Does: Humidity, Light & temperature seems to update once in a while
  • Does not: UV never updates and never worked (device is outside and on regular time in “direct or indirect” sunlight.
  • Does not: stop creation of ghost devices/renumbering of devices.

Vera support has an answer for everything! (but not the problems). A small grip of frequently said things:

  • The device just does not report it so Vera can’t display it.
  • We’ve been testing the same device on our lab and we were unable to replicate the issue you’re experiencing.
  • According to the logs and the parameters of the sensor, the behavior is expected since the sensor generating ghost devices happens at a wake-up most of the time and that’s the information the sensor sends back to Vera.
  • Different flags appearing in the sensor such as can’t detect device, or getting the manufacturer are highly related to errors during the pairing process (Which is not your case, since you’ve done it several times) or a faulty device.
  • We can set the autoconfigure parameter to No and the “ghost” devices to invisible so they don’t show in the Vera interface, but you need to keep in mind that the Vera reflects what the sensor is sending.
  • We’re still waiting for an answer on your case from the higher Tier/Level 3.
  • We removed the ghost devices (in fact they’re hided).
  • We’re receiving a high volume of email, accept our apologies (during the 7.30 debacle).

Below a screenshot of the complete email (back-forward) with Vera Support… a 71 page document…

Oh Vera…

have you tried copying tthe config for http://wiki.mios.com/index.php/Aeon_4in1

if this is the unit https://www.amazon.com/Aeotec-Multisensor-Temperature-Humidity-Vibration/dp/B0773FWJ2Y.
Motion, Temperature, Humidity, Light are the same as the 4 in 1 but UV and Vibration may need custom configurations to work and these are probably what is causing the ghost devices.
Im assuming UV would be similar to light and vibration would be an open/close

Id get one to mess with but its $60

https://www.youtube.com/watch?v=IWO3-QWJwoY here is a video

I have 4 of these devices setup and all working as expected. I have also set some automation for an external awning to deploy if temperature and lux values are over xyz for xyz period. Sensitivity is the only setting in Vera I had to tweek

1 Like

Hi PrincessCleavage, Can you post a screenshot of the devices (and sub-devices) with them showing UV?

Hi Richie, no I have not. this is another physical device.

That’s what I have as well (next to a load of ghost devices… hided and moved to other room)


Have you ever seen UV reporting something?

I think so, I will check tomorrow when its day time

I have two of them. I have NEVER seen the UV number change. As I look at it right now they are both at 0, and the lights are on in that room, and it is starting to get bright outside. Go figure. I gave up long ago with this when Vera was making excuses for it not working. I suppose bad habits are hard to break!

I have never seen that UV sensor is reporting anything other that “0Level” and also have problem with gost motion-sensor devices (currently I have 3 of them).
Rest of sensors seem to work properly.

Yes my UV sensor also shows 0 but my guess is that in order for UV to register something it would require direct sunlight to shine on the unit and none of my units ever get direct sunlight. I do not have a problem with ghost sensors

@ PrincessCleavage is right. For the UV sensor to report anything different than 0, it must be placed somewhere outside directly under the sunlight.
Just tested this using a ZW100 sensor from our office and here is the result:

0x31 - CC Multilevel Sensor
0x5 - report
0x1b - sensor type - UV
0x1 - level
0x1 - value (which is 1 in dec)

Regarding the ghost devices, I need to look over some logs to see if I can spot anything. I will leave the multi-sensor connected in the attempt to replicate this issue.

Bogdan, you were also involved in my case :zipper_mouth_face:

I don’t know if it were you or someone else… but according to Vera “my” sensor(s) did not report anything at UV to Vera. And according to the manual the sensor may not be behind glass else it cannot report UV correctly (logically). My sensor is placed outside, in direct light/sunlight sometimes under a roof.

I was the one to advise Vera to buy such a sensor because a few months ago vera support did not even have had such a sensor and wanted to test everything on my unit (with all disadvantages of that). :zipper_mouth_face:

I am not part of the Customer Care department, we are more than one person with the same first name in the company.
However, you should know that the value 0 displayed on the UI did not came from Vera, but rather it was reported by the sensor.
If your sensors are always reporting 0, there could be multiple reasons for this.
Just out of curiosity, please compare the configuration of your sensors with the one we have here (see below) and let me know.

versioninfo

1 Like

image

Try to add parameter 45 with data size 1 and value 1.

1 Like

Done, will monitor:

I have a couple of these sensors, and also have never had a UV reading; BUT they are located indoors, and I don’t believe that there is much in the UV spectrum indoors. Perhaps a constant reading of zero is a good thing.

As for Vera changing IDs on the children, that is a problem with all devices that have chaildren. The parent device stays the same, but the children change with every re-configuration. It’s a Vera thing. Always has been.

Well… it’s a mess again…

Since I had “waiting for wakeup to configure device” I had to press “configure node right now” and then hell bagan… Now all my device ID are resetted (yes I know Vera does this, but it is so FRIKKING anoying and unneeded!).

And a day later I have 3 new ghost devices again…

Restore a backup that was working, then set automatically configure to no. This should prevent future resetting of the children.

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy