All of my Philio PAN16 devices says "Can't Detect Device" but still works

I have 3 of these and they all shows Can’t Detect Device, but they still works. Is there any way to get rid of these messages? The support doesn’t seem to be able to make it go away. Should not be a problem, what seems to be supported by Vera?

Go to Devices -> one of you PAN16 -> Advanced -> Variables

Please, tell values:

  1. PollSettings
  2. PollNoReply
  3. PollRatings
  4. ConsecutivePollFails

And… If device switched on and of (or off and on) from Vera, are “Can’t detect” disappears?

2 Likes

Pollsettings 60
PollNoReply 7184
Pollratings 0.00
ConsecutivePollFails 62

When on/off the message disapperas some times, some times it doesent.

This is from one of the 3 devices.

It’s a well known problem of Vera controller with some devices, for example - with Heltun thermostats.
If answer to poll request too slow (by Vera opinion), after N consecutive “fails”, “CommFailure” variable bringed on and status of device “Failed”, but device still Ok.

Simplest way:

  1. Ignore it. May be, after 10 or 10000 years this problem can be fixed.
  2. If you don’t need a security, you can try re-add PAN16 as unsecured device. May be poll answers can be delivered faster (or may be not).
    Unpair it, go to “Add device”, select Fibaro 223 from wizard, go throw wizard. It’s only way to add device without security :smile:
    (don’t ask me, why it can be done by this way - too many questions, but too few answers :slight_smile: )
    If it does not help - use solution from point (1)

Thank you, I will give it a try to add as unsecured and see if that helps.

One problem with alternative 1, to ignore it. When the error message is present, the device still works from Vera, but not with the Google Home, i’m not able to control those with my voice.

Workaround is:

  1. Set poll interval to zero (no poll)
  2. Check CommFailure variable by variable_watch or by timer and send “do nothing” command by SendData, for example - set unneeded device parameters to always-right value.
    If any communication with device performed, CommFailure status disappears.

I have already sett poll interval to zero, does not help.

  1. I Don’t understand what or how to do…

At evening i can write small script.

awsome, thank you!

Try this
Add to startup (Apps -> Develop -> Edit startup )
Fill “yodev” for one of you PAN16 and oversee, how it works for a day or two.

local yodev=NNNNNNNNNNNNNN

luup.variable_watch(luup.variable_watch("ResetCommFail","urn:micasaverde-com:serviceId:HaDevice1","CommFailure",yodev)

function ResetCommFail(dev_id,service, variable, old_val, new_val)
   if new_val == "1" then
-- Obtain node id from dev_id
      local devnod=luup.devices[dev_id].id
      luup.log(string.format("+++ Kick device %d",devnod))
      if devnod == nil then return end
      if devnod == 0 then return end
      local Nod = string.format("%d",devnod) 
-- set dev. parameter 7 to 1, it's a LED control
      luup.call_action('urn:micasaverde-com:serviceId:ZWaveNetwork1','SendData',{Node=Nod,Data='112 4 7 1 1'},1)
   end
end

Where exactly should i add my device? And is it device # found on settings tab i should use?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

© 2019 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy