Ambient Weather Sensors

If you’re looking for temperature/humidity sensors you may now consider the Ambient Weather F007TH. It’s not the lowest cost sensor out there but I believe it has a longer range than many of the others. The latest EXT2 firmware for the RFXtrx433e decodes signals from this unit. I’ve found it to be able to be received over longer distances and even from the inside of a freezer. The one from Banggood is very inexpensive but isn’t really good for outdoor use. The unit has gaskets but when I placed one outside it got lots of condensation inside.

No, I don’t sell these things and have no connection to anyone who does :slight_smile:

Thanks for sharing :slight_smile:

@tinman I have a bunch of these sensors but cannot figure out how to get them to be received by the RFXTrx… can you help out?

If you have the Oregon protocol enabled it should receive signals from them.

Oregon Protocol? Sounds like a Robert Ludlum novel :smiley:
C

Can you let me know if you get it working? I have RFXtrx433E with EXT1 Firmware. I guess I could update it to EXT2. If it works, they are on ebay for approx’ £6.00 so I could use a couple of them.

will do - and yeah I’ve got 8 of these and have had them for like 3 years and the rfx even longer. I’m kicking myself for not doing this earlier, as long as it works. I might have to upgrade my firmware on it to get it receiving though, based on what I’ve been reading. This thing is so finicky so really don’t want to go that route unless it’s going to make it work.

So, before I go bricking my setup…

I bought the rfxtrx specifically for controlling rollertrol window shades, and have installed the files from some wiki site zip file directly by uploading luup files.
Understanding that I need to update the firmware on the actual rfxtrx itself, do I need to update my vera plugin from the files in this thread, or the app download named RFXCOM?

On this same note, how do I see what version I have of the plugin? On my actual device it says beta3 on the message of the device, but I also have some other random ‘rfxtrx controller’ device that doesn’t control anything, like it’s an extra device created by accident - but if I delete it, it comes back.

The RFXCOM app is very old and should not be used. Download the ZIP file found here: Plugin Update V1.87
Upload all the files to your Vera hub. Once that version of the plugin is running you can see the plugin version in the Help tab of the RFXtrx device. After uploading the plugin files, if you still have a random rfxtrx controller there may be some files you’ll need to delete. Let me know about your results.

1 Like

I assume I should be updating the rfxtrx firmware first, but I can’t connect to the device using either the flash programmer windows manager… Sigh any ideas?

Be sure to connect the RFXtrx to your computer before starting the RFXFlash program. That way the program usually finds and selects the correct port.

Yeah I tried unplugging and replugging. I could hear the confirmation from windows, but nothing in the programs.

Also, I just uploaded the new plugin files and don’t see any difference. Is there an easy way to remove them all and start over? I see most have a ‘1’ after them, like they’re duplicate copies.

Where are you seeing the files with a ‘1’ after them? When you upload files to your Vera hub they will normally overwrite any file with the same name.

In the luup files section. Where you can drag and drop them, below that are the files listed. I have tons listed there for plugins but many are with a 1 after… :confused:

Many will have digits after them. Just appears to be Vera’s convention

C

1 Like

Yes, most of the device files (*.json and *.xml) will have a ‘1’ in the filename. That’s typical.

So when you connect the RFXtrx to your PC with USB, run RFXflash and click the Connect to Device icon (second from the left at the top) what happens?

I’m an idiot - I just needed to download the usb device driver for the rfx. After that and a reboot, I connected fine. I flashed the firmware and now see the new plugin layout and have enabled Oregon Scientific protocol. I have “enable automatic device creation” set to yes, so now I assume I just wait for the sensors to start sending out data…? I’ve had this all in place for about 20-30 minutes and nothing new showing up and nothing happening when I click “refresh data” on the temp hum data tab.

Probably worth mentioning, I don’t know if I have the Rfxtrx433 or the Rfxtrx433E. (purchased in 2013) But the user guides were pretty clear that the 433 firmware type 1 and 2 could go on either, but the 433E EXT1 or EXT2 firmware flashed to the 433 would cause serious problems. So long story, short, I flashed 433 Type 2 vers 1025 on my unit.

I sincerely appreciate your help through getting this all set up!

The Ambient weather sensors do not transmit as often as some others I have but I would have thought that 30 minutes would be long enough for at least one of them to show up. How far away are the sensors from the RFXtrx? If you could move one close - at least temporarily - you could at least determine if they can be detected.

I think these (F007TH) report every 10 mins, but maybe you’re right at 30. I moved one literally beside the rfx on it’s shelf and nothing showing up after about 6 hours…?

I suppose the F007TH will transmit every 2 minutes, check the transmit indicator on the sensor (if available)
Check with RFXmngr and enable the Oregon protocol and use the latest Ext2, Pro1 or Pro2 firmware!

© 2019 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy