AutoVera app still working for you?

Can’t tell if I’m the only one this is affecting, but my AutoVera android app stopped working a while back, with the main problem being that it refuses to populate the “Your Veras” list of controllers.

My posts elsewhere online, including the app dev’s own AutoVera forum, have gone unanswered, so I’m left wondering if the app is still active and/or works with UI7 any more.

I’ve tried all the classic uninstall/reinstall, check Settings, etc. but coming up empty on solving this issue.

Thoughts? Thanks!

  • Libra

According to the app’s log report, the issue seems to lie with getting OAuth authentication from the Mios servers, for which it is receiving this error message:

SOLVED!

AutoVera users must enter their GetVera username in all lowercase when setting up or logging into the app. Apparently, the Mios authentication server chokes on capital letters in usernames (not a problem for passwords thankfully), and this has been a known issue for a couple of years.

@Sorin - please notify whoever oversees the mios1 server of this issue; perhaps it’s just a switch someone left set?

Meanwhile, João Dias @dkc , the dev behind AutoVera, will update the app to advise users (or more likely modify his code so tolowercase() happens automatically). His Vera broke a while back so he’s moved on (both from actively maintaining AutoVera and from this forum).

THANKS!

  • Libra
1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy