AutoVera looses Vera3

Recently purchased a new Vera3 to upgrade my existing Vera1. I am still experimenting with the Vera3, and only have two Schlage locks, one light, and some Virtual Switches on it. The rest of my stuff is still on my Vera1, which is on a separate ZWave network. I am also experimenting with the AutoVera application.

So far I am only using AutoVera Scenes, and AutoVera Device Info. And I got them working (good stuff). Got up the next morning, and when I went to play with the tasker code some more, discovered that AutoVera is no longer seeing the Vera3. Trying to do an AutoVera “Device Info” operation causes AutoVera to abort with a bad pointer. Running the AutoVera application through the Android launch icon shows that AutoVera still seees the Vera1, but does not see the Vera3. I have multiple Android devices, the Vera3 has disappeared on all of them. Refresing the Vera devices has no effect.

Access to the Vera3 is done through my Linksys router. The Wifi on the Vera3 has been turned off. I use a fixed IP address for the Vera3, utilizing the router to assign a specific IP address based on the Vera3’s MAC address.

The Vera3 is still fully functional. I am able to access the Vera3 through the interface. The Vera3 is running UI6. The Vera3 scenes and triggers are working correctly, as well as my LUA code.

I have tried rebooting the Android devices, and rebooting Vera3 both by the reboot command and by power cycling the Vera3. I also tried de-installing and re-installing the AutoVera app on one of my Android devices. I had installed the AutoVera plug-in on the Vera3. I de-installed it as well. AutoVera is still not seeing the Vera3.

Anyone else see this? Any suggestions on what to try next?

Sorry for the difficulty you’re having, you have certainly taken the correct troubleshooting steps. Unfortunately, AutoVera is configured to be compatible with only with UI5 at this time, however, that does not explain why your Vera 3 does not show within the AutoVera app. You should still be able to control devices locally, even with UI6. Are your Veras using different accounts/authentication? If one is on UI5 and one is UI6, that could explain why you cannot see both.

My Vera1 is on UI1. Because of it being so ancient, it is not connected to any micasaverde server (I access it locally using the local IP address). And yes, AutoVera does choke on it if I try to read the Vera1 device list. Obviously I do not have AutoVera do that.

I have been able to access the Vera3 (up until yesterday) just fine (about two weeks).

So, to be clear, you have been using AutoVera with your Vera 3 running UI6 for a few weeks and it just recently stopped working? Am I correct in assuming you do not require remote access or control with AutoVera?

Your Android device would need to be on the same network as your Vera 3, when you register, as well as for any control or status updates. Are you are connected to this same network?

Correct. I may be using AutoVera remotely in the future, but I am not anywhere near there yet.

Your Android device would need to be on the same network as your Vera 3, when you register, as well as for any control or status updates. Are you are connected to this same network?

Yes, same network (and router). Both of my Vera’s are connected via ethernet cable to the same router. The Android devices connect wirelessly also through that same router.

Also remember that it was working two days ago, including just before I retired for the evening. Sometime during the night it stopped working, and I noticed it first thing the next morning. That is what is confusing me, in that there should have been no activity on the network (I was sleeping) when this occured.

Question: What protocol is being used when polling for Vera’s on the local network? Is it different that was is used by GetVera/the browser when it searches for local Vera’s?

There is no polling involved. The vera units phone home and the vera information is retrieved via a http request from the mios servers. Depending on the vera firmware, the http request will be different and in some cases more complex.

  • Garrett

Thanks, Garrett.

If you are on the same network, you should be able to find your local Vera, without authentication. Because of AutoVera’s incompatibility with UI6, you should probably remove your username and password and try to refresh on the Your Veras page.

Your Vera should appear as an IP address and you should be in the same situation you were in previously, with AutoVera working locally but not remotely.

Even locally, UI5 and UI6 use a different URL / API for the locate function.

  • Garrett

Thanks again, Garrett!

Do you know of any changes made to the UI5 URL that would be affecting discovery, whether in the last few days or few hours?

Disregard, it seems there was indeed a temporary server issue affecting discovery.

Seems logical. Last night I restored the Vera3 to factory default. Still did not see it, but this morning the Vera3 magically reappeared.

I will attempt to downgrade to UI5.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy