Beta - Ezlo Linux firmware v.1.1.988.2 update for Vera Edge and Ezlo Plus controllers

We’re releasing a new update for Ezlo Linux firmware for Ezlo Plus and the Vera Edge (that runs Ezlo Linux). v.1.1.988.2:

Changes:

  • This release comes with changes in the Firmware versioning format that were triggered by changes in our flow of building the Firmware. The new firmware version will be 1.1.988.2 and the new format allows us to track changed components better and determine what exactly changed and what needs to be updated. Also in the future we will be able to update firmware “partially” if needed on controllers that are using 1.1.988.2 firmware version or a major one.

New Features:

  • Implemented mechanism for possibility to update plugins independent/separately from Firmware.

  • Added support for HTTP server functionality

Fixes:

  • Fixed the issue about not being able to change color on Zwave RGB bulbs
  • Fixed the issue with random Zigbee module crash and automatically restart when trying to change Zigbee dimmer value after the hub reboot
  • Other bug fixing on Z-Wave and Zigbee devices

Known issues:

  • Issue on devices that support Tamper where the broadcasts and notifications generated are opposite to the actual tamper state

  • Issue on Z-Wave devices with “electric_meter_amper” that is updated only when the hub is restarted. Ampere meter not changing value instantly once pairing a device supporting it (for example pairing a switch and adding some load to it - e.g. connect a bulb)

  • Issue with incorrect sunrise/sunset time for scene in case the timezone is changed after enrollment. The sunrise/sunset scenes are calculated based on location and for the moment we do not have UI support to change it after enrollment (API is in progress of being integrated in UI)

  • Issue on Vera Edge where after the first update from Vera FW to the new Linux FW the “Internet” LED is OFF

API Document:
HTTP server (Public) API Documentation.pdf (20.7 KB)

To get your controller updated to the latest version please do one of the following actions:

  • Power cycle your Vera Edge / Ezlo Plus controller or
  • Unplug the ethernet cable, wait for 10s, plug it back into the Vera Edge / Ezlo Plus controller.
6 Likes

great work guys!

Good work team, web server is now running. When we can expect web interface?

Not a very pretty transition when I followed the directions to disconnect the ethernet cable to upgrade to 1.1.988.2.

Did anyone else need to un-pair and re-pair devices on Android? Not too difficult with just a few test devices, but not what I expected.

Tried on iOS and didn’t get the device broken messages, but unable to get dimmer to respond. Must be missing something?

Yup, same here.

Thank you @wfoley & @reneboer for informing us on this.

Same here.

Then I will wait with the upgrade till this is solved

Same here, can not detect any previous included devices.

Also 3 new device appeared from nowhere after firmware update, and i can not delete them.

Reinstaled a couple of devices, still the smartthings zigbee door and temp sensor only includes as a temp sensor.

Guys, thanks for the feedbacks, we are checking this issue now.
Will back with the answer asap.

1 Like

Hi
it might be interesting to include a journal where we will see the flow of everything that happens during the installation, inclusions and exclusion, uses in beta test, would be more efficient no?

1 Like

You can see broadcast responses in the ezlo api https://apitool.ezlo.com/dashboard. works with plus not sure about atom or plug hub

1 Like

Working with all Ezlo hubs including Atom and PlugHub.

1 Like

does the atom and plug hub use broadcast then? As i read somewhere that not all the Ezlo hubs use broadcast

from api page.
Broadcast message will show up here. Keep in mind that some hubs do not support broadcast messages

How do I disable Wi-Fi on the Edge under this firmware? I’m not using it and don’t want it adding to the RF clutter.

I did not purposely trigger an update of my Ezlo Plus to avoid the “Device Broken” issue but now when I login I see that my Ezlo Plus has updated the firmware anyway an also for me all devices have the “Device Broken” flag.

I hope that once these Ezlo Devices are available for the masses there is an option to disable “automatic update” of firmware.

4 Likes

Guys, a question about the issue you have with devices control after update.
Which build you had before update to the latest build v.1.1.988.2 ?

I am pretty sure i was previously on 1.0.29

Broadcasts are the same for all Ezlo hubs.

But devices were added on 1.0.27 or earlier version, right ?

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules