Beta - VeraMobile for Android v.7.50.692

We’re submitting today to Google a new Beta update for VeraMobile for Android v.7.50.692 with the following:

New features:

  • Add support for the location settings for Ezlo controllers
  • Add support for changing the temperature, date, and time formats for Ezlo controllers
  • Add support for changing a time zone for Ezlo controllers.

Bug fixing:

  • Fixed an issue where an incorrect message was showing up after including an S2 device without authentication
  • Fixed an issue when the app gets disconnected if the user taps back from play record video.
  • Fixed an issue where the user unable to set the controller’s siren to off from Preset Modes on the relay and local connection
  • Fixed an issue where the user disconnects from the app when the app is opened from standby mode
  • Fixed an issue where the user isn’t allowed to edit a mode trigger in create scene step
  • Fixed an issue where the user is unable to access a newly added smart assistant until re-opens the app
  • Fixed an issue when newly added configuration parameters are not displayed on the app
  • Fixed an issue with the Vistacam 702 live stream

For those of you that are Beta testers via the Google platform and want to test the build faster, you can enroll at this link, as we’ve changed the tool to distribute the builds - if you haven’t done it already. If you already use the new tool, you’ll receive an app update with v.7.50.690.

1 Like

You still can’t have dashes in your controller name.

I’ve just changed my settings to degrees C and DDMMYYYY OK.

Looks like you have now tidied up and organised the time zone selection screen as we requested.

Let’s hope the app disconnects and refresh problems are now fixed?

1 Like

Well that didn’t last long till it broke.

All devices just vanished

Had to quit the app and launch it again to get the devices back.

When leaving the Vera app on the Devices screen and then opening other apps on the phone instead.

When switching back to the Vera app sometimes it remains on the devices screen as expected.

However other times you just see the Vera logo and a spinner and then it loads the dashboard page instead.

So still very buggy and for me unusable. Like you I switched to The Home Remote. Very satisfied with this app! I hope that by the time the Ezo controllers are out of “early beta phase” we can integrate them in The Home Remote.

1 Like

Out of house now and on 4G, switched back to the Vera app and nothing is loading just spinning circles of death.

Hi @cw-kid, are you using a vera or ezlo controller? In this release we fixed some issues regarding controller reconnection. Also, when did the devices vanish? When Vera spinning is being displayed or coming back from background directly to devices page? What phone model/android version do you use? We successfully tested vera using 4g.

Hi @Mai_Pensato. Can you please describe your issues with the app?

The app was connected to the Ezlo Plus.

Devices all vanished one time after switching back to the app.

Think it goes to the Dashboard page rather than the devices page I was previously on, when spinning.

Huawei P20 Lite Android 9 Pie.

Sorry to say but I’m not seeing much improvement with the app from the last time I looked at it maybe a month ago.

Some times when I turn on an appliance plug using the Vera app, in the Vera app GUI it still shows the plug as being off, even though I just pressed that very button, the Vera app GUI does not update sometimes.

But the actual physical plug has indeed turned on.

I have to navigate to a different area of the app like scenes then back in to devices and then that particular plug is showing as turned on correctly.

This is what I have been calling the refresh problem throughout many threads here.

Yet other times you can press a button and it does update the button in the GUI and changes its state OK no problems.

Do you Devs not actually use the Vera app you are modding? I won’t say developing.

How are you not seeing these same issues as some of us users on the forum? that we have been reporting these issue for months.

I know your working with a bad app to begin with and you probably would of been finished by now if you had built a brand new app from the ground up.

Thanks.

2 Likes

The latest version makes the devices part on the portal page “flickering” for the VeraPlus. To check I downgraded to the previous version and that displays the portal page without any flickering. Using Android 10 on a Blackview 6300.

Think I see that as well.

If you scroll up and down the devices list sometimes you can see some of the device icons flicker very briefly.

Thanks for reporting. We will look into it.

@oleg.macovei

Was that issue fixed with the old wakup command class you looked at on my Ezlo Plus box?

As that old Everspring door contact sensor, still says it can’t detect it.

Thanks.

BUGS report.

https://jira.mios.com/servicedesk/customer/portal/72/ECS-423

I see flickering on most visible device icons whenever I switch a device ON or OFF. I’m on Android 11 via either of our two Pixel 4a 5g’s.

This is bad on the dashboard

I am seeing the same thing.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules