BroadLink Mark II plugin

still no luck

./broadlink_cli --type 0x6026 --host redacted --mac 052cd3a7df24 --rfscan

Learning RF Frequency, press and hold the button to learn…

RF Frequency not found

Why did you invert the mac address when trying to learn RF? Try this:

./broadlink_cli --type 0x6026 --host redacted --mac 24dfa7d32c05 --rfscanlearn

Typically, I copy and paste the command directly from the broadlink_discovery output.

I had read that you needed to invert the address but also discovery returns the address inverted
./broadlink_discovery
Discovering…
###########################################
RM4

broadlink_cli --type 0x6026 --host redacted --mac 052cd3a7df24

Device file data (to be used with --device @filename in broadlink_cli) :
0x6026 192.168.1.111 052cd3a7df24
temperature = 0.0

Tried the other way and same result

./broadlink_cli --type 0x6026 --host redacted --mac 24dfa7d32c05 --rfscan
Learning RF Frequency, press and hold the button to learn…
RF Frequency not found

We know that RF learning through the broadlink app works so I wonder if the learning protocol for RF has changed with version RM4?

I believe you are correct… I personally don’t have the time or hardware to extend the RF capabilities for the RM4 series of devices. If you read through the python-broadlink GitHub issue list, you might uncover what we need to change in the plugin. Once we know the extent of the changes, we can decide who gets to take a shot at developing and testing changes :wink:

You can use sudo ./broadlink_discovery to run it under root.

I will try but it is perilously close to my understanding of some of these things :slight_smile:

Still only getting
“discovering…”

Found this in the Github issues Broadlink RM4 PRO is not able to learn or to send RF Signal #358
Towards the end felipediel commented 9 days ago
You can use --rfscanlearn as a temporary solution to obtain RF codes:

Does that mean there is a working version for broadlink_cli and if so how would I check?

I believe so. You could try downloading/cloning the python-broadlink GitHub repo to your local machine and then install it by cd’ing to the downloaded copy and using pip3 install . Then run ./cli/broadlink_cli <args>

Actually, I just remembered that you can install a GitHub repo directly. Instead of downloading and running pip, just point to the GitHub repo.

pip install git+https://github.com/mjg59/python-broadlink.git

Unfortunately the version I had already downloaded is the same as above which means it should have the RF working but does not for me
(https://github.com/mjg59/python-broadlink
https://codeload.github.com/mjg59/python-broadlink/zip/master)

I’m not sure what the root cause is so at this point, I suggest that you open a GitHub issue on the python-broadlink repo to ask for help learning RF codes with the broadlink_cli program. The developers are pretty active over there so hopefully you will get some help. Once you are able to learn RF codes with the broadlink_cli, you will be able to configure your Vera plugin.

I’ve also ordered an RM4 Pro device that should arrive Friday so I will be in a better position to understand what is happening. If you learn the magic path elsewhere, please report your findings here to help others. :slight_smile:

Of course I will.

Thanks

Hi, just wondering how you got on with your new RM4 Pro?
I’ve not managed to progress on the python-broadlink repo

I did and have already provisioned it for my network but haven’t gotten much further because my office has been inaccessible due to home rennovations.

FYI, I configured the WiFi completely without the app to keep it cloud-free so to speak. I put it in AP mode, connected to the “Broadlink …” network that it advertised and then ran the broadlink_cli --joinwifi command to connect it to my network. I haven’t had time to test it with the Vera plugin but will soon.

How are things progressing with yours?

Sadly stuck in the same place.
So I got to the stage where as you have done configured WiFi without any of the apps. Used broadlink_cli --joinwifi to connect successfully.

I can learn IR easily enough, the orange learning light comes on and learns the code.

For the RF I have two different remotes one for blinds and one for cooker hood extractor running at 433.15 and 433.92 respectively. The orange learning light comes one but times out for both.

So not even got to trying anything on the Vera yet.

It’ll be interesting to see if you have the same issue when you get round to it.

Hope the renovations are going well.

The only frequency Broadlink uses is 433.92. Don’t expect a learning response from your 433.15 device.
I’ve got a RM4 device on it’s way and will compare it against the RM Pro3, having a RM4 running against the RM3 as a development model might help.

That would be great to know.

Thanks

Just a quick post to say that the plug-in installed great and after a few reloads and some waiting for things to propagate so I could test it out, it seems to be working well with a RM Pro+.

FYI - The json is as follows…

`{“78:1d:34:fd:91:12”:{“blInternalId”:“00000002”,“blKey”:“8383u3he7dg63gw6y3tegwy”,“blDeviceType”:10141,“blIp”:“192.168.1.140”,“blDesc”:“RM3 Pro Plus”}}

Good news. Sounds like an old car I once drove - needed a few restarts before it would get going.

The version you should be seeing is ver 0.56 Refer to the variables tab for the version number. It has improved RF learning and handles some of the more recent RM Pro models as well.

The plugin, along with about 60 others, is available in the AltApp store.

It’s not entirely clear to me how I use the AltApp store, I found it on the forum, installed it, but wasn’t sure what else I needed, e.g AltUi? Or openLuup ?

The AltApp plugin “automatically” integrates with and extends AltUI by becoming a menu item in that UI:

ie AltUI --> More --> App Store

If I remember correctly the store might not work on Vera 3 because of problems along these lines:
SSL urls

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules