Cant connect when not on WiFi

Hi,

I can not connect to my Vera Plus when i’m not on WiFi. I have added my MIOS login and password. But it just says:

Gateway credentials
Incorrect username / password for unit: IPADDRESS, VERA_ID

I can login with my credential on get.vera.com.

Anybody know why?

Thanks

Regards

Claus

Hi Claus,

I had a similar issue when I just upgraded to VeraPlus U17. While I am still having issues with other parts of the app since I have upgraded the Vera, turning off the "Direct to Vera (no MIOS) did the trick for me and let me connect with WiFi or Cellular.

Good Luck,
Dave

Hi Dave,

That did not work for me :frowning:

But thanks anyway

Regards

Claus

I’m having the same problem. Are there any password ‘special characters’ that HomeWave doesn’t identify?

Maybe… regular stuff like @*&$%(@&$ should be ok. Maybe accented letters and such won’t work properly, actually I never tested that.

Problem resolved. Was experiencing issues with Vera and getvera.com password. Many thanks to the good folks at Vera Customer Care who reset the password which corrected the problem.

HomeWave is now connecting when not on WiFi.

Sorry to bump this old topic, but I have exactly the same issue coming back to Vera and HomeWave after 2 years or so of not using either. I can log in to getvera.com and connect to my unit… but I can’t connect to it via HomeWave when away from my WiFi. What URL (if any) needs to be added to the “URL (Internet)” field?

Thanks in advance…

You can leave the URL field empty. Also leave “Direct to Vera” off.

It might be the same password weirdness that other have experienced: the password will work on the getvera website but not in the API. Try the (free) app from Vera and see if you can connect with that. f that also fails when not on WiFi, reset your getvera password.

1 Like

That’s what it took–thanks!

Hi All, Upgraded from a Vera Lite to a Vera Plus with UI7 a few days ago. Like others HomeWave works fine locally, but I can’t connect remotely. Tried all kinds of settings. Can anyone who has this working tell me EXACTLY how you have your HomeWave app configured?? I see some talk about “special characters”, but getvera forces you to use one in your password. Any help appreciated. Jeff

Special characters like exclamation points are ok. I had some doubts about using different alphabets like Hebrew or Russian.

You do not need any special settings to connect remotely, leave everything at the default setting. If you were on UI5 previously, you will need to turn OFF the “UI5” switch in the Vera settings in the app. Check the following:

  • IP address: filled in
  • Device ID: filled in (if you upgraded from a different Vera, check if the device ID matched your current Vera)
  • Username and Password: filled in
  • URL: blank
  • Direct to Vera: Off
  • Ignore MIOS IP setting: Off
  • UI5 Firmware: Off
  • Authenticate locally: Off

There is something weird going on with the password in UI7 and the newer Getvera portal. There are cases where you can access the portal via the web but not with the API that apps use. To check if this is the case, install the free Vera app and see if you can connect remotely with that. If not: reset your Getvera password. Sounds like rubbish but a great many people have run into this problem after an upgrade.

I went though each item, still getting “Gateway credentials Incorrect username / password for unit: 10.0.1.10 5…[my serial#]”

For IP Address should I have my Vera Plus’ local IP address? Not “https://home.getvera.com/users/login”? I did try both, neither working for me. If my password has a “#” that should not cause an issue?

Thanks for the help.
Jeff

Ok, think I got it working! I changed the “#” in my password to something else for the '‘special character’. Now seems to be woking through a cell connection. Thanks again for the help, Jeff

Well, I have it working for my account, but I just added a “Other User” [“Basic User” level] for my girlfriend on her iPhone and having the same issue. I can log into the Vera account with this “Other User” on the web page and Vera iPhone app, but not with the HomeWave app.

I had the same issue my user credentials until I took the “#” out of the password, now I have the same issue with this account (that also does not use a “#” in its’ password).

hummm…this is frustrating.

PS If I log in on her iPhone with HomeWave with my user ID and Password it works, but not with her user ID and Password. Wondering if it has to have the Admin account type, and not be a Basic level account? Let me try that…

PPS Made her account an Admin account like mine, but didn’t change anything, still can’t log in by cell. Maybe “Other User” Accounts use a different way of logging in?

I don’t know if other accounts need something else to log in. The Vera app should use the same API as HomeWave, but it is a convoluted nasty API (at least the login part) and it’s been years since I have implemented it, perhaps there have been changes. I’ll create an extra user on my Vera and see what happens during login.

Yes, please let us know if you are able to add another user and log in Ok. Thanks.