DSC Stay Instant Arming ie. *9 + code

I see some older posts on this issue, but no resolutions yet.

I am looking for a way to arm the system with *9 + code from the plugin, scene or Imperihome.

Any thoughts?

I tried using the Advanced Scene editor to do Arm with Night and NightInstant, also tried QuickArm with Night and NightInstant, with and without pin codes. The alarm system always ends up in stay instant mode.

Got it working, no pin code required, I just made a scene with the following luup.

Change Device_ID to the correct ID and change sleep to a few seconds after you exit delay.

luup.call_action("urn:micasaverde-com:serviceId:AlarmPartition2",
                "RequestArmMode", 
                { State="Stay", PINCode="0" } , Device_ID)

luup.sleep(35000)

luup.call_action("urn:micasaverde-com:serviceId:DSCAlarmPanel1",
                 "SendCommand",
                 {Command = "071", Data="1#*9#"}, Device_ID)

If you are old like me … you will remember the “Lost in Space” sitcom.

In that case you will remember:
Danger Will Robinson … Danger

See: https://www.youtube.com/watch?v=RG0ochx16Dg

In any case NEVER use luup.sleep with a value more than a 2000. This can cause Vera to Reboot.
You can do this with a NORMAL scene with a delayed action.

[quote=“RichardTSchaefer, post:4, topic:197074”]If you are old like me … you will remember the “Lost in Space” sitcom.

In that case you will remember:
Danger Will Robinson … Danger

See: https://www.youtube.com/watch?v=RG0ochx16Dg

In any case NEVER use luup.sleep with a value more than a 2000. This can cause Vera to Reboot.
You can do this with a NORMAL scene with a delayed action.[/quote]

Ugh… I tried with a normal scene, but couldn’t figure out how to send *9 to the DSC panel.

I thought I would have to wait until the exit delay was over to send *9, I just changed the sleep to 2000 and it still works.

Gibby did you get this working reliably?
I also would like to arm my alarm in stay without the entry delay. (*9)

[quote=“Jamr, post:7, topic:197074”]Gibby did you get this working reliably?
I also would like to arm my alarm in stay without the entry delay. (*9)[/quote]

Yep, I have been using this luup code in a scene for over a year with no issues.

[code]luup.call_action(“urn:micasaverde-com:serviceId:AlarmPartition2”,
“RequestArmMode”,
{ State=“Stay”, PINCode=“0” } , 97)

luup.sleep(2000)

luup.call_action(“urn:micasaverde-com:serviceId:DSCAlarmPanel1”,
“SendCommand”,
{Command = “071”, Data=“1#*9#”}, 90)[/code]

Thanks. I will try it.

I use a basic scene and chose “Also, execute the following Luup code:”
Then I add it to a dashboard in Imperihome and set it as a protected action so it does get trigger from a phone accidentally.

I struggled with this same thing in years past on UI5. I am starting over again with UI7 and have a more elegant solution to *9 instant arming without a pin code.

Basically you need to first arm in stay mode, wait for the exit delay to finish, then you can transition into *9 instant(no entry delay) without entering a code. This script will vary based on your exit delay time, but my exit delay is set to 90 seconds since I have the silent delay option selected on my CP-01 panel.

--Send Stay Arm Command for Partition 1
luup.call_action("urn:micasaverde-com:serviceId:DSCAlarmPanel1","SendCommand", {Command = "031", Data="1"}, 11)

--Wait 100 seconds(10 seconds past 90 second exit delay)
luup.call_delay( 'send_cmd', 100)

function send_cmd()
   --Send *9 Instant Arm Command for Partition 1
   luup.call_action("urn:micasaverde-com:serviceId:DSCAlarmPanel1", "SendCommand", {Command = "032", Data="1"}, 11)
end

Hope this post helps someone out in the future. I know I fought this one years ago. My solution was to send the code with the “200” command after the “32” but I hated having my code displayed and stored in plain text.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules