Ecobee App Routinely Stops Working

For the past 3 months, just about every month I have to uninstall then re-install the ecobee app. The ecobee symbol on the UI goes gray and the temperature stop updating accurately with the ecobee thermostat. Uninstalling and re-installing is the only fix for this. Please fix this bug in the app.

Hello there, the ecobee plugin is not a mios plugin. It is community supported. Member Watou was it’s original author for UI5 and I helped migrating it to UI7 and then to openLuup.
What version of the plugin are you using, on what vera? I have run the plugin for years and have never had to reinstall it. Not even once.
One likely possibility I can see is that it is caused by your vera reloading the luup engine while the key is being renewed by the server. Your vera would then have an outdated security key upon reload. This is a stability problem with your vera and can’t be fixed by the plugin. It is a security feature of the ecobee API we cannot circumvent and can only be fixed by eliminating the reboots of your vera.
If you can recover only be re-installing the plugin, it would mean that your vera is dying: You have data corruption issues causing the ecobee plugin files to get corrupted.

You were correct. My VeraSecure bricked a few days after this post. Have a replacement seems to be working fine so far.

Sorry to hear this… unfortunately not uncommon as you may see from my other posts in the general section. The vera hardware and OS setup is not really set correctly by design to do what mios has set for it to do… It is prone to very premature nand flash failure and data corruption by locating all of its frequently used and overwritten files in a tiny partition while most of the flash chip is not allocated or unused. To circumvent this, I would recommend extrooting. (can do a search in the general section). If you run out of space and do not have an external drive, you could look at also my other script about the vera flash partitioning.

Thanks for the advice. I would expect to have to “learn” programming and how to do that you listed had I purchased something like a Raspberry Pi and went the cheap route, unfortunately if this is required with this $300 VeraSecure, I will begin looking at different home automation controllers as I’m not interested in anything but plug and play and “thought” with this higher priced controller it would be that. Especially dissatisfied with the lack of scene set up capabilities without learning how to use the PLEG nonsense, again something that should already be incorporated as plug and play. Plus the first controller only lasted 4 months and from what I’m reading here, they brick ALOT, and Vera waits until they receive your defective one before sending a replacement leaving you without home security for 2 weeks, not acceptable from my needs.

Yeah, I am with you. Sadly the vera is, even at this price not quite a general end user product. It has a steep learning curve with a lot of tinkering needed to make it work if you want more than the very basic functionalities of a couple of light switches. For many of us it has become a hobby just to maintain it and to grow its capabilities.

Funny coincidence, I just got done posting in the “Ecobee 3 Plugin --> How long does a PIN last?” (http://forum.micasaverde.com/index.php/topic,59088.0.html), about how often I now have to reset the PIN in the ecobee plug-in.

While I’m glad to see I’m not the only one, I am disheartened as to why this might be happening, especially if it’s a sign of greater problems to come. I’d like to think it’s just my Vera Plus rebooting every day (which it must be doing, considering how often I receive “Down” and “Up” notifications).

Thanks for the detailed info!

I’m back to ask if anyone knows a way to convince the Ecobee 3 App to “forget” a thermostat that is no longer in use. I’ve tried several times to “DELETE DEVICE” for each of the 7 or so devices created for Thermostat #2 (which itself is no longer connected, so has no graceful way to be unpaired from Vera).

Yet all the devices keep popping back up! Is there a more elegant/standard way to get the app to “forget” a device and its children devices? (I would uninstall, but I want to continue using the app with Thermostat #1, still installed and functioning – although the app seems not to control it any longer, boo.)

THANKS! - Libra

Puzzling… I have no idea why this would be. Is the thermostat still on your ecobee account by any chance? The ecobee plugin creates child devices based on what is reported to it by the API.

Yes, you are on the right track. (A) The unwanted thermostat indeed was still listed on my ecobee account. (B) At first, I was unable to remove it from said account, but ecobee instructed me how (namely, login to your web portal on www.ecobee.com, then select the profile button in the top right corner > My Account > unregister thermostat > select the thermostat you wish to unregister).

© Meanwhile, I submitted a Customer Care ticket with Vera support, and they wrote back the following:

"There are two different ways to get rid of the child devices:

  1. You may delete the Ecobee plug-in and then reinstall it, configuring it with the one thermostat you are actually using.
  2. Hide the child devices, since they cannot be deleted permanently unless you remove the Ecobee plug-in."

I should write back Vera tech support and let them know about option (B) above as a third approach, which appears to have worked successfully for me. I was able to manually “Delete Device” on all 7 orphaned devices that belonged to the ecobee plug-in, and they have not since returned.

Sorry to have troubled everyone for such a seemingly simple thing. (Ain’t that the way it always is around here??)

  • Libra

Has anyone else seen issues with Ecobee receiving the “ContinuousOn” variable for the “SetMode” command? It should be setting the fan mode to always on, but every time I run it (through PLEG, Reactor, Scene, etc.) it just sets a temperature holds and the fan mode stays on Auto.

I reached out to Ecobee and they of course were zero help and told me to get help from the developer of the plugin :slight_smile:

Any ideas?!

UPDATE: instead of deleting post in case anyone else has run into this…
You must clear your hold (“Home”) in my case, as Home has a fan setting, so it kept overriding my manual fan setting. I changed my actions to start with a “resumeprogram” to clear that, then set hvacmode to “Off”, then fanmode to “ContinuousOn” and all is working as expected

© 2019 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy