Ecobee Plugin Update

Thanks for reporting back. Let us know if you run into anything else. Pretty impressive what on can do with a phone these days…

1 Like

itty-bitty question - it’s now showing in Celsius - setting to flip somewhere? From the documentation it should be mostly automatic, so maybe something in the ecobee developer stuff?

It should pick up the unit from your vera’s settings. If it cannot find it, it will default to Celsius. I did not touch this portion of the original code. Do you have your vera setup that way?
I actually don’t like the original code. I am going to make some changes to make is simpler.

Please try 2.21-rc1 but make sure that the temperature scale is already set on the vera.

1 Like

Hey sorry to jump in here with questions so late in the thread, but is there a way to update the Plugin from the AltUI Plugin screen?

yes, assuming you installed in from the AltAppStore and not from mios, you can upgrade to the latest version by typing “master” in the update field and hit the upgrade button.

No unfortunately it was installed from the Vera UI. This was before IO started using AltUI.

In that case you will have to do it manually I am afraid by uploading the files to the vera through SCP/SFTP.

Ok, is there a step by step link kicking around somewhere? Complicated?

Ok sorry, reading the Github page now and see a guide. Will come back if I run into issues.

Ok, sorry gents, raising the white flag on this. I got lost as soon as it was mentioned to copy things to folders on the Vera (I have no idea where any of that is).

Is there an easier way to do this? I’d be willing to go backwards if I have to and uninstall and re-add ecobee to the Vera.

Cheers,

Easiest way is to uninstall the one from the mios repo and install from the alt app store though I am a bit worried now that I think about it that the altappstore will not move the icons to the new designated plugin icon folder on the vera.
If you want to have better control, I think it is better you learn about SCP/SFTP drop the files appropriately there.

Ok, how do I get the SSH password for the Vera? It isn’t my login password. The password on the bottom of the vera isn’t working either.

It should be the password at the bottom of the vera.

Ok, just to make sure I’m not missing anything, in Terminal (I’m using MacOS), I type ssh 192.168.0.101 (my veras local IP). and then when it prompts me for a password I type the password on the bottom of the Vera.

Yes this should work.

Oh boy, this isn’t working. It is impossible to change this password outside of a command line, correct?

http://wiki.micasaverde.com/index.php/Logon_Vera_SSH

Sorry just don’t want to paraphrase.

ok I had to type ssh root (my ip address). That gets me into the Vera. Thanks. I’ll try to figure some of it on my own from here.

1 Like

per my other post, you need to specify root or the terminal will present your logged on id.

Just checked on a box at home. It is still possible, in Catalina, to su to root in a terminal, but you really don’t want to :slight_smile:
C

yeah Vera was set to F - but I just uploaded the v2.12 of L_Ecobee1.lua and it’s showing F now so you must have fixed it! Thanks again!!

1 Like

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy