Failed to call fmipservice device

Hi there,
I have had this app working for quite some time now, but just recently one device is displaying the following error:
Failed to call fmipservice device
And stating that to check credentials. I have successfully logged into iCloud to verify the creds and also checked finished my iPhone is enabled, in fact I don’t think anything has changed. Any idea what might case this issue on one of my device but the other device and app is working fine?

Happens sometime,probably some Vera resource limits . I have this rarely and a full Vera reboot fixed it every time.

Still getting the same error. I have now removed all iPhone locator devices and also uninstalled the app, rebooted and reinstalled but it is still setting the same error. Version 2.48

If you are sure your credentials are ok ( check in the settings tab maybe ) then the next step is enable debug mode , the reload lump, let it run 5 min and send me the log by private email and the device number that fails.
Thx

ok , I think I have found something

I can replicate the issue now and it seems that apple changed their certificate on July 2019 25th for https://fmipmobile.icloud.com/fmipservice/device/ but unfortunately the CA root that signs it is self signed or unknown. so https.request() is failing

I can repro the problem using postman , it fails and it works if I disable the SSL certificate verification

so now the question is how to disable certificate validation on https.request() , I have not find yet. if anybody knows, I am interested …

1 Like

I have the fix :slight_smile:

The 2.50 version will fix this, it is right now available on https://github.com/amg0/IPhoneLocator and I will push to Vera App Store in a little while when I get confirmation that it works ok. it certainly fixed the issue for me

thx for reporting it

2 Likes

Thanks, this seems to of fixed the authentication error but now I have “google reported an error”

I think I’m having the same issues… how do I use the v2.50 fix now rather than wait for it to be pushed to the Vera App Store?

@PrincessCleavage
You can Get the files from github and upload them using ui7 apps file upload

That should be different , so same procedure : debug mode +logs.

Looks like I just had to add my google map key as when troubleshooting I deleted and reinstalled the app

Ok ! So all good now ?

Yes thanks, working again as expected

Hello,
Same problem, resolve with the new version V2.50
Thank you

Hi,
The same problem, but it is not resolved with 2.50. I’m on VeraLite v1.7.1040.

I went to Github and I don’t see a simple way to download the complete lua file.
I can only edit the old lua file, and I must had made a mistake since the only thing that has changed is the version number to 2.50

Is there a link where I can download the complete fixed 2.50 lua file?
Thanks

Thanks. Is this going to be on the Plugin store any time soon?

Cheers

C

Yes it is pending approval

Triffic. I might wait
Cheers

C