Fibaro 3 in 1 Sensor Ghost devices keep appearing

I have had 5 Fibaro sensors on my system working without any issues apart from battery level not being reported correctly
Installed a new one after the new firmware update and a ghost device appears with this description

_GET_LANG(generic_sensor,sensor) 2 I have logged a ticket but nothing has been fixed so far, I was advised to reset and re add the devices which I have done (along with one of the older sensors ) and now that is also adding a ghost device so that rules out faulty sensors and would seem to point to a problem with the firmware update?

Anyone know how to fix this this extremely annoying problem
thanks
Nobber

I had the same problem with some qubino devices. I just hide the devices. You can do that by adding:
luup.attr_set(“invisible”,“1”,) in the startup LUA section.

(More recently i am experimenting with the “NoChildren” variable on my test unit.This. It works but i want to test it more)

Ok thanks, I’ll give that a try, but I think support already tried that and it came back

If they already tried that then the luup code should be present in de startup section. You can check that easily.

Ok I have added the code for all three devices so they are now hidden, thanks

But there is obviously still a problem I just cant see it now :wink: out of sight out of mind I guess, hopefully nothing more serious is going on, thanks

Hahah Good one!! So I added the three devices to the Lua start up and they disappeared nice

until today of course and new ghost devices have been created with different ids FFS!

Devices are from the same parent?

Hello yes they are

Ok, just to be sure;

  • The previous hidden devices are still hidden?
  • The new ghost devices have the same parent as the previous hidden ghost devices?

Yes they do

also these Fibaro report battery level at 100% all the time…anyone know how to get them to report correctly like the Fibaro smoke detectors do, thanks

I have the same issue with the battery level. A fix/solution would be great. Now I know the battery is empty because the device isn’t working any more (can’t be find)

I have also problems with ghost devices. Both the Fibaro one mentioned here and for Movement Sensors. I have been in contact with support but they did not put very much effort into trying to solve it. It was mentioned somewhere in the old forum that turning off Auto Configuration prevented the ghosts from re-appearing. You will then have to remove the device and include it again and do a manual configuration. It worked for me for NEARLY all the ghosts.

Oh no, just stumbled on this topic. I have exactly the same issue… I opened a support case, received the following reply but this did not help. the problems instantly started after the last firmware update.

I AM SURE THIS PROBLEM IS INTRODUCED SINCE LAST FIRMWARE UPDATE

VERA: Sorry for the late answer, I wasn’t in the office

You can change the autoconfigure value again to “Use default Value” --> “Configure node right now” --> “Wake up the sensor” --> “Wait until the device creates the children” --> Change the autoconfigure to “No” again so it won’t create any additional phantom device ,

ME: I have done exactly what you described below. An I may not swear, but F. Always something with this system. Now I only have a master device and no childs at all anymore à all logic broken again. I don’t want to have vera in support mode because everytime you (not you personally) went in something else is broken. What can I do? Is this device not supported in the right way anymore? These problems arised after the latest firmware. Please help me out despite I am very annoyed by this situation (as you may imagine).

VERA: The sensor is probably trying to reconfigure for some reason, you can go to the device settings and change the autoconfigure value to “no” after that you can go to advanced–>Commands–>Reconfigure node and that should delete the phantom device, you will need to wake up the device after that as well

ME: Hello, I have included the 3 motion sensors freshly. But now on one of them I have ghost devices appering with a higher device ID. _GET_LANG(generic_sensor,sensor) 1 Device type: FGMS-001 (v3.2) What is wrong again here?

ME: It did not work despite. I have taken the bite and reincluded the devices. Thank you for the support.

VERA: I have done some work on the controller, please try to wake up the sensors again, if that doesn’t work, I’m afraid you are going to need to un-pair and re add the devices as there is not much else I can do from my end, I’m sorry if these causes you any inconvinience,

VERA: Sorry for the late answer, I was out for the weekend, Can you please re-enable the tech support access?

ME: Ok thank you. The motion sensors still don’t work… what is the problem?

VERA: I honestly don’t remember to have uploaded a backup to your controller, I just made changes to the three sensors, but either way, if something that I did revert your settings somehow I deeply apologize, on the other hand, I always make a backup before doing any change to the controllers so you should be able to recover your settings, Attached is said backup,

ME: Doorsensor seems to work, although I hade to physically “shake” it to force tamper detection and now it shows motion.

ME: So I now just woke up “Tuin V Sensor Beweging Parkeerplaats” and immediately get Can’t Detect Device.

ME: Hi and thank you for the support till so far. I will wake them in a few hours. But what happened overnight!?!?! I have added a faulty shutter switch yesterday and installed a qubinu flush shutter and changed all my scenes, logics, etc. TOOK ME A FREAKIG LOT OF TIME! And now I see this devices is gone, logic is gone and the old device (deuwi) is back? Have you placed back an old backup? I may not swear.

VERA: I have done some work on the controller, Can you please wake up the two motion sensors? I think the door sensor should be working now, but if it’s not then wake up the device as well,

ME: Thank you for the support. The Sensor HZ Deur Motion with 1% is detecting motion but says Waiting for wakeup to configure device. The other 2 do nothing. All 3 have full and new batteries.

VERA: Can you please test the devices one more time? Let me know if they are working properly now

VERA: I’ve escalated your issue to my colleagues from a higher level. Please leave Techincal Support enabled - we’ll keep you posted as soon as we have a resolution on this matter. Thank you for your understanding and patience

ME: Hi, ofcourse I have done that… not helping. Though I do see that vera sees tampering (shaking) with device…

VERA: Can you please try bringing over your sensors close to the Vera controller and waking them all up by pressing the z-wave button on the sensor really fast a couple of times? I notice one of the sensors says “Waiting for wakeup to configure device” and signals that the battery is down to 1%. Can you please replace the battery on this device and after that bring it close to the unit and wake it up as well. Let me know if the problem persists.

ME: Hello, Since last firmware update all of my 3 sensors are not working anymore. It is directly linkable to the upgrade all was fine before.FGMS-001 not working anymore in 7.29

Wow, Impressed with your patience & persistence … I gave up and reset the devices, reinstalled, then when it created those ghost devices I just moved them (not the main sensor and the other 2 child devices) into a room called zwave…they still appear down there but right at the bottom, so out of site out of mind :wink:

When i search the forum on FGMS I see a lot of complaints about device compatibility. I think Vera should dive in to this. I just sent another mail to support:

Hello Jose,

Can you please escalate this issue?

I have MAJOR issues with this device since the latest firmware update. It is unusable now.

Got: Can’t detect device

Then I deleted it and tried to reinclude:

Z-Wave device 1076 ERROR: Failed to setup security. Please exclude this device from your system, and then include again. Waiting for wakeup to configure device

Add/Remove : Exchanging security keys…

Add/Remove: ERROR Cannot send network key

Waiting for wake up to configure device

And so on

I am Pairing next to vera

Nothing helps, including as generic device, including as FGMS-001 v3.2, excluding, resetting device (yellow light)

I am sure something is wrong with this device integration in the latest firmware.

when will this be solved?

It’s not exactly a ghost sensor … it’s the shock/tamper sensor. When I shake the sensor enough to get the red/white/blue flashing, I see a value in the “GET_LANG” sensor – so far it’s always a value of 11. Then it goes back to zero.

What is seems that changed in the latest firmware is support for this sensor feature. With the new firmware, I noticed that every one of my FGMS001’s (I have 20 of them paired with my VeraSecure) was throwing an error in the log file like this:

01 06/07/19 19:29:34.176 ZWaveNode::IsValidSensorType type 7 in cc 0030 not supported, only supporting: 31-01,02,03,0A,14,1B <0x7663f520>
01 06/07/19 19:29:34.176 ZWaveNode::ZWaveNode::FindChildSensor node 147 device 355 got incorrect type 7 <0x7663f520>

I un-paired/re-paired one of them and found that the “ghost” device was the shock sensor, and it no longer created the above error.

So I am actually in the process of un-pairing/re-pairing all of my FGMS001’s. I’ve only had a couple that have given me security problems when trying to re-pair. I found that re-booting the controller and then trying again worked successfully. Note that after I un-pair the FGMS001, I do the factory reset on it before trying to re-pair. (Hold button down until it glows yellow, release then press/release button again while it is still yellow. A red flash signals factory reset complete).

I find that Vera include process is also creating a fifth device on the FGMS001 which is hidden, but has a name which includes “seismic” in the default name.

Hello
Glad it works for you., I tried to unpair reset etc etc but the “shock sensor” re appears…

so still waiting for Vera to fix

Thanks

It looks like I’m the only person who thought it was a “feature” when that additional sensor device appeared. There I was thanking Vera for making my 3-in-1 sensors into a 4-in-1 by giving me access to the accelerometers in the FGMS001 that I didn’t have before.

yes nice take on it :wink: shame Vera didn’t realise what they had done coz they opened a support ticket when it was first notified to them by several users :wink: