Fibaro Single Switch 2, Can't Detect Device.


I’m on a clean install on a Vera Plus and upgraded the Firmware to the latest version this morning (1.7.3015)

I have about 30 devices installed and everything is working fine except my latest addition of a Fibaro Single Switch 2 (FGS-213 ZW5 v3.2) that constantly reports “Can’t detect device”.

When I flip the switch on or off it works and Vera says that the device is responding again… then a couple of minutes later it says “Can’t detect device”.

I read in a thread that setting CommFailure variable to 0 would help but this does nothing.

Anybody got a solution for this? It’s highly annoying when Vera says that a device isn’t working when it clearly is…

Thanks in advance for any help solving this issue!

I should probably add that the device has never been working for me, not on the old firmware or the new…

I have the exact same problem with the Fibaro Single Switches that I have. They work when controlling them, but go into “Can’t Detect Device” mode shortly after. If any one has found a solution to this, please share it here.

same thing here. I have 2 of the single switches, one is ok, the other is on “can’t detect” most of the time

Hi there, to my knowledge, most of the issues with Fibaro switches and dimmers should be resolved in the latest betas.

Please check with our support team to see if there are still any recurrent bugs open with this device and if it’s something else that needs to be reported and resolved.

I have the same problem with all the FGS-213 switches.

Me too, same issue…

Hi I just upgraded my Vera Lite to the 7.0.23b (from 7.0.22) yesterday evening
My Fibaro FGS-213 still acts the same. I can control it (on/off) and it returns power consumption,
but it keeps saying “Can’t Detect Device”

An upgrade to 7.0.23 did not help. Still the same.


Same here :frowning:

Assume you’ve tried removing it, and adding it back in? Pain I know, but sometimes that can help with devices having issues…

Hi. Did just upgrade to 1.7.1017 (7.0.25) firmware on my Vera Lite.
The result is still the same.
I can control light on/off and I receive power readout from the switch.
But the poll algorithm “can’t detect device”.
Could it be because the poll requires Z-Wave+ ?


Same problem here. Running on Vera Plus fw 1.7.3501.

I had the same problem on a VeraLite, but I recently bought the Plus. Upgraded the firmware first and then included every unit from scratch. Still the same behavior, works like intended but get the annoying error message.

Exact same problem here. Just installed a single switch 2 on My Vera edge running latest production firmware, and same issue. Works fine, reports power, but getting error message. I guess it?s something to do with fact adding as generic zwave device rather than a specific named device but don?t have option as it isn?t there. I did wonder if adding as a fibaro double switch would work and get the right XML files that have specific fibaro settings in them maybe seeing as Vera have done the work on the double switch.
I also hate the fact it installs three devices for one switch but that isn?t Vera?s fault.

Probably why this only has a compatibility of 8.

Any tips appreciated

I just installed a new Fibaro Double Switch and had no problems with that device.

However after the last update the “Can’t detect device” message came back on a Fibaro Dimmer 2 device.

To hide the message, I change Automatically Configure to No.

thanks CW-KID

that did work. I noticed on a few other devices I have like the Aeotec Smart Plug 6, it is setup by default with “Poll this node at most once every “0” seconds”

So I tried that for the Single Switch, and that stopped the message. Of course now vera isn’t polling the device, but I have no idea what that does anyway, and now I don’t get the message.

Either way message is gone. and everything still works.

I think your better to set Automatically Configure to No on the device rather than have polling set to 0.

I have a FGS-213 which gave me troubles on a Vera Lite with UI7 (1.7.30) stating “Can’t detect device”. I set the “automatically configure” to “No” in the settings sub menu. I didn’t change anything else… Polling interval is still 60s.

The same problem i have with this FGS 213