help with aeotec water sensor 6 zw122

apologies in advance if this is in the wrong place or has been answered (I did search)

I have verahome and hoped to add the aeotec water sensor to it - i suspect i should have check the compatibility list better before I bought it :slight_smile:

I loaded it as the smart switch 6 (device 112) and some of the sensors work ok and I get “leak detected” message in the log when there is water, but is obviously is not the right device and there is no way I have found to trigger a scene when the leak is detected (as vera thinks it is a switch)

Any pointers greatly appreciated

Go in the device screen under advanced and tell us what you see in the device category num, subcategory num, device json and device file. It is likely that these were configured wrong by the vera.


when I added it I added as a 112 rather than 122 (did not notice originally and there is no 122 water sensor in the database)
device category number: 11
device subcategory number: 0
device json: D_GenericIO1.json
device file: D_GenericIO1.xml

it creates devices for each of the 6 sensors (the temp works correctly, the others just come up as generic io and display a switch that does nothing (no great surprise I guess). It strange in that when it does detect water the correct alert gets added in the log

any ideas appreciated

I do not have this specific flood/water sensor but I have a few of a different brand and have observed the same absurd behavior from the vera trying to automate too much of the device configuration in the wrong manner. My advice would be the following and will take a few tries and errors:

  1. Remove all of such sensors from the system by unpairing them.
  2. Install ALTUI
  3. Pair them one at a time with a browser page on ALTUI and one on the UI.
  4. Once the device is paired go as fast as you can on the vera UI to the generic device and under settings, change the automatically configure setting to “no”
  5. The vera should reload Luup and hopefully the device will still be there with no child device. If it isn’t you will have to use ALTUI and go to that device and insert/replace the existing attributes with the following:

device_file: D_FloodSensor1.xml
device_json: D_FloodSensor1.json
category_num: 4
subcategory_num: 2
device_type: urn:schemas-micasaverde-com:device:FloodSensor:1

If one of the attributes is missing (not too surprising with the last 2 firmware versions) let me know, we will need to do it through lua code.

  1. If Luup has not reloaded, reload the luup engine. Now test your sensor. It should work without it having to create a child device. If you have a child device and decide to use it as your main device (this was my workaround), it is likely that you will notice that it will untrip itself after 10s. Some bug in the vera causes it to think that it is a motion sensor. Then after a few luup reloads and reconfiguration, the child device will stop tripping altogether so having a child device is not the way to go.

Thanks very much for the suggestions, very helpful

I did follow them and in the main seems to work at the moment - the only issue I have is that in the vera ui it has the red “waiting for wakeup to configure device” - even when I manually wake the sensor and now left it overnight it does not update/clear. Any ideas?

on the positive side - I can now create a scene based on water being detected and it does what I want!


Are you seeing the “waiting for device to wakeup” in the child device or in the main device (you can verify by the id of the parent, it is 1 or 2, it is your zwave network so it is the main device, if it is the child device, the parent id will be the id of the main device).

If it is the child device, you can safely delete it by clicking the garbage bin at the bottom right. The device won’t wake up since it doesn’t exists. The parameters/variables are already updated on the main device. If it is the main device, this would be strange. I would have to think about it.

it is the main device (the parentid =1 ) - I will try removing and adding it again (although did do this a few times yesterday). I assume when I update the device/category details per you email it does not matter whether I use the vera ui or the ALTUI - I did do both ways and have also tried restarting luup and restarting the whole unit

I seem to have it up and running now - some strange behaviors -
If I tried to delete any of the generic child devices, the who device was removed
I also needed to leave the automatically configure to “use default behavior” - if I try and change this then I get the “waiting for wakeup to configure device” problem

So thank-you very much for your pointers - I am happy that it is now working.

now only if I can have a leak to make all the effort worthwhile!

Not sure you want to be looking forward to a leak… :o

Glad you got it working though.


Were you able to get the temperature sensor to work for the device?

I received the ZW122 for Christmas and using your configuration parameters have been able to get water sensor and temperature working. At least testing sensor, when water was is present, I have received alert. There is a value for temp, although off about 5 degrees from other devices.

I see 4 devices, 1 water, 1 temp, 1 _Generic IO and 1 _Generic IO1 device. Both generics have on/off displayed in GUI. I know that sensor has a vibration/tamper sensor, which I can only assume that is configured through on of the Generic devices. If so, would anyone have or post configuration parameters for device?

Anyone know what the second _Generic device would be?

Any assistance you can provide should be greatly appreciated.