Help with the integration of the Fibaro FGBS321 universal sensor

I had an FGBS321 sensor with four temperature sensors attached. At one point one of the sensors displays the same temperature. I changed the temperature sensor, excluded FGBS321 and then included it again. It didn’t work anymore. I thought the FGBS321 was defective so I bought a new one. In Vera I have the following configuration, whether I include FGBS321 with temperature sensors or without temperature sensors.

The same configuration appears on the old universal sensor.
I need help

No idea why it’s not working but yes, include it with the sensors. The manual is very specific.

But, the relationship between Vera and these things is flakey as hell. I’ve lost count of the times my temperature sensors have stopped updating, and the only answer is to exclude and re-include :frowning:

I’d go for an exclude and factory reset.

C

I have two Fibaro Universal Binary sensors in my summer cottage. Both with two DS18B20 temperature sensors. Temperature sensors (normally only one) have stopped working about twice a year. Before I have to configure Binary sensors to get temperature sensors to work again (tedious job because the ids of the temperature sensors shift/changes and I have to correct the ids back to old to get my scenes working).

Three days ago I find some new information how to add Fibaro Smart implant to Vera and there was instructions how to do it (Fibaro Smart Implant Instructions to configure binary inputs). I god idea to check if I can correct my problems using those instructions. Both my Binary sensors have one temperature channel not updating. I checked the MultiChCapabilites values (Advance/Variables-page) and found that there were differences between those two sensors and some odd lines.

I edited the values like this (don’t add text with parantsis):

1,32,1,48,156, (e1 IN1)

2,32,1,48,156, (e2 IN2)

3,33,1,49, (e3 Temperature sensor1)

4,33,1,49, (e4 Temperature sensor2)

if you have four sensors then (probably)

5,33,1,49, (e5 Temperature sensor3)

6,33,1,49, (e6 Temperature sensor4)

After reloading the luup both Binary sensors started to work again and temperature sensors where okay (and they are still working). Best part is that you can do this also remotely. Don’t need to be at the cottage to correct the situation and no Id shifting).

(In the same way I also managed to correct my AeoTec HEM2 energy meters with 3 clamps that have lost one energy sensor clamp to update values. In this case MultiChCapabilites value should be:

1,33,1,49,50,

2,33,1,49,50,

3,33,1,49,50,

)

1 Like

This might be really useful as I have the same issue with the FGBS321. I’m afraid I don’t quite follow your instructions, tough. Can you clarify for me?

Thanks

C

Find your Binary Sensor master/main device, click arrow > (settings). Go to page Advanced and to flab Variables.

Find field MultiChCapabilities
MultiChCapabilities
Check values and if you have to correct them click Edit. After you have edited values save them and reload luup.

That is how I do it…

Thanks, I seem to have extra numbers:

1,32,1,48,156, 2,32,1,48,156, 3,33,1,49, 4,33,1,49, 5,33,1,49, 6,33,1,49, 4,4 4,4 3,3 3,3

So do we think delete ’ 4,4 4,4 3,3 3,3’

Any idea what they might be?

Cheers!

C

I think that they are trash lines. I had also that kind of trash lines in the end of the list in both binary sensors. One had in the end 3,0 (or something) and when I removed that line, temperature sensor 1 started to work again. The other binary sensor had two similar lines in the end 4,0 and 4,0 (or something) and when I removed those line temperature sensor 2 started to work again.

So I am quite sure you have to delete those 2 lines. (But for the safety copy your settings before removing those trash lines)

1 Like

Thanks

Sadly no difference in terms of the temperature reporting on the two temperature sensors.

I’ve seen this before and added the Capabilities that were missing from the failed sensors:

211,156,0,4,33,1,L,R,B,RS,|49,

But there are lots more variables in the failed sensors including:
ConfiguredAssoc RECONFIG

Which seems very wrong. I’m minded to delete that variable as well. Any thoughts?

C

If I remember right also my failed temperature sensor had empty Capabilities field but after correcting the master/main device MultiChcapabilities field and restarted the luup, temperature sensor started to work and also the Capabilities field was updated (I didn’t have to correct that manually)

Remember to restart luup after you have modified MultiChcapabilities field. If you don’t do that then temperature sensor is not working

Thanks. I did restart, or thought I did.

I’ve been messing around with some other stuff, and had a restart. One of the failed sensors is working! Thanks so much!

And the other one now! Vera support could do with knowing this!

C

I have two motion sensors and four temperature sensors. Nothing works.

Is this okay?
image

Before I change the sensor with a new one, everything works.
I changed it because a temperature sensor didn’t work. Now either I use the new universal sensor or the old one the same result.

Looks right, what do you mean ‘nothing works’?

C

I get this:

image

So you’ve got all the correct sensors in there. You have temperature sensors connected ok?

Might be worth going into one of the temp sensors to set the parameters as I did above.

C

Yes, everything is correct. Whether sensors are connected or not, so it appears in Vera.

Sorry, I’m probably out then :frowning:

C

After I updated to 7.31 beta, after Vera restarted … the Fibaro universal sensor works.

1 Like

@jukka sadly everything has stopped again. Can you post all your settings for the Universal sensor and one of the temp sensors for me?

Cheers

C

Edited: Just polled the master and things seem to be back

Do I understand that it works?
Do you still need settings?

It does seem to be working, thanks. The settings would be useful however as the sensors all have different ones!

Cheers

C

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy