Homebridge Ubuntu on HyperV

Installed Homebridge on Ubuntu running as a VM/HyperV on Windows 2016. Homebridge is running but I can’t add it to HomeKit. I get the following error: Couldn’t add Homebridge. Currently using a VeraLite. Ordered a VeraPlus but I wanted to try to get HomeBridge up and running.

Not sure about home bridge. I have been personally using this:

Change username or pin in config.json by increasing last digit by one and try to add again, usually fixes most pairing issues.

Did that result is the same. Homekit sees the HomeBridge but will not add it.

Have you tried to disable firewalls on host and vm as troubleshooting?

thanks disabling the Firewall on Ubuntu worked. now I need to figure out why there is not option under automation to add a new automation.

You need an Apple TV or iPad as a home hub for automations and remote access.

Ok thanks.

Stuck on one more issue. Can’t see my garage door opener. The Homebridge-vera lib is missing garage_door.js

How can I get this file added?

Yes, the npm install doesn’t contain the latest push to github with the garage_door.js
I did a workaround and modified functions.js to use lock.js on a specified subcategory a long time ago and that is still working for me so a haven’t bothered to update the lib.

I’m no npm guru but I think you need to install the vera plugin from the github repo with “npm install https://github.com/damianxd/homebridge-vera.git”.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules