Homebridge-vera TypeError

I have the following error in ubuntu 18.04 and 20.04 after detecting correctly all the vera devices. And after showing the QR it crashes. My config.json is very simple:
{
“bridge”: {
“name”: “Homebridge”,
“pin”: “987-54-453”,
“port”: 51826,
“username”: “CD:23:2D:D3:CE:30”
},
“accessories”: [],
“platforms”: [{
“platform”: “Vera”,
“name”: “Vera”,
“veraIP”: “192.168.1.50”
}]
}
Can you help me, in detecting what is causing the error? Thank you in advance.
The error is repeated 3 times:

[29/12/2020 20:30:02] TypeError: Cannot read property ‘level’ of undefined
at Object.module.getVariable (/usr/local/lib/node_modules/homebridge-vera/lib/functions.js:29:22)
at map.forEach (/usr/local/lib/node_modules/homebridge-vera/lib/functions.js:34:40)
at Array.forEach ()
at Timeout._onTimeout (/usr/local/lib/node_modules/homebridge-vera/lib/functions.js:33:15)
at ontimeout (timers.js:436:11)
at tryOnTimeout (timers.js:300:5)
at listOnTimeout (timers.js:263:5)
at Timer.processTimers (timers.js:223:10)

It could be caused by duplicate id’s, when a scene and a device have the same id.
Add "ignorescenes":true to the config to see if that resolves the issue.

Can you post the home bridge log entries for the discovered devices? It looks like it is trying to process a device that has a ‘level’ property. If we can figure out which device is causing the issue, you can add it to the ignoreDevices section of the config.json.

Thank you but it didn’t work.

Debug Homebridge.pdf (38.0 KB)
Thank you for your support. Attached you can find a pdf with the logs, but I still can’t see which device causes the problem.

A quick and dirty approach is to add all devices to ignoreDevices and introduse them one by one to find the one causing the problem.

Ok, you are running version 0.82 which is pretty old. I run the latest from Damian’s repo. I would suggest that you try to update your homebridge-vera install using the following:

npm install -g git+https://github.com/damianxd/homebridge-vera.git

If that doesn’t work, then try @Crille’s suggestion and work your way back.

@blacey The versioning is really confusing, my npm says:

Package Current Wanted Latest
homebridge 1.2.4 1.2.5 1.1.7

But the startup log for homebridge says 0.8.2 so it’s not certain it’s outdated.

Thank you both, I’ve identified the device causing the problem and ignored it, which solved the problem.

2 Likes

@Crille - Think of Homebridge as a container that runs community plugins to expose accessories to HomeKit. Homebridge has a version as well as the plugin homebridge-vera. My suggestion is to install the latest homebridge-vera plugin from Damian’s git repo.

You’re absolutely right, too many New Year’s Eve drinks for me I guess, mixing up homebridge and homebridge-vera packages. But everything after 0.8.2 is beta what I can understand?

Sounds like a good evening to me!

While beta, it has been working well in my home for months… If your aint broke, don’t fix it. If it is, then try the git repo because you can always revert.

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules