How to make Vera recognize Fibaro Flood Sensor v3.3 as a flood sensor and not as Generic Z-wave device?

#1

Hello. I have two types of devices at home connected to Vera Secure (latest version):

  • Fibaro Flood Sensor v3.2 (everything works as expected);
  • Fibaro Flood Sensor v3.3 (problematic);

Instead of recognizing this device as “Flood sensor”, my controller Vera Secure recognizes it as “Generic Z-Wave Device” (with limited functionality, i.e. no triggering by water leakage) while paring process.

Questions:

  1. What’s difference between Fibaro Flood sensor v3.2 and v3.3?
  2. Why couldn’t the controller recognize the device correctly? (already reported to Fibaro Company, and I feel that most likely the issue is on Fibaro side)
  3. Can I downgrade this device from v3.3 to v3.2 somehow, or upgrade to next version 3.X?
0 Likes

#2

Did you try changing the device_type, device_file and device_json to match the one working as expected? Worth a shot, if that does not fix, easy to change those variables back…

1 Like

#3

Thank you. This workaround works! :+1: Now I see the enabled scene configuration: Whenever Flood Sensor is armed and detects flood

So far I’ve replaced:

  • device_file: D_GenericIO1.xml with D_FloodSensor1.xml
  • device_type: urn:schemas-micasaverde-com:device:GenericIO:1 with urn:schemas-micasaverde-com:device:FloodSensor:1
  • manufacturer: Fibar with Fibaro
  • model: empty with FGFS-101 Gen5
  • device_json: D_GenericIO1.json with D_FloodSensorWithTamper1.json

Nevertheless it would be nice if Vera would fix this in one of next release, because this is not still perfect. For example, I don’t see this device in Device --> Type --> Flood Sensor list, and in addition to, this device doesn’t present in Dashboard --> My Modes --> Choose sensors to arm.

0 Likes