How to play the sound files?

Hi Richard

I have read everything on your site but i can not get it to play sound files in your latest android app.
I try the <<>> coding, but it is not working
what should be entered between <<>> ? the name of the file?
I have uploaded a file called hond.mp3 (barking dog), but i can not get it to work

hope you can help me

Mark

Open the Vera Alerts Android App.
Click Menu then Sounds.
Add a sound file and give it a name like Test
Then send a message like:
This is a <> file

Hi Richard

Thanks for your reply
I thought that would be the way but i can not change the name in the android app

when i click on Sound Name then my keyboard appears but it will not store any entry (no text appears when i type)

is there anything i do wrong, or can it be a bug?

Keep clicking on the name until you get it’s attention.

I noticed that the keyboard steels the focus when it pop’s up (When I first touch the SoundFileName I get an orange border around the text box) … Then I touch it again and the keyboard opens but it takes the focus away (i.e. the orange border is gone). I click it again and I get the orange border. Type a character then the keyboard word correction area pop’s up … and steels the focus again. I click one more time and everything seems to behave properly.

So I leave the keyboard there while I add files. I will see if there is something I should be doing to keep this from happening.

I managed to get the following text in : hond

but i still dont get the sound. it is an mp3 file, that works on the tablet,

i use the following code:

luup.call_action(“urn:richardgreen:serviceId:VeraAlert1”, “SendAlert”,{Message = " this is a <>" , Recipients = “”}, 30)

that should be ok? but i cant get it to work.

all other alerts work, also the tone:tts works fine. except the sound. is it ok to use mp3?

it is shown as: this is a <> in the alert panel

The names are case sensitive.

:frowning: sorry

i corrected that but still no succes.

ahhh

it works when i use {tone:tts} in the message

should that be the case?

it works when i use {tone:tts} in the message
Yes ... Earcons are part of the Text To Speech Engine!

A couple of other things for others out there:
Make sure there is no leading/trailing space in the name … Otherwise you have to match it :frowning:

The Notification {tone:N} and TTS use the Android Notification Steam for volume control.
The Earcon uses the Android Music Stream for volume control. Go to your Android - Settings - Sound and make sure you do not have the music volume turned down!

I tried to get the Earcon’s to use the Notification stream … the documentation indicates it should work … but I get errors … so I let it default to the Music stream.

ok, i didn’t know that.

Thanks again, it is working for me now. the dogs are barking in the kitchen ;D

Hi,

Am using the latest v6.05 from Play Store of the Vera Alert, the latest v6.43 of the Vera Alert, running UI7, running latest Google TTS under 6.0.1 of Android.

Can’t get the EarCon thing to work. TTS works fine, the alerts come through okay - when I insert a number between the <<>> the speech pauses correctly. BUT when I put the name of the sound (dog) that has been configured in the app. nothing happens

Here’s the syntax I’m using from the SendAlert option in Vera…

{tone:tts} <> Vera is running

dog is the name of the sound which has a valid path to the locally stored MP3. I also cannot delete any sounds from the same screen, but not fussed about that atm.

Anyone else having this problem ?? or can help ?

Thanks in advance,

David

Can you please prove a example of the syntax needed to call a sound file called “test” to work?

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules