HTD MCA-66, MC66, Lync 6 AND 12 Plugin Working

#1

HI EVERYONE,

I HAVE DEVELOPED TWO PLUGINS IF ANYONE IS INTERESTED, THEY CONTROL EVERYTHING AND I HAVE SET UP SCENES TO CONTROL ALEXA. STILL IN TESTING STAGES BUT WORKS GREAT FOR MY SYSTEM.

MESSAGE ME IF YOU HAVE ANY INTEREST.

0 Likes

#2

[quote=“Newzwaver, post:1, topic:195450”]HI EVERYONE,

I HAVE DEVELOPED TWO PLUGINS IF ANYONE IS INTERESTED, THEY CONTROL EVERYTHING AND I HAVE SET UP SCENES TO CONTROL ALEXA. STILL IN TESTING STAGES BUT WORKS GREAT FOR MY SYSTEM.

MESSAGE ME IF YOU HAVE ANY INTEREST.[/quote]

Hey Im interested in the Alexa and HTD MC66. i HAVE THE GSW1 AS WELL
Please can you send me the instructions and code

0 Likes

#3

Plugin has been published, give it a try and thank you everyone for your support.

0 Likes

#4

Sorry late to the party. I have a huge HTD system and just purchased 6 echo dots. Avid user of the HTD valet app. Before I spend the $$ to purchaser a vera plus hub and a insteon modem, can I ask a few questions? Again thanks for the programming. Can I do everything on the vera hub and alex that I can on the valet app. Mainly interested in the presets. I usually change all zones in the whole house in the morning and switch them to a unused zone in the evening but leaving the system on for intercom. Or do I have to tell alexa to turn on each of the 12 zones

0 Likes

#5

Sure thing how can i help?

0 Likes

#6

Got this plugin installed and working, but the controller device persistently nags that “Can’t Detect Device” in a red banner. Any tip to make that go away? All the functionality is there and everything works right away when I click “All On” or “All Off”, so not sure why it says it can’t detect something. Any ideas?

0 Likes

#7

Hi

Can you check the settings under advanced and then variables? Can you post a pic? You may have to change the commfailure from 1 to 0.

0 Likes

#8

Thank you for developing this!!!

I will be happy to provide feedback and testing. I have a VeraPlus and the MCA66 with HTD MCA66 GW device.

I installed the plug-in successfully. Then I set the IP and mac address in the Advanced->Params tab. (use a static DHCP, so it stays put).

The plug-in created 6 HTD audio zone devices automatically for me. I was getting the message of “Can’t connect to device” but I followed your recommendation and set CommFailure=0. The message went away. The HTD Controller device responds to the all on/off command. Each device seems to respond to the on/off command. Volume +/- works and the source select works. The results reflect in the Valet app on my phone.

Problems:

[ol][li]The volume slider for an audio zone does not work. If I move the slider I get a popup in UI that says ERROR: Invalid Service[/li]
[li]Using the vol up/down buttons is not reflected in the slider.[/li]
[li]The source button for the currently selected source is not highlighted.[/li]
[li]Power status is not reflected with highlighted button.[/li]
[li]Creating a scene with devices is limited. No way to selected source for a zone when creating scene.[/li]
[li]Scenes with HTD zone does not run if vol set. Just says Scene run fail.[/li]
[li]Scene with just on/off for zones seem to run but with no effect.[/li][/ol]

So, this is a great start but not really usable yet. To replace the Valet app we will need to be able to set zone mode, source and volume. Same as using presets in the Valet app. If a scene could just trigger an already configured preset that would be fine.

I’m happy to collect any logs or other info that might be helpful.

Thanks again for the work!

edit: I am showing app version 1.1. Installed from the app store not via the files in the other thread…

0 Likes

#9

Hi

I have fixed the plugin and everything works with the exception of the slider, it did work but something has changed and I need to fix it. For some reason the files uploaded in the plugin are not the same as I am uploading. Go back to the files I supplied in this post and load them into you vera this will fix the issue until I can chat with Vera Tech Support.

0 Likes

#10

New to the forum and Vera but have used my Lync 12 for the past year. I just purchased a Vera Plus and was able to load the app and can see 12 zones but I only have on/off volume up/down and mute on/off control. I do not see where I can select a source. I also have a general zone that when you are in the UI shows all the sources but gives an error when you select one. I am new to Vera and Alexa and any help on the set up and scenes is appreciated. I tried to IM Newzwaver but it appears I am unable to right now.

0 Likes

#11

[quote=“Newzwaver, post:9, topic:195450”]Hi

I have fixed the plugin and everything works with the exception of the slider, it did work but something has changed and I need to fix it. For some reason the files uploaded in the plugin are not the same as I am uploading. Go back to the files I supplied in this post and load them into you vera this will fix the issue until I can chat with Vera Tech Support.[/quote]

Ok, I should go use the latest files you attached in the other thread. Should I delete all of the devices/controller that the plugin created before I do that?

Thanks!

0 Likes

#12

no need to delete this will overwrite everything. message me if you have any issues

0 Likes

#13

Updated and will be in the App Store, you can manually change your sources. Working on an auto and the screen view was changed someone asked for it. Also on the main device, Alexa and Google you can access sources.

0 Likes

#14

Just wondering if https://github.com/Newzwaver/HTD-MC-66-MCA-66 has the latest code? I’m asking since I’m looking to do an implementation for the MC-66/GW-SL1 for SmartThings. I figured I could look at your work and learn a few things.

Thanks,
Aaron

0 Likes

#15

Ok sorry for the regressive post however new to Vera but now new to Htd valet app. Where do I get the plugin for a lync12 as the one I pulled from the Vera store doesn’t allow source changes. I am looking to change using presets or just walk into a room and change source

0 Likes

#16

Hi Taylor,

I am working reading and setting the Lync source using Vera, however work has been crazy and I am currently on vacation so a little overdue. Should have something shortly.

0 Likes

#17

I can get everything to work except setting the volume to a specific level. My scene to set the volume to my preset level runs without error but the volume level doesn’t change.

Anyone else having this issue with the MCA-66?

0 Likes

#18

[quote=“alchse, post:17, topic:195450”]I can get everything to work except setting the volume to a specific level. My scene to set the volume to my preset level runs without error but the volume level doesn’t change.

Anyone else having this issue with the MCA-66?[/quote]

Same here, and also that it does not show up on third party apps like imperihome

0 Likes

#19

Sorry, I have been week after week out of town and no chance to work on the plugin. The slider still needs work with the MC66/MCA66, I had it working and before I could load it up my system crashed and yes stupid me didn’t do a back up. Other than that is the slide isnt working on the lync6/12 the reason is volume2 file is required and for some reason was removed from versa. Message me and I will try my best to help. Time for me is very limited and I do apologize for that.

0 Likes

#20

Your contribution is not an obligation , its prerogative and I am sure we all appreciate the effort you have put in .

Regards!

0 Likes