HundredGraphs Logger plugin beta

doest work good wen tring to log data … will stick to the Lua Api untill u guys fix this

custom variables dont work

We got custom vars, check 2.2 plugin

1 Like

Locks are preconfigured too

@ipstas I am now investigating the possibility to take in use the Vera Plugin instead of the Moniton.lua script but I can not figure out how to specify my second Vera as Node 2. Do I need to register my second vera using a different e-mail address to get another API key or is it still possible to use different NODE_ID for each Vera device like in the moniton.lua? Seems to me like you need to add this variable so it can be configured.

@korttoma 2.3 with node_id added is on AltApp store

1 Like

@ipstas thanks for adding “DeviceNode” but the feeds stil ends up under Node 1 @hundredgraphs.com/feeds even if I set it to 2 in the plugin.

Have you saved the devices?
What DeviceNode shows in Advanced/Variables?

This is what I have saved:

This is what is under advanced variables:
image

This is what I can see @hundredgraphs.com/feeds

As I see, you have 2 nodes both in raw data and in the Feeds collection. Can you try to minimize Node 1?

@korttoma I am still trying to find out why it doesn’t work for you.
Can you check you have API key added in a plugin
And the plugin is enabled
Could you also set Advanced/Variables Dev = 1, it would send data to the dev server as well

Ok, I generated a new API key so now the secondary vera (Node 2) is the only device pushing data to the cloud.
I also set Dev = 1.
Stil all the data sent ends up under Node 1

now trying to set it to Node 3 to see what happens.

Stil ends up under Node 1 and it says Stalled for all feeds.

If I configure it as Node 1 it looks exactly the same as using any other node number.

Disabled the plugin on my secondary vera now until further notice. If you have any idea what I could try next I will enable it.

Updated the API key in moniton.lua on my main vera so it again reports to node 1 like it is supposed to.

@korttoma Can you try to enable it on Monday and let me know while it is running. I need to catch it while it runs otherwise it is totally not clear why it doesn’t create a new record

Ok @ipstas , I now disabled my main vera (reporting to node 1), removed all feeds from hundredgraphs.com/feeds/ and enabled my secondary vera reporting to node 2.
As soon as I enabled the plugin in my secondary vera (reporting to node 2) I can see the feeds but they are still populating under Node 1. Dev = 1, DeviceNode = 2, version = 2.3.

Thx, I think we got it. Can you try 2.4 from AltApp store and let me know if it have fixed the issue

With version 2.4 I now see the node 2 data correctly under node 2. Great work @ipstas

Ok, so far so good, now if you could let me know how to send custom variables then I would be all set to allso convert my main vera to use the plugin.

I have added the following custom variables to the plugin custom var page:

Custom Uptime urn:akbooer-com:serviceId:EventWatcher1
Custom MemAvail urn:akbooer-com:serviceId:EventWatcher1
Custom MemFree urn:akbooer-com:serviceId:EventWatcher1

Is that enough? Or did I miss something?

@korttoma You need to rediscover devices after you have added new custom Vars and enable them of course
So go to Devices tab, reset devices, get them again, enable, save. You should have new feeds in a minute

1 Like

@ipstas Ok, thanks now it works!

Some small issues with the custom variables @hundredgraphs.com/feeds.
They are all called “Event Watcher” now and I can only change the name of one of them (Uptime), if I try to change the name of the other 2 (MemFree and MemAvail) it will again effect the first one (Uptime).

Looks like a bug, thx for reporting

1 Like

I’m using 2.3 and it doesn’t recognize my custom vars by doing a reset/get devices. Is this a bug in 2.3 with custom vars?

© 2019 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy