HundredGraphs Logger plugin

Thx, I think we got it. Can you try 2.4 from AltApp store and let me know if it have fixed the issue

With version 2.4 I now see the node 2 data correctly under node 2. Great work @ipstas

Ok, so far so good, now if you could let me know how to send custom variables then I would be all set to allso convert my main vera to use the plugin.

I have added the following custom variables to the plugin custom var page:

Custom Uptime urn:akbooer-com:serviceId:EventWatcher1
Custom MemAvail urn:akbooer-com:serviceId:EventWatcher1
Custom MemFree urn:akbooer-com:serviceId:EventWatcher1

Is that enough? Or did I miss something?

@korttoma You need to rediscover devices after you have added new custom Vars and enable them of course
So go to Devices tab, reset devices, get them again, enable, save. You should have new feeds in a minute

1 Like

@ipstas Ok, thanks now it works!

Some small issues with the custom variables @hundredgraphs.com/feeds.
They are all called “Event Watcher” now and I can only change the name of one of them (Uptime), if I try to change the name of the other 2 (MemFree and MemAvail) it will again effect the first one (Uptime).

Looks like a bug, thx for reporting

1 Like

I’m using 2.3 and it doesn’t recognize my custom vars by doing a reset/get devices. Is this a bug in 2.3 with custom vars?

1 Like

We have update on Vera app for 2.8 and AltUI for 2.9. I would highly recommend to have a plugin upgraded. More than few bugs were fixed

Hi ipstas,
How can I enable the feeds in the Vera hub? The API key is set, Interval is set to 600 but LastRes is empty.

I need to push the data from my Aeotec Home Energy monitor.

Thanks a lot

Anyone else having issues with the hundredgraps web page?
Seems like some certificate issue.

It’s not the first time it happened, seems the project lost its steam.

Having trouble adding my Thermostat’s Current Setpoint. I’ve added the following within “Custom Vars”…


I have reset and re-discovered devices a few times, but do not see this device appearing. Have I done this incorrectly?

Mine is

urn:upnp-org:serviceId:TemperatureSetpoint1

Just went through something similar trying to get the setpoint into a variable for TTS.

What I learned from our resident experts is to get the service name is you go to Advanced > variables then hover over the variable. Who knew.

Of course, I could be totally wrong, I’ve never used Hundgred Graphs.

C

1 Like

Thanks @Catman, you are right! This fixed it, working correctly now

1 Like

Thanks due to those that put up with my ignorance earlier!
@therealdb @akbooer @reneboer :smiley:
C

1 Like

We have updated the server at https://www.hundredgraphs.com, made if faster, smoother and fixed few bugs. The next month we are going to have some large changes in how it looks like and what it can do.

The next step will be to make it sexier too. And if you have any ideas, please let us know.

With that we are going to update our pricing, the Free Forever plan stays free forever, but the current paid plans will be changed. If you are going to sign for paid plan this month your price will stay the same for at least a year.

We are also looking at semi-retiring old script and rely more on a plugin, the reason is that the data from the old script is incompatible with the AI we promised for so long. Semi-retiring means we still want to provide you that option, but we can’t continue to support it for free and we will start asking some negligent fee (really negligent)

2 Likes

Hello,

  1. Custom vars need to be able to add a name to them. Moniton.lua allowed this.
  2. On both the app (uninstalled now) and mobile chrome, every time to get widgets to load I have to tap feeds or some other menu item and go back to the dashboard
  3. Takes 2 taps to access the menu, not sure why.
  4. Color schemes or picker for the graphs.

Thanks!

  1. nevermind on this one, figured out where to rename Custom vars need to be able to add a name to them. Moniton.lua allowed this.
  2. On both the app (uninstalled now) and mobile chrome, every time to get widgets to load I have to tap feeds or some other menu item and go back to the dashboard
  3. Takes 2 taps to access the menu, not sure why.
  4. Color schemes or picker for the graphs.
  1. You can’t rename it on the plugin side, we don’t want to mess with your controller. But you always can do a custom name on the HG side. Just go to Feeds and click on the name you want to change to custom.
  2. Do you mean graphs are not loaded on a 1st go? Is it still a case?
  3. Is it app or a site as well?
  4. Elaborate please?

Hi @ipstas

  1. Yes, figured it out after the fact, sorry about that.
  2. Correct, I have observed that the “reconnecting” is not reloading the charts and I often end up refreshing the page or going into a menu and back to the dashboard to get it to load.
  3. Both app and site requires 2 taps to access the menu. First tap is like it has to have the menu object highlighted (you don’t see anything visually, just my guess), then second tap actually reveals the menu. I use Chrome mobile for Android, latest versions always. I have done cache clear and data clear in recent times.
  4. I stated in the past in this thread that the colors are reverse. 100% wouldn’t be red for a gauge, the natural feeling of 100% would be green. This would look best for battery variables. For my pump power with wattage, a gradient of colors in either direction to pick from such as lower wattage is green, medium wattage moves to orange and higher wattages move to red.

On a side note, I’ve used help on the site and the team has been fairly responsive. I have a ticket in with them (don’t remember the number) whereby a power gauge for my pump had been off for 3 hours but the gauge was showing 1400watts still. When you go to graphs, tap the pool pump graph, then go back to the dashboard it will repopulate correctly for a while and then it’s like it times out.

I switched my graphs to public at the request of the support person to view them. Use my username just like here on the forum (tomtcom).

03-21-2020-09-21-54



1 Like
  1. We have added a button for an update for linear graphs, and gauges are updated in real time. Unfortunately linear are a bit more complicated and requires aggregation on the server side and for now we can not make them real time. But you don’t need to refresh the whole page anymore, just click on an update button and that graph will be updated without page refresh.
    Hopefully we will make it real time in the future after a hardware upgrade.

  2. That should be fixed by now, can you please check it?

  3. Colors are very debatable. Yes, the 100% of battery is definitely green, however 100% of power use is definitely red. We can offer two schemes maybe, the second is reversed of the existing one

  4. THANK YOU! We have totally missed that bug, gauges were updating the right column with numbers but were not updating the gauge itself. It is fixed by now. Thanks again for bringing it up.

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules