HundredGraphs Logger plugin

Mate, my pleasure

Site and plugin were both updated.
The new version of plugin 2.1 is available on Alt App Store. It is highly recommended that you would update to it.
TL;DR Now you can rename the device on a Vera side anytime, it sill would report the right device based by ID.

Tech stuff
The improvements were done in sending results over the Post instead of Get, this allowed to send devices IDs and units as well. It also would allow HundredGraphs.com finally move closer to release the Energy DashBoard
We still accept the data over the old API with the old lua file, however it is going to be phased out in the future.

Regards from Colombia,
I am Dynayen Heredia, i’m really newbie, congratulations for you work Plugin Hundred Graphs. I am looking for a monitor for power consumption and temperature changes, for my smart home with Vera Edge (Ui7). I’ve seen at MIOS Market the plugin HundredGraphs, y I check your comments in Vera Community.

I install this plugin in my controler, but I think no work correct, when I refresh navegator (Chrome) the device disanble automatically.
Also in my profile, I see an alert, about an error, however my password is different from what appears in the fault message.

is this normal?
Why does the device only change state?Picture1

@Dynayen, it looks like you are using both old way (lua file) and new plugin, you need only one of them. And if you use the lua script, Variables could have only a-zA-Z_, that’s why it errors.

Great app! Thanks for the great work!
Is there a way to add Vera reboots and free memory to the graphs?
I would also like to track my Danalock open/close log in a graph, but it doesn’t appear in the devices…
Any suggestions?

Thanks,

Morgi

Is this a lock? Locks are not supported in the plugin yet, same as Vera system variables, you have to run lua script. As I know, people have them reported with systems plugin. You can find examples here Free graphs for your temp/power sensors

Thanks for the quick reply.
Yes, Danalock is a zwave lock.
I prefer not to use lua codes as it much too complicated for me…
Hopefully you will add those on the next updates.

Regards,
Morgi

Can’t promise the exact day, but sometime around August

1 Like

doest work good wen tring to log data … will stick to the Lua Api untill u guys fix this

custom variables dont work

We got custom vars, check 2.2 plugin

1 Like

Locks are preconfigured too

@ipstas I am now investigating the possibility to take in use the Vera Plugin instead of the Moniton.lua script but I can not figure out how to specify my second Vera as Node 2. Do I need to register my second vera using a different e-mail address to get another API key or is it still possible to use different NODE_ID for each Vera device like in the moniton.lua? Seems to me like you need to add this variable so it can be configured.

@korttoma 2.3 with node_id added is on AltApp store

1 Like

@ipstas thanks for adding “DeviceNode” but the feeds stil ends up under Node 1 @hundredgraphs.com/feeds even if I set it to 2 in the plugin.

Have you saved the devices?
What DeviceNode shows in Advanced/Variables?

This is what I have saved:

This is what is under advanced variables:
image

This is what I can see @hundredgraphs.com/feeds

As I see, you have 2 nodes both in raw data and in the Feeds collection. Can you try to minimize Node 1?

@korttoma I am still trying to find out why it doesn’t work for you.
Can you check you have API key added in a plugin
And the plugin is enabled
Could you also set Advanced/Variables Dev = 1, it would send data to the dev server as well

Ok, I generated a new API key so now the secondary vera (Node 2) is the only device pushing data to the cloud.
I also set Dev = 1.
Stil all the data sent ends up under Node 1

now trying to set it to Node 3 to see what happens.

Stil ends up under Node 1 and it says Stalled for all feeds.

If I configure it as Node 1 it looks exactly the same as using any other node number.

Disabled the plugin on my secondary vera now until further notice. If you have any idea what I could try next I will enable it.

Updated the API key in moniton.lua on my main vera so it again reports to node 1 like it is supposed to.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules