Installing Sonos Plugin 2.0 (development/pre-release) for Azure TTS access

I uploaded everything in the main folder on the link that was in the message. I deleted the previous download so I wouldn’t get them mixed but I will be happy to do it again to make sure

Yes, please. Also make sure after step 10, you do step 14 to finish–that browser refresh is important, too.

You should see version 20054.2040.

Hi Patrick, can I do a clean install of Sonos 2.0 (so without existing plugin installed) and start from step 4 ?

Yes, that should be fine.

1 Like

In the old version, using the Say command, I used to put GroupZones to ALL. then TTS would play everywhere.

This is not working with 2.0. is there a new method?

Thank!

Hi!

Thanks Patrick for helping us newbies out!
Is there a ETA for your official 2.0 release?
/Fanan

Well, it works famously for me when I do it! Can you check your LuaUPnP log for anything after the “Say” action is logged?

Not at this time.

Patrick, I’ve had mixed success with TTS installing the Sonos devices on openLuup. But with RV gone, maybe that’s part of my problem.
Will v2.0 beta install on openLuup, now or in the future? I’m trying to keep as much as possible OFF of the Vera boxes.
I just tried winging it, and it did not go well. But THANKS so much for all your work on this!! It’s a great addition to the overall polish of the Vera systems.

Blockquote
#18:Sonos System:./L_SonosSystem1.lua:65: module ‘lxp.lom’ not found: no field package.preload[‘lxp.lom’] no file ‘./lxp/lom.lua’ no file ‘/usr/local/share/lua/5.1/lxp/lom.lua’ no file ‘/usr/local/share/lua/5.1/lxp/lom/init.lua’ no file ‘/usr/local/lib/lua/5.1/lxp/lom.lua’ no file ‘/usr/local/lib/lua/5.1/lxp/lom/init.lua’ no file ‘/usr/share/lua/5.1/lxp/lom.lua’ no file ‘/usr/share/lua/5.1/lxp/lom/init.lua’ no file ‘…/cmh-lu/lxp/lom.lua’ no file ‘files/lxp/lom.lua’ no file ‘openLuup/lxp/lom.lua’ no file ‘/etc/cmh-ludl/lxp/lom.lua’ no file ‘/etc/cmh-lu/lxp/lom.lua’ no file ‘./lxp/lom.so’ no file ‘/usr/local/lib/lua/5.1/lxp/lom.so’ no file ‘/usr/lib/arm-linux-gnueabihf/lua/5.1/lxp/lom.so’ no file ‘/usr/lib/lua/5.1/lxp/lom.so’ no file ‘/usr/local/lib/lua/5.1/loadall.so’ no file ‘./lxp.so’ no file ‘/usr/local/lib/lua/5.1/lxp.so’ no file ‘/usr/lib/arm-linux-gnueabihf/lua/5.1/lxp.so’ no file ‘/usr/lib/lua/5.1/lxp.so’ no file ‘/usr/local/lib/lua/5.1/loadall.so’
Blockquote

1 Like

Agreed, Patrick’s the best. I now think of Vera as “the box that runs Reactor and Sonos” and his other amazing plug-ins. The rest is gravy.

1 Like

Hi Patrick,

Well, I got impatient, and installed 2.0 on a Vera instead of openLuup, and I had a new problem. I found the following message with [ cat /var/log/cmh/LuaUPnP.log | grep -i -E “warning|error|failed” ]

01 02/25/20 16:44:36.723 eLuaInterface::CallFunction_Job device 81 function SSonosSystem1_SonosSystem1_StartSonosDiscovery_job failed [string “–[[…”]:3425: bad argument #2 to ‘format’ (integer expected, got string)e <0x775b0320>
01 02/25/20 16:44:36.723 eLua_Job::Run job#2 : dev:81 (0x14d31e8) P:50 S:0 Id: 2 failede <0x775b0320>
04 02/25/20 16:44:36.724 <0x775b0320>

Just because I’m stupid and like to experiment, I made a small change to line 3425 in L_SonosSystem1.lua and got my Sonos devices to create, but It will probably come back to bite me.

Can you take a look to see if there is a problem with that line, or if it’s something just on my end?

Thanks!

I’m wondering what version of code you have… I have no string.format on that line in the latest. The latest is 20055.1905. See footer of the Settings tab on the master device.

Ver 2.0 does not run on openLuup yet.

I show - Sonos Plugin version 2.0develop-20055.1905

The line reads: table.insert( w, zone.udn:upper():gsub("^RINCON_","") )

I have no idea what it means or how it sees a string I just found a line with a variable that I thought would be a number, and plugged it in there. (I know it’s wrong, but…)
table.insert( w, zone.port:upper() :gsub("^RINCON_","") )
there is now a 1400 somewhere where it shouldn’t be on my system, but it seems to be working and talking.

Well, the line you’re showing has nothing to do with the error message, and the change you made isn’t correct (but harmless–just affects the default name of the Vera device on discovery). I don’t even know where to go with this next. :joy:

If my change is “harmless” then don’t spend another minute on it. It’s working, so I’m a happy camper!

Your work on this has (partially) restored my faith in Vera, and gives me the function I wanted. Hopefully you will get it moved over to openLuup someday, and when it’s “real” instead of pre-beta, I suspect it will install correctly, even for me.

Thanks again

1 Like

Hi rigpapa, great development. After some reinstalling I got everything working now. I tried V1.5 first, but had some problems with it.
Now I’m converting my Scenes and LUUP to get everything working with this version.

Hello Patrick
I completed the install of Azure and I have the Controller with Sonos Plugin version 2.0develop-20057.1500 installed. It found 11 new zones. It says creating devicies which I assume are going to be 11 child devicies. But… nothing has happened for over an hour with multiple tries of …luup.reload() & hard refreshes of control F5. My previous Sonos version was 1.5 and I deleted it after the upgraded controller appeared but even if I’ve lost my device # of 298 I don’t mind renumbering the devices in my scenes. As usual any help is greatly appreciated.
Wilbur

Well, if I had to guess based on what you said, when you deleted 1.5 after upgrading to 2.0 and creating the new master device, you deleted files that 1.5 and 2.0 have in common. I’d start by reinstalling the 2.0 file set. You don’t need to do anything else at this time… just re-upload the 2.0 files and restart Luup.

Is that this link?

for n,d in pairs( luup.devices ) do
if d.device_type == “urn:schemas-micasaverde-com:device:Sonos:1” then
luup.attr_set( “plugin”, “”, n )
end
end
luup.reload()

No. Repeat steps 4 through 10, and then skip to 14.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules