Last software update fail

I got a notice in Vera plus Iphone app about new firmware. Then I just started the upgrade from the Iphone app and the update proceded. Since that I am not able to come in contact with my Vera from any interface. After some hours I rebooted vera the hard way by plugging off the power. After done it several times I still not have any interface which I can come in contact with vera. Would like to be able to roll back to an old backup - since this update failed. Anybody have any tips on what I shall do?


Factory reset the unit and then try to restore a backup. Maybe after reset, a good idea is to call support and have them do it for you.

I’ve got the same issue. Just upgraded to the latest firmware after the CEO’s flag waving e-mail to find my Vera is now un-responsive. This has happened on more than one occasion in the past when applying firmware upgrades. The whole process seems a joke a very very flaky - I DREAD pressing that Upgrade Firmware button as more often than not it bricks the controller and then you have to wait for support to respond and attempt a remote fix.

Seriously considering swapping the whole controller for a different manufacturer now.

OMG - Support have just responded with proposed fix and at the same time the unit started responding, some 30 minutes after I rebooted it!!

Have made a factory reset and still can not connect to Vera Plus by any interface. If I only could access vera I could restore backups that I have downloaded to my computer. Any advice do I have to make the full reset that also erase user data?

If you’ve done a full factory reset, you’ve already erased your data. How are you trying to connect to it, as any changes to the IP address will also have been lost…


Well I have made a full reset since it anyway did not work after last firmeware release. Now I cant see the controller at all.
I try to connect to the controler over its WIFI, but the wifi on the controler can not be found. The controler is connected to internet via my Roater (LAN to WAN). But when i scan my networks IP i can not find any device that is VERA. Soo it looks like the Controler have lost all To the sorounding world.
When i try to add the controler again as it was a totally new new controller the vera guide cant find it. It is like the controler have become totaly dead.

Same issue there.
Only power and wifi leds are green fixed.
Internet & Service are green blinking.
Tried to push 3 times the reset button. No effect.

Contact the support, waiting for an answer.
Really, really fed up with this box.

1 Like

Same issue there
There is a continuous “user configuration” for multiple devices. The metering does not work, the off and on status indication is not correct.
One fibaro device constantly updated.
The following message also flashes half a minute: "System error: Device: 106. Fail to load implementation file D_FUP_uuid 5f9ec1b3-ff59-19bb-8530-0005cd2cfed7.xml
Luup: Downloading Luup Plugins "
And frimware updates indicate a bug that cannot be resolved with the scripts described in more than one place.
I’m very angry that there is practically a flashing brick.

I’m assuming your Vera normally connects over cable. My bet is the IP on the Vera is not part of your LAN IP range, so you’re not going to get any connection. My next step would be to connect a cable to it directly with a laptop as if it was a brand new device.


1 Like

A backup and restore is a connection problem for me solved but nothing more.

I have tried the Lan cable direct to the controler, no success. I dont remember how I did the first time to set up Vera plus. Shall I try to connet with a USB cable between Vera and a Computer with WiFi to my home network?

Do you have any advise on alternative manufactors with more stable controlers and still the same type of features as Vera provide?

I am starting to wonder if I should write my own upgrade script to prevent all of this nonsense and workaround the storage partition problem which is the root cause all of these problems. It’s just insane. I am not on mios’ payroll. The solution is actually fairly simple. Because of my mods to the vera, I am now manually upgrading firmware through scp without any factory reset.


Had to do a full factory reset. That reset with the latest firmware and I was then able to restore from my last backup and delete a load of unused plugins. Generally old plugins appear to be the issue but Vera provides no indication as to their compatibility!

BTW support didn’t advise me to do any of this!!

Any “hard method” to go to factory reset, as pressing 6 times the reset button does NOTHING… ?

Same issue here!!! After updating the firmware yesterday, this is the first time Vera has gone almost totally nonresponsive for me, and it’s not a happy experience at all!!! I’m not even sure what to do about performing and then recovering from a factory reset!!!

This is a bit out of date but…

In short connect a network cable from the vera to your PC
Set your PC IP address to
Connect to Vera on

Hopefully off you go…


@Catman, I did a full VeraEdge reset and tried setting my Mac’s IP as you suggested, but I couldn’t access the controller over my wired network. Can I connect over the controller’s WiFi? I can connect and log into it, but then I don’t know how to access the controller via my browser. I’m totally down at the moment and am unable to control many devices in my house!

You should try to interface the Vera device using an Ethernet cable to an available computer and setting your network adapters IPV4 settings to DHCP. Once connected visit the Vera’s default IP address through a browser and change the subnet back to your networks subnet.