Manually restore backup

Is there a way to restore a backup via ssh

every time I try I get this error

PS. The backup is from a different unit

Are you trying to restore a backup from the Mios cloud? If so, have you tried downloading it locally?

C

yes im trying to restore a backup downloaded off mios cloud to My NAS to a different V+ ao that i can do some testing

This appears to be a server error. Nothing to do with the vera failing. Possibly the server preventing your vera from downloading the backup file because of a different PK id.
It is always best to have local backups. I believe that you should be able to run the restore locally unless something changed in the firmware. The restore is actually quite easy to do once you have the local file if you want to do it manually.
It consists of only 2 major elements: the user_data.json files and the dongle.dump files which need to be uploaded to the zwave chip and is done automatically by creating a file to the /etc/cmh folder and running a luup reload.

Try saving the backup to the local machine that you’re accessing the Vera from?

C

yes i have the backup saved locally on my PC but every time I try to use this backup it fails and just says Internal error. fyi I am on Firmware 7.0.29

ok then untar the backup. Copy the /etc/cmh/dongle.dump files from the backup into the vera at the same location.
run touch /etc/cmh/dongle.restore and reload luup
Then upload the /etc/cmh/user_data.json files (all of them) from your backup to the vera and reload luup. If this doesn’t work, you may have a corrupted backup.

dont wanna sound like a nonce but how do i untag the backup 7zip always gives me an error

sorry auto correction at work… it is untar, not untag… obviously you need to use the tar/untar which is a linux tool. Not windows’ 7zip

beautiful i can figure that out –

one more thing, my v+ is extrooted couldnt i just upload it to mt extrooted V+ and untar it there?

You sure can.

2 Likes

so no luck after following the instructions s o tried to copy the entire folder and that did not work either

What errors are you seeing?

the devices are there but no user data, could that be because it is actively being read by the OS

so what it didnt do is allow restore my backup but what it did was mimic my old system and i was able to restore a backup from my the mios server, so copying all the files to a different vera pretty much allwed me to image my old vera to a new unit even though the mac and serial is different

so if your vera dies totally as long as you have a backup u can clone the unit
all u would need is just different hardware

Glad you got it figured out. What you said is a characteristic of zwave. It isn’t quite that simple with zigbee…

So i have a question, if we can clone our vera unit is it possible to cluster veras for distributed processing?

…a sort of Verawulf cluster? :slight_smile:
C

Not sure I understand what you mean. If you are talking about having multiple primary controllers cloning one another then no, it is not a good idea. What you can do though is to have a primary master and multiple secondary controllers. You could use the secondary to send commands and run device addition while the primary would collect all the sensor data. This would make for a pretty complex system though.

1 Like

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy