MiOS App Beta

AND

  • When connected to Cloud, VP devices and scenes do not appear

It’s the same in the Vera mobile app. VOI only appears on the menu when connected to a controller running Ezlo firmware.

BUGS

The Dashboard page title text, the colour of it seems to be linked to the colour of the tiles State on or off.

As you can see I set the tiles on state to be yellow and now the dashboard page title text is also yellow.

The Dashboard page does not refresh or update itself.

When I turned on the lamp the tile remains blue and 0%. I had to leave the dashboard page and go to another area of the app and then go back in to the dashboard page for the tile to then change to yellow and show the correct percentage.

BUGS

When setting the tiles State on / off to some colours it doesn’t work if you have also set a background image.

The tile instead goes transparent.

On Tile: A =48
Off Tile: A =15

(This lamp is a Philips Hue device via the AltHue plugin on Vera Plus)

I didn’t have this problem when the tile was set to blue for off and yellow for on and I added a background. That seemed OK.

But now setting them to different shades of grey the tile doesn’t show these grey colours, it’s just transparent as you can see in the above screenshot.

FEATURE REQUEST

Also please add a setting so we can properly make tiles transparent when off and I will set a tile colour for when on.

Also can the tile icons be made bigger in size, can hardly see them.

Thank you @cw-kid for you feedback.
We will look into it

1 Like

This is the look I was going for, this is the 3rd party “The Home Remote” where the tiles are transparent when off and a grey colour when on etc.

image

Their tiles are bigger and you press the 3 dots for the extended dialogue controls.

BUGS

This is taken from the website configurator, its the same in the standalone Ezlo dashboard configurator app.

Also you cannot seem to edit existing dashboards or tiles in the Mios app currently.

The default icon shown in the configurator is not the same icon as that is displayed in the mios app for this tile, as you can see in the above screen shots.

Also No upload button to add your own image icon yet.

So, with help, I was able to create a 3-button Dashboard (named “Broken”) at https://edash.mios.com/#/dashboard-preview to control 3 binary light switches.

However, upon completion, the new dashboard appears “blank”…


…then figured out that I must click the > button at upper right in order to see the buttons layout I created.

Can someone please explain why clicking any of those buttons doesn’t do anything? I’ve clicked them in various spots, single- and double-clicked, nada. I thought the whole purpose was to turn things on/off. :confused:

I don’t recall anyone stating that the beta Dashboards are supposed to non-functional, but perhaps I expected too much?

The website version and the standalone Ezlo Dashboard Configurator app are not functional. They can only be currently used for creating your dashboards.

They are functional somewhat in the Mios app.

I expect that the website version will become functional at some point.

Can you see the dashboard you created on the website in the Mios app in Settings - Dashboard Settings?

I suspect not as there is a bug where they don’t appear in the Mios app anymore, they did initially for myself but no longer for newly created dashboard pages.

You can create a new dashboard directly in the Mios app instead for now. But you will likely need to use the other tools to modify them, as you can’t seem to edit existing dashboard pages and tiles in the Mios app.

It’s all a bit of a mess at the moment.

1 Like

After adding more tiles it’s clear the icons are coming from the devices themselves in Vera not from the Dashboard Configurator.

Mios app

Ezlo Dashboard Configurator app

FEATURE REQUEST

To be able to hold down on a tile in the Configurator and drag and drop it in to a new position to move the tiles around.

1 Like

FEATURE REQUEST

Remove the device delete option, don’t need it and definitely do not want to see it in a front end dashboard GUI app!

FEATURE REQUEST

Also on the first screen shot of the Lamps details dialogue control, can I set the background colour globally of all of these to dark.

And change the blue colour on the on / off button, slider and percentage text.

1 Like

BUG

I just added two Scene tiles and set their background colour to a light grey, A=15.

Now the dashboard flickers.

This is an unlisted video not public.

@cw-kid Thank you for your feedback. We noted all the findings.
One small note: the dashboard tool from the web site and stand alone app plays now “the builder” role. It only can be used to create and preview dashboards.
We are considering implementing more functionality, that will allow users to send commands from it too.

1 Like

Hello guys,
During my conversations with some of you, I identified some points into the flow that are not intuitive enough.
Until we will fix that, here are some explanations:

There are 2 ways of displaying and using a dashboard:

  • You choose one template and define one layout that auto adapts when you rotate the phone
  • You choose 2 templates: one for landscape and one for portrait and you will see 2 different layout when you rotate the phone

You can choose between the 2 options by turning on/off the “Use one template” switch

The default is off => you need to define 2 different layouts, one for portrait and one for landscape. This is why you are back to “Select dashboard template” page after you go trough all the steps. You have one more orientation to configure.

Here are some examples:

  1. The “Use one template” switch is off and the user defined 2 layouts:

  2. The “Use one template” switch is on and the user defined 1 layout:

Regarding device control, the mechanism now is still the one we had on Dashboard Pro:

The thing you can configure now for your dashboard is the look of a tile based on the device state. Example: If you have a sensor, your tile can look different if the sensor is armed / disarmed or tripped.

This is how tripped sensors behave in Imperihome. By default the devices tile background flashes red.

For example for my Patio Door if the door is opened, I see my door opened icon and the tile background flashing red…

When the door is closed, I just see the door closed icon and the tile looks normal.

FEATURE REQUEST

Can you make the tripped sensor tiles behave the same as this.

Also in this video you can see a “Composite” security sensor tile. When I click this tile, it pops up and shows all the sensors I have assigned to it at a glance

3 Likes

I have recieved 2 emails saying there is an update in mios beta app, the latest being 1.0.602.

But when i go to download i get “no apps yet”


I had no issues downloading the initial beta release.

In contrast to the Vera app I had no issues installing the 1.0.602. The installation of the Vera beta app always fails and I have to uninstall it first. Perhaps one of the MiOS developers could tell the developers of the Vera app the trick of smoothly updating the beta app :wink:

Does it still make sense to install the Vera Beta? Or is there anything that the MiOS app cannot yet do?

Hi. Do you use also the store version of Vera app? Do you mix them,like installing Vera from store, then installing from AppTester? Usually this is the reason the install would fail. Please remove all Vera apps(store, apptester), and install only from one source.

1 Like

I only install from AppTester. When I’m at home, I’ll try removing Vera and MiOS App and then install the Apps again via AppTester and then try to reinstall these Apps via AppTester (Updating to the same version).

Still receiving emails telling me there is a new beta version, but as posted multiple times, not seeing any apps to download.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules