Mount CIFS Share on Vera Edge?

#1

I have followed the guide to mount a CIFS share with the VeraEdge, but am getting an error of Permission denied. I know the username and password work because I am using the same mount command on a linux box which is able to mount it just fine.

I tried installing cifsmount and get an error “Unknown package ‘cifsmount’”

Has anyone else run into this and solved it?

0 Likes

#2

You need to install the CIFS packages:

cd /tmp/
opkg update
wget  [url]http://download.mios.com/firmware/openwrt/ramips/packages/kmod-crypto-md5_2.6.37.1-1_ramips.ipk[/url]
opkg install kmod-crypto-md5_2.6.37.1-1_ramips.ipk
wget  [url]http://download.mios.com/firmware/openwrt/ramips/packages/kmod-crypto-hmac_2.6.37.1-1_ramips.ipk[/url]
opkg install kmod-crypto-hmac_2.6.37.1-1_ramips.ipk
wget  [url]http://download.mios.com/firmware/openwrt/ramips/packages/kmod-fs-cifs_2.6.37.1-1_ramips.ipk[/url]
opkg install kmod-fs-cifs_2.6.37.1-1_ramips.ipk
opkg install cifsmount
rm kmod-crypto-md5_2.6.37.1-1_ramips.ipk kmod-fs-cifs_2.6.37.1-1_ramips.ipk kmod-crypto-hmac_2.6.37.1-1_ramips.ipk 

To test mounting manually. Try this:

mkdir /nas mount -t cifs -o user=<username>,pass=<password> //<nas ip>/<share> /nas

h/t to everyone on this thread : http://forum.micasaverde.com/index.php?topic=16452.0, since I literally copy-pasted the instructions from that page.

0 Likes

#3

No, this doesn’t work. Been trying to get this working for [tt]DataYours[/tt] see http://forum.micasaverde.com/index.php/topic,25800.msg216212.html#msg216212.

Seems that CIFS install needs to be built specially for MiOS / UI7 / Edge.

0 Likes

#4

I ran into this when I was on a Vera 2. The existing CIFS packages for Vera 3 (UI5+) wouldn’t work on my Vera 2, even though I was also on UI5.

0 Likes

#5

CIFS installed without a hitch on my vera3. I JUST hooked my edge and finished transferring everything from my vera3 to my edge, now I’m going to try these steps on my edge

stay tuned!

0 Likes

#6

rats.

this is a MAJOR problem for me as I bought the edge so that I could hook my 3 to the wi-fi in my condo and not have to pay for dedicated cable there.

–sigh.

[code]
root@MiOS_45002430:/tmp# opkg install kmod-crypto-md5_2.6.37.1-1_ramips.ipk
Installing kmod-crypto-md5 (3.10.34-1) to root…
Downloading http://download1204.mios.com/firmware/mt7620a/openwrt/ramips/packages/kmod-crypto-md5_3.10.34-1_ramips_24kec.ipk.
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-crypto-md5:
  •  kernel (= 3.10.34-1-3e1f0737091de4852204d1fc5fdc48c9) *
    
  • opkg_install_cmd: Cannot install package kmod-crypto-md5.[/code]

has anyone reached out to their support team to see what the timeline is for this ?

0 Likes

#7

[quote=“lionelandjen, post:6, topic:185496”]rats.

this is a MAJOR problem for me as I bought the edge so that I could hook my 3 to the wi-fi in my condo and not have to pay for dedicated cable there.[/quote]

Try use --force-depends when installing the packages and then reboot. I have mounted my NAS on VeraEdge.

0 Likes

#8

This sounds really promising, but adding that to the install lines still didn’t work for me, giving error “Unknown package ‘cifsmount’”.

Could you possibly post a full script - I’ve rather lost track of all the different flavours of suggestions to get this right - but delighted that at least someone has done!

0 Likes

#9

My test was not very systematic when trying to get cifs pkg installed. Before I got it to work, I even removed some of the packages and reinstalled them. But here are the rough steps that I think should work:

opkg update
opkg install --force-depends kmod-nls-utf8 kmod-nls-base kmod-crypto-hmac kmod-crypto-md5 kmod-crypto-misc kmod-fs-cifs

You will probably get some dependency errors. Just run the install cmd repeatedly and it will tell you that the packages are installed. Especially run opkg install -force-depends kmod-fs-cifs to make sure that the cifs package is installed.

Finally, restart VeraEdge.

I think I also had other kmod-crypto-* packages installed, but they probably either won’t matter or will be automatically added by the install command above due to dependencies.

The reason I used --force-depends is that I saw people in the OpenWRT community having similar problem recently. Looks like a package signature miss match between OpenWRT build. Some suggestions were to rebuild the kernel yourself and include the kmod-fs-* options. However, we can’t do that for Vera. That’s why I thought of force installation.

P.S.

  1. Using “cifsmount” as the package name won’t work. It shoukd be kmod-fs-cifs
  2. My VeraEdge is upgraded to v1.7.961
0 Likes

#10

OK, well, I guess this bit is good news:

# opkg install --force-depends kmod-nls-utf8 kmod-nls-base kmod-crypto-hmac kmod-crypto-md5 kmod-crypto-misc kmod-fs-cifs
Package kmod-nls-utf8 (3.10.34-1) installed in root is up to date.
Package kmod-nls-base (3.10.34-1) installed in root is up to date.
Package kmod-crypto-hmac (3.10.34-1) installed in root is up to date.
Package kmod-crypto-md5 (3.10.34-1) installed in root is up to date.
Package kmod-crypto-misc (3.10.34-1) installed in root is up to date.
Package kmod-fs-cifs (3.10.34-1) installed in root is up to date.

However, this is not:

# mount -t cifs -o user=XXX,pass=YYY,nounix,noserverino //172.16.42.100/DATAMINE /dataMine
mount: mounting //172.16.42.100/DATAMINE on /dataMine failed: Invalid argument

Do I have the mount syntax wrong, now? It worked before.

0 Likes

#11

[quote=“akbooer, post:10, topic:185496”]# mount -t cifs -o user=XXX,pass=YYY,nounix,noserverino //172.16.42.100/DATAMINE /dataMine
mount: mounting //172.16.42.100/DATAMINE on /dataMine failed: Invalid argument[/quote]

Did you reboot the device? I will check on my device again tonight.

0 Likes

#12

Yes, I did, and have done just now. Still the same. :frowning:

0 Likes

#13

Try removing some arguments. noservino is the first thing I’d eliminate and if that didn’t work, nounix until I found the argument that it doesn’t like.

Also, the /dataMine mount point does exist, right.

0 Likes

#14

akbooer, mine command was:

 mount -t cifs //{ip}/{sharePath} -o user={user},password={password}

I did not try nounix, noserverino. But looks like your problem is that the option should be “password” not “pass”

0 Likes

#15

Actually, “pass” has always worked, but changing to “password” still doesn’t help. Nor does removing nounix and noservino. Everything I try gives me:

mount: mounting //172.16.42.100/DATAMINE on /dataMine failed: Invalid argument

[ul][li]The mount point /dataMine is there (incidentally, in your example you don’t have one??)[/li]
[li]the remote server is there (and mounted on three other Veras under UI5)[/li]
[li]all the packages are apparently installed and up to date[/li][/ul]

…completely stumped. ???

0 Likes

#16

Actually, I do have the mount point, /dataYours. Just didn’t paste the command correctly.
Yeah, this is puzzling. I will check packages I have installed and report back.

0 Likes

#17

Hi akbooer,

Using the instructions I got it working on VeraEdge. Do you have the password in quotes? I found is you have special characters it won’t take it

Cheers Rene.

0 Likes

#18

Good for you! For me: no quotes, but only alphabetic characters.

0 Likes

#19

Hi Akbooer,

I actually just took your startup LUA to mount the cifs. Changed all instances of pass to password and works like a charm on Edge with UI7 and Lite with UI5.

Cheers Rene

0 Likes

#20

[quote=“dreamcryer, post:16, topic:185496”]Actually, I do have the mount point, /dataYours. Just didn’t paste the command correctly.
Yeah, this is puzzling. I will check packages I have installed and report back.[/quote]

Here is a list of my kmod-* packages:

kmod-cfg80211 - 3.10.34+2014-01-23.1-1
kmod-crypto-aes - 3.10.34-1
kmod-crypto-arc4 - 3.10.34-1
kmod-crypto-core - 3.10.34-1
kmod-crypto-crc32c - 3.10.34-1
kmod-crypto-des - 3.10.34-1
kmod-crypto-ecb - 3.10.34-1
kmod-crypto-hash - 3.10.34-1
kmod-crypto-hmac - 3.10.34-1
kmod-crypto-manager - 3.10.34-1
kmod-crypto-md4 - 3.10.34-1
kmod-crypto-md5 - 3.10.34-1
kmod-crypto-pcompress - 3.10.34-1
kmod-crypto-sha256 - 3.10.34-1
kmod-eeprom-93cx6 - 3.10.34-1
kmod-fs-cifs - 3.10.34-1
kmod-fs-exportfs - 3.10.34-1
kmod-fs-ext4 - 3.10.34-1
kmod-fs-jfs - 3.10.34-1
kmod-fs-msdos - 3.10.34-1
kmod-fs-reiserfs - 3.10.34-1
kmod-fs-vfat - 3.10.34-1
kmod-fs-xfs - 3.10.34-1
kmod-fuse - 3.10.34-1
kmod-gpio-button-hotplug - 3.10.34-1
kmod-ipt-conntrack - 3.10.34-1
kmod-ipt-conntrack-extra - 3.10.34-1
kmod-ipt-core - 3.10.34-1
kmod-ipt-ipopt - 3.10.34-1
kmod-ipt-nat - 3.10.34-1
kmod-ipt-nathelper - 3.10.34-1
kmod-ipv6 - 3.10.34-1
kmod-leds-gpio - 3.10.34-1
kmod-ledtrig-netdev - 3.10.34-1
kmod-ledtrig-usbdev - 3.10.34-1
kmod-lib-crc-ccitt - 3.10.34-1
kmod-lib-crc-itu-t - 3.10.34-1
kmod-lib-crc16 - 3.10.34-1
kmod-lib-crc32c - 3.10.34-1
kmod-loop - 3.10.34-1
kmod-mac80211 - 3.10.34+2014-01-23.1-1
kmod-nand - 3.10.34-1
kmod-nf-conntrack-netlink - 3.10.34-1
kmod-nfnetlink - 3.10.34-1
kmod-nls-base - 3.10.34-1
kmod-nls-cp437 - 3.10.34-1
kmod-nls-iso8859-1 - 3.10.34-1
kmod-ppp - 3.10.34-1
kmod-pppoe - 3.10.34-1
kmod-pppox - 3.10.34-1
kmod-rt2800-lib - 3.10.34+2014-01-23.1-1
kmod-rt2800-mmio - 3.10.34+2014-01-23.1-1
kmod-rt2800-pci - 3.10.34+2014-01-23.1-1
kmod-rt2860v2 - 3.10.34+r2714-7
kmod-rt2x00-lib - 3.10.34+2014-01-23.1-1
kmod-rt2x00-mmio - 3.10.34+2014-01-23.1-1
kmod-rt2x00-pci - 3.10.34+2014-01-23.1-1
kmod-sched-core - 3.10.34-1
kmod-scsi-core - 3.10.34-1
kmod-scsi-generic - 3.10.34-1
kmod-slhc - 3.10.34-1
kmod-usb-acm - 3.10.34-1
kmod-usb-core - 3.10.34-1
kmod-usb-dwc2 - 3.10.34-1
kmod-usb-ohci - 3.10.34-1
kmod-usb-serial - 3.10.34-1
kmod-usb-serial-belkin - 3.10.34-1
kmod-usb-serial-cp210x - 3.10.34-1
kmod-usb-serial-ftdi - 3.10.34-1
kmod-usb-serial-keyspan - 3.10.34-1
kmod-usb-serial-mct - 3.10.34-1
kmod-usb-serial-option - 3.10.34-1
kmod-usb-serial-pl2303 - 3.10.34-1
kmod-usb-serial-wwan - 3.10.34-1
kmod-usb-storage - 3.10.34-1
kmod-usb-storage-extras - 3.10.34-1
kmod-usb2 - 3.10.34-1

And I just unmounted and then mounted the NAS again:

mount -t cifs -o user=user,pass=pass //{myip}/DataYours /dataYours/

My password also contains only alphabets and numbers. Maybe just remove, reinstall the packages and reboot Vera?

0 Likes