Need to reset Vera Plus completely?

So, I took my two Fibaro FGS-223 down from the shelf and included them to my Vera since the current FW is supposed to support them.

No luck, Vera fails in configuring them properly. They work, but can’t be configured.
So after fiddling a while with numerous excludes/reset/includes, I gave up and got in touch with support.

Several rounds of exclude/reset/include later, support concluded that my Vera Plus needs to be reset since it once was upgraded from a Vera Lite on UI5 (it wasn’t, there was a Vera Edge and UI7 in between, but that doesn’t matter as I get it). And the upgrade is not compatible in one way or another, so I need to at least wipe out the Z-wave network and start all over again with inclusion of all devices. That means a major effort.
What is not clear to me is if I need to do a factory reset of the whole unit. Support says there are files there from UI5, but is unclear when it comes to if this is a problem I need to fix or not. They tell me to reset/clear Z-wave network.

Questions I was hoping anyone could assist me with:

  1. Second opinion: Could it really be true that a previous upgrade breaks current compatibility?
  2. If so, is there another way to fix that than to wipe it all out and start over?
  3. Can I verify by wiping out the network, then try to include the devices, and if it still fails would a restore bring my old network back?
  4. What if there is some old files on the unit that create problems, could a factory reset and restore help? Or do I need a complete rebuild of everything, building it from scratch?
  5. Any other suggestions?

Homeseer has a 50% discount this month, with free upgrade to upcoming HS4. Sounds tempting in this situation, but I would rather continue where I am.

Any insight highly appreciated!

So, support doesn’t answer my questions, just wants me to reset. @Sorin might want to take a look at that, not the kind of communication I would expect.
This community doesn’t seem to have answers either.

Too bad, but this was the last drop. Just purchased HomeSeer Pro to migrate it all, so thanks for the party. 10 years with Vera has been a bumpy road, hope it all works out for you.

Will try to give you a hand here:

  1. backup your setup (including your zwave network)
  2. Do a factory reset
  3. Add your new device and see if it works and configures properly. If so, support was right and you may want to continue building your network.
  4. If it fails then you can always restore from backup. Your network will be back.

My opinion: Having gone from the lite to the edge to the plus myself, the major change in terms of protocol was getting your controller from zwave to zwave plus and the difference in routing between the then not so good native zwave routing which the vera manually took over and the much better zwave plus routing which doesn’t require the vera routing. How does it affect your device compatibility? It shoudn’t. How you could have old UI5 files in your UI7? I have no idea. The only files of importance are your zwave dongle back up and your user-data.json. Everything else should come from your firmware updates and plugins so I have no idea what they could be. I too am very skeptical of the factory reset which… only wipes these two files, the plugin folder and resets your network configuration file.

Also if you are dealing with a seemingly large network… and reseting your vera enables you to add your fibaro which appears to support secure class, it is likely that the zealy zwave implementation on the current firmware has made your network way too busy to be able to configure your device and exchange the secure class key in particular. Just a thought… In that case, the fix is in the upcoming 7.30… unfortunately which enables you to disable all of the bloatware functions the old vera devs thought were good to add and cripple your network if you have more than a handful of devices.

1 Like

Hello, Thorden. I’m really sorry to hear about this. Looking at the ticket, I see you are affected by some migration issues.

Issue is described here: NOTE to customers who migrate from Vera2,3/Lite to VE/VP/VS

It’s not bad intention on behalf of the support team when they are telling you to reset. It’s just a side effect and a technical limitation of the said migration you did in the past and you have their full support with everything.

Thank you for your input and insight, rafaele77, highly appreciated. I wish support could have given the same answer on a direct question.

My network is not very large, around 40 physical zwave devices, some other plugins, virtual devices and child devices. Bunch of scenes and quite a lot of LUA code.
VeraPlus is pretty stable, but delays do occur frequently.

I will reset this unit and use it in my vacation home when I have migrated everything, let’s see if it works then.

Thanks, Sorin.

The post you linked to is dated almost two years after I first migrated from VeraLite to VeraEdge, so I guess that wouldn’t have helped me much.

I understand the support team can’t do anything about a technical limitation, but they should try to answer direct questions. I wanted to know if I could get back to where I was by backing up and restoring the unit, but never got a clear answer like rafalene77 gave above. Just that this would corrupt my z-wave network and I would have the same issue again. Not the right answer.
I obviously didn’t want to end up in a situation where I had to start all over again for no reason, in case the suggestion didn’t solve the issue. Hence the obvious question; could I restore it, or is the reset permanent? Should be an easy answer. The unit is in fact working OK, so keeping it untouched is definately an option instead of investing massive amounts of time rebuilding it. No good answer to that.
Neither did they answer if I needed to do a factory reset or not, so they was very unclear of what they wanted me to do, and what my options where. Even after direct questions, more than once. That was the main reason for my frustration.

No that’s history, I am moving it all over to HomeSeer thanks to this incident. I will keep the Vera Plus unit and rebuild my much easier installation in my vacation home from scratch with it. It is now running on a VeraLite which refuses to be upgraded from UI5. (another support incident telling me the memory was corrupted so it couldn’t be upgraded.)

© 2019 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy