Netatmo, username and password?

Hi,

Ive installed the Netatmo app and can enter the ClientID and ClientSecret. I also have my Netatmo username and password to enter but there is nowhere to enter username and password? See attached image. What am I doing wrong?

I’m new to Vera and my skill level is basic, sorry.

Pete

try restarting you Vera and then refreshing your browser (Ctrl + F5).

Have tried restarting and refreshing many times and no change.

Then I guess you need to try to install the plugin again, seems like something is missing.
Try grabbing the latest files from github -> https://github.com/akbooer/Netatmo/tree/development

I, too, have the same defect.
Yesterday, in the area of 10 GМT, communication with the weather station was lost.
I also checked the settings. There is no space for entering the password.
I was helped by a reboot, it all worked.
BUT! place did not appear

Just a thought - are they getting populated under the Params tab instead of Variables? Even the older 2016 code does seem to set the default username and password variables to ???.

There is also no :frowning:

[quote=“korttoma, post:4, topic:199166”]Then I guess you need to try to install the plugin again, seems like something is missing.
Try grabbing the latest files from github -> https://github.com/akbooer/Netatmo/tree/development[/quote]

I have installed these latest files and issue is still present.

Can you see it in the variable list?

http://vera_IP:3480/data_request?id=status&output_format=xml&DeviceNum=39(replace ‘39’ with your device ID and use the proper Vera IP).

Also, it is possible to go to the advanced tab and create the variables if they aren’t there. I believe you’d want to use the NetatmoSID:urn:akbooer-com:serviceId:Netatmo1

[quote=“jswim788, post:9, topic:199166”]Can you see it in the variable list?

http://vera_IP:3480/data_request?id=status&output_format=xml&DeviceNum=39(replace ‘39’ with your device ID and use the proper Vera IP).

Also, it is possible to go to the advanced tab and create the variables if they aren’t there. I believe you’d want to use the NetatmoSID:urn:akbooer-com:serviceId:Netatmo1[/quote]

Yes I can see the username and password in the variable list.
I manually created the variables and values and it now all works ok ;D. But can still not see them in the advance tab. Not an issue for now as I should not need to change the values.
Thanks for your help.

[quote=“peterpercy, post:10, topic:199166”]Yes I can see the username and password in the variable list.
I manually created the variables and values and it now all works ok ;D. But can still not see them in the advance tab. Not an issue for now as I should not need to change the values.[/quote]Perhaps this is a “feature”. Maybe the Vera is hiding these variables as a security precaution even though they are visible through other means.

HI NOVICE IN PROGRAMMING I DO NOT KNOW HOW TO MAKE MANUALLY CREATED MANUALLY CREATED THE variables AND VALUES AND VALUES J AI THE SAME PROBLEM AS ABOVE THANK YOU FOR YOUR SUPPORT A +

Type this into the UI page at Apps > Develop apps > TestLuup code (Lua)

luup.variable_set ("urn:akbooer-com:serviceId:Netatmo1", "Username", "XXX", DDD)
luup.variable_set ("urn:akbooer-com:serviceId:Netatmo1", "Password", "YYY", DDD)

where:

[ul][li]DDD - is the device number of your Netatmo plugin[/li]
[li]XXX - is your Netatmo account username[/li]
[li]YYY - is your Netatmo account password (avoid special characters)[/li][/ul]

then press GO.

thank you for the answer I will try to get to know you

:)ok all works thanks for the information

[quote=“akbooer, post:13, topic:199166”]Type this into the UI page at Apps > Develop apps > TestLuup code (Lua)

luup.variable_set ("urn:akbooer-com:serviceId:Netatmo1", "Username", "XXX", DDD)
luup.variable_set ("urn:akbooer-com:serviceId:Netatmo1", "Password", "YYY", DDD)

where:

[ul][li]DDD - is the device number of your Netatmo plugin[/li]
[li]XXX - is your Netatmo account username[/li]
[li]YYY - is your Netatmo account password (avoid special characters)[/li][/ul]

then press GO.[/quote]

We have the same problem with Blue Iris… can not set the Username and the Password anymore… Do you have any idea what could be the command for Blue Iris…

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules