new product from FIBARO: Fibaro Roller Shutter 2

-Control roller blinds, awnings, venetian blinds, gates and garage overhead doors,
-Power metering function allows for monitoring energy consumption,
-Advanced limit switch calibration mechanism which allows for precise positioning,
-Five individual operating modes allowing for the proper configuration and correct operation,
-Manual and remote operation by FIBARO interface, mobile devices and wall switches,
-Advanced association functionality allows for creating groups consisting of other FIBARO devices,
-Wall mounted Emergency Button,
-IR barrier integration,
-Automatic Gate Closing,
-Alarm System integration,
-Safety mode, cuts off wall switches when motion inside or outside has been detected,
-Z-Wave Range Tester


I like to share my experience with these sutter switches.

I bought two of these to control my sunscreens.
The screens are installed with spring switches, which I have to hold until the screens have reached the position you want them to or until the end contacts switch them off.
I installed the new fibaro FGRN-222 between those spring switches and the motor of the sunscreen.

Now I can control the screen via my vera or by a momentary turn of the spring switch (I don’t have to hold them anymore). Another turn on the spring switch will stop the screen in its movement. Very nice feature.

I created a scene in vera so I can control the screens with my kaku remote (via rfxcom).

I am very pleased with these fibaro shutter controls.

Fgrm222 has a feature to control the tilt of roller blinds. How does the device show up in Vera? Ideally there would be two slider controls: one for the positioning of the blinds and one for the tilt angle.

I don’t use them that way but the control looks like this

Thank you for looking into this @Benji! It looks exactly like the control on my FGR221. To enable the tilt feature a device variable has to be set. I ordered a bunch of the new modules, but I doubt vera will support the feature right from the start.

I have 1 module fgr-221 that control my blinds. I’ve found that to leave the blinds as I want I have to put 11% in vera lite, so they are closed (touching the floor), but stay with some holes open to get some clarity in the room.
The problem is that if for some reason I need to open or close the blinds manually by wall outlet, then when vera lite executes the closing of the shutters to 11%, they are not as I want… Then I have to check again and again to see what the best % wanted to remain as before. This is why I ask if the module FGRM-222 is more sensitive to the point of checking meticulously exact positioning.

Cause I have saw this advertising:

-Advanced limit switch calibration mechanism which allows for precise positioning

@p lopes

I don’t have blinds with shutters (just sunscreens that can go up or down), so I cannot test it for you.

The FGRM-222 have a calibration mode(parameter 29) to allow them to callibration the position.
You set the screen in the down position and after putting parameter 29 in you execute “Configure node right now” and the FGRM-2222 will calibrate itself by finding the most up and most down position.
I think this is what you are looking for.

Hope this info will help you


Was exactly what I was looking for!!! Many many thanks!!!

By the way, on my Vera Lite where can I put this parameter 29? It’s possible to send me a print screen please :frowning: ?

@ p lopes

First of all make sure that your blind is in the down position(as far as possible).

Then go to vera, choose the configuration screen of the FGRM-2222 and choose the tab “Device Options”
You should see a screen like my first attachment.
Then click on “Add configuration settings” and the screen will look like the second attachment.
Variable “1” into “29”
Data Size “monitor only” into " 1byte hex"
Desired value in “1”
The screen should look like the last picture.

Get out of the configuration screen of the FRGM-222 (click on the “X”).
Then click on the save button of vera. You will get an error saing that vera cannot set this parameter but thats normal.
The FRGM-222 wil perform a calibration cycle by going up, down and up again.
After this the FRGM-222 is calibrated.

Many, many, many thanks in advance for this tutorial that should be available for all those who are starting with VeraLite :wink: :wink:

Please, can you confirm me if

Data Size “monitor only” into "

1byte hex or 1byte dec

So, as you say it, I will put the blind is in the down position - 100% close do you mean?

If you put in a value of “1” then there is no difference between Data size “1 byte hex” or “1 byte dec” so either will do ( used hex I think)

I have sunscreens that go up and down so down is closed.
It also depends on how you wire things of course.
The important thing to remember is that the calibration process must go through one and a half cycle (up, down and up again) or in your case (open, close and open again).
If this is not the case then you started in the wrong position.

Don’t be afraid to make mistakes. The callibration process can always be repeated.

The number 1 is the same in decimal or hexadecimal so it doesn’t matter which you use.

Sent from my Nexus 7 using Tapatalk 4

Thanks a lot!

Can you see if i’m doing well, or please, if I don’t, please let me know:

-Connect only L+N to the FGRM-222
-Pick Vera Lite and take near to FGRM-222
-click on the “battery buton” on Vera Lite to do the mode add device
-on the FGRM-222 click 3 times on the B button with a little screw
-see if VeraLite start blink fast (orange colour)
-If yes ( start blink fast orange colour), it’s done and I can press de button on the Vera Lite to add device

This is what I have done to add the FGR-221… but was not sure if I did it right…

Be my guest to tell me what I’m doing wrong or right

Seems ok to me.
If you connect the vera to your netwerk and open the userinterface do you see the new device ?

Sent from my ASUS Transformer Pad TF700T using Tapatalk

I didn’t receive it yet…

only friday, but I wanted to know how to use it this device upgraded from FGR-221… Because this FGR-221 was not doing proper positioning of my roller shutters.

So when I saw this advertising

“Advanced limit switch calibration mechanism which allows for precise positioning”

I was very excited to see this works properly!


I have a litle problem…

I have done this

Variable “1” into “29”
Data Size “monitor only” into " 1byte hex"
Desired value in “1”
The screen should look like the last picture.

Get out of the configuration screen of the FRGM-222 (click on the “X”).
Then click on the save button of vera. You will get an error saing that vera cannot set this parameter but thats normal.
The FRGM-222 wil perform a calibration cycle by going up, down and up again.
After this the FRGM-222 is calibrated.

but appears a red line under the window of the device, saying some error… and then, If leave that 29 - 1 hex there, in one hour, my house seems a carrousel… windos shutters perfoming a calibrate cycle a few times in 1 hour :frowning:

and than, I took out the line 29 - 1, and now, they do the schedule that I want, but appears allways 100%

please see my images, attach

any help?

What I have done is :
Put the shutter manualy in the 0% position.
change variable “29” into “1”
save the configuration on vera
Then the sutter will go through a full calibration cycle and will end at 100% position
Then you change the valua of variable 29 into “0” again otherwise blinds will keep on calibrating.

hope this helps!


I have done that… after calibration process, I have change value from 29 - 1 to 29 - 0, exit and save.

However, when I go to the dashboard, all my windows shutters show me that they are on 100% - and they are not, they are at 10%.

Anything that I’m still miss?


I’ve experienced the same issue a couple of days ago.

Polling from Vera to these devices is not working fine.

Set polling to 0 (not polling) instead of 60.

Problem fixed

Happy new year


Can anyone confirm if ToggleState is working for the Fibaro FGRM222 roller shutter module in UI7 ?

I am using a Vera Edge UI7 firmware version 1.7.1419. I have successfully calibrated the module OK.

However I need to create a scene for my Aeon Minimote so I can use one button on the remote to Toggle the curtains either open or closed.

This worked perfectly fine on my old VeraLite UI5 but in UI7 it doesn’t seem to work properly.

If the curtains are open and I run the togglestate scene the curtains close, if I then run the scene again the curtains should open, however they do not and remain closed. I can hear the module switch but its not opening / toggling the state.

I also have another Fireplace ToggleState scene with an Everspring On / Off plug switch and that works fine in UI7, just not for the roller shutter module.

EDIT: I added it as a Generic Device as I couldn’t see it listed elsewhere.


Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules