Newly Integrated Devices on Ezlo Platform 2020-Nov-18

This is not a new request. In may this year Pitt and myself asked this and this was promised by MCakan:

Lol the discussion…
For me what makes the most sense is to see this list in alphabetical order of the manufacturers on the site. Someone who buys a box will look to see what is compatible on the site …
But I also think that a simple link allowing an extraction of this list in Excel would be welcome or a search banner in this list on the site

Come on guys, just a simple copy/paste of the list into excel already gives you the option to manipulate this data in any way which suits you. Took me a mere 3 secondes to have it ordered by name.

Once the new platform is finished and actively marketed, it would make sense to create a user-friendly list of supported devices.

There’s no place on the Internet where I can find a list of the new beta Apple homekit device support which will be supported in a production-level solution in 6 months time. And no one is complaining there.


We will have them also under a gsheet doc (like this) that you can view or copy the data in it to anywhere else if you want to change it. We will share the links in the general posts.

1 Like

Will the team be looking to integrate more TKB Home devices ?

There is currently only one on the list a Dual Paddle Wall Switch - TZ66-D.

I have some TKB Home devices, a Thermostat TZE93.716 they also have several other model numbers for Thermostat devices.

And I have some TZ77 RGBW Dimmer modules for LED strip lights.

TKB Home have a large range of Z-Wave products as you can see here.

Thank you.

sorry to say it like that but apparently the requests made on the forum on certain materials are not priority even if they are used more than others … it’s been a few months that we ask for the smart fibaro implant and the Aeotec siren but for the moment they are not part of the last list of material …
Apart from the forum I do not see where to ask for an integration of materials …

Hi @cw-kid. Yes, I checked again and see that we only had samples of TZ66-D and integrated that. For the rest I’ll check and add them to the samples needed list if they are not yet there.

1 Like

Just to clarify, as long as these devices comply with the Zwave standard, then Ezlo should work now! Try it as a generic device.
We use the Zwave Interview process that enables Ezlo hardware to work with any Zwave device automatically (no integration required).

However, there are some devices that has “quirks” that require additional code (they fall under naughty device manufacturers category btw) that sometimes require us to modify things to work with that device.

Also, we physically test anything we put on our website as “integrated”. Like I said, as long as device manufacturer has followed the zwave protocol properly, then you can simply use it without any problem.

So to summarize

1-Any Zwave device should work (as long as device manufacturer has followed the Zwave protocol properly) (try to use those devices, include them as generic zwave and see what happens)
2-We only put as “integrated” after we physically test it.


Thank you.

I’m not sure about the US market as I am in the EU.

But for the EU market “TKB Home” is a large Z-Wave manufacturer and as you can see have an extensive range of Z-Wave products and usually at reasonable pricing.



Hi @melih
If I ask Ezlo for this integration is that the device does not work as it should according to its manufacturer compared to the box, I have already tested on my VeraPlus, I will try on the EzloPlus but I am sure of waste my time otherwise it would have worked well on my VeraPlus in generic zwave inclusion. I am doing the test and I will keep you posted, as for the rest but I would like to have a feedback from the team this time because the other tests and trials on my Fibaro FGS224 and my valve still hear that the team connects to my EzloPlus, I created an access for them at the request of @Ioana and for more than 4 weeks nothing, no feedback. However the valve works well, it is enough just to invert a variable to have the good state, for the FGS224 it is more complicated, well I think, but as I have no feedback from the team I have not want to add more device from my VeraPlus (40 device) to my EzloPlus knowing that according to my tests many are inconclusive (around 65-70%) and are reported to the Ezlo team.
In any case, I see that the application is progressing well and that the updates are linked with new features but the problems are not solved like the sunrise / sunset for example. The reported translation errors are still present (home-away-night-vacation mode) these are simple things to rectify and yet this is not done when we are told that it is reported to the team. I hope there will be a lot more discussion and feedback with the beta testers as we are spending time with you trying to move the solution forward without being informed of what is happening on what we have reported. and it is unfortunate and frustrating. I hope you will not take this message badly because it is not my intention.
Best regards

How is this meant to work ?

280 Heiman HS1CA-Z

Is listed in your document.

However when I try to add this device I cannot find it in the Vera mobile app.

If I search for Heiman no results are returned.

If I look in the Sensors section no Heiman devices are listed.

I then tried to pair it to the Ezlo Plus as a Generic Z-Wave device, however as yet I am unable to get that working either.


Thanks for the feedback @cw-kid. When I check it I see that there is no Pairing Wizard for pairing but it is fully integrated with Ezlo platform if you pair it as a generic z-wave device. There were 2 android issues found and solved way back during integration period. I’ll create a ticket to inform the teams and to check it again what might be the reason for this.

Thanks for the feedback, very valuable!
sunrise/sunset has been fixed with the latest version of the beta that we should be launching (code has been completed)…
One thing for sure, all our development is writing code, every day! So we will go thru all these issues, just matter of time. There is a “HUGE” amount of investment going into it. It just its a lot of work, I mean a lot! But that only means its a matter of time…one by one they will all be coming…the key is : Investment is being made into this code base to continually build it.


Thank you for you feedback!

Regarding sunrise/sunset issue: On Android app, starting with version 7.50.583 you can find a new option in Settings->Unit settings that will allow you to configure your controller’s location. If the controller location is right, sunrise and sunset will work properly.

For the iOS users this feature will be available in the next beta update (in review as we speak).

Fibaro FGS224 is not officially integrated on our EZLO controllers, but we added it on our list.

Could you please tell me the model and the manufacturer of your valve? We have some issues on our backlog about reversed states and I want to check if your valve is on the list.

Could you also tell me again what are the translation issues you noticed in the app so I can send them directly to the team?

Thank you,


Asking for all products from Qubino… most of them need integration :frowning:

I see, so if there is no Device Pairing Wizard the device is not listed in the app. That makes sense I guess, however from a dumb users point of view, if a device is supported by Ezlo, when I search for that device in the app to add it, I’d like to see it listed in there, even if when I select it, it just navigates me to the add Generic Z-Wave device wizard.

It could give some users some comfort knowing their device is listed and that they found it in the app. Anyways…

I was pressing the button on top of the device inside the battery compartment. However I have just noticed there is a small pin hole on the side of the device and its that button I should be pressing 3 times.

So on the Ezlo Plus I tried to add it as a Generic Z-Wave device again and this time it detected the device, the Vera app then asked me if I wanted to pair the device in Encrypted mode or Unencrypted mode, I selected Encrypted and now the device is just flashing rapidly with a Green light and I cannot see that the device has been added in to my device list in the app.

The Generic Z-Wave device wizard didn’t ask me to name the device or assign it to a room, after I selected Encrypted mode, it just took me back to the regular list of devices on the hub, so I don’t think it worked correctly.

After some time the device stopped rapidly flashing Green and now its flashing green slowly about every 30 seconds and I still cannot see the device listed in the list of devices.

Looking in the user manual for the LED pattern it says its normal:

Green LED flash 1 time
every 30 seconds
No sound

The user manual specs state this, so presumably that means it supports Encrypted Mode.

Security 2 Version 1

I then closed the Vera app and opened it again, however I still cannot see the new device listed.

I then checked the API tool using hub.devices.list and presume they are in the order of first added device to last added device?

The last device is number 81 and is an Everspring Siren and not this Heiman CO sensor. So don’t know what’s going on?

I then tried to pair the device again to the Ezlo Plus and got “The inclusion process has failed” message popped up. I then tried to remove the device which seemed to work. Added the device again and now I am at the Encrypted or Unencrypted page again. I selected Unencrypted this time and now its asking me to give it a name and assign a room.

The next screen I see is the Devices list page: Room / Type / List etc and its totally blank no devices are shown at all they have all vanished. Dragging down to refresh this page does not bring them back. Navigating to another area of the app like Scenes and then going back to the Devices does not bring them back.

So exit the app launch it again and now the devices are all back again.

Now in the room I assigned I can see the device named “CO Sensor” with 100% battery.

So hardly a good user experience trying to pair this device to the Ezlo Plus.

Looking in the API Tool again I now see the new device 82:

_id: "5fb7cc43120bab1240a67710"
armed: false
batteryPowered: true
category: "security_sensor"
deviceTypeId: "608_32773_4096"
firmware: Array[1] [{"id":"eu.608.32773_4096.0","version":"2.0"}]
gatewayId: "5edaf25700000014fe72ac9e"
info: Object {"firmware.stack":"5.3","hardware":"255","manufacturer":"Heiman","model":"HS1CA-Z","protocol":"zwave","zwave.node":"8","zwave.smartstart":"no"}
name: "CO Sensor"
parentDeviceId: ""
persistent: false
reachable: true
ready: true
roomId: "5f4e2fa7120bab1069c13c45"
security: "no"
status: "idle"
subcategory: "co"
type: "sensor"

Attached is the user manual for this CO Sensor.

HEIMAN HS1CA-Z manual Gen 5.pdf (167.7 KB)

Thank you for your time and effort of the very detailed explanation of your case. This will help a lot. As a side note I’m happy that it worked for you after all this hustle. I’ll copy your whole case in the ticket so that it is checked to see what might be the reason for this.

@Oleh or @Oleg one of them, is on Skype with me, he says he is checking it. He also has remote connection to my Ezlo Hub currently.

1 Like

Hi Adina

Topic for the valve

Translation topic

Hi MCakan

The same CO Sensor pairs to my production Vera Plus effortlessly with no problems what so ever. See this thread for full details.

The is a specific device pairing wizard on Vera for this CO Sensor also.


Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules