No online server backups showing

Logged in and looking and the backups tab and nothing is showing. Used to be able to choose from a list of server backups but i don’t see anything listed.

I am logged in.
Cleared my cache
Tried another browser

Any idea how I can get a recent backup to restore from?

M

As far as I know your backups ar tied to your username. Make sure you are logged in with it through home.getvera.com.

I have - from multiple computers but nothing showing

FYI. Not that it helps you, but I see daily backups for my Lite, Edge and Plus. Have you logged on with your account admin UID?

Cheers Rene

I have. When i called support they told me their backup servers are doing maintenance and they would send me a file soon.

I tried from three computers and incognito browsers. I am logged in

I recommend a local backup, if you have another computer running 24/7 in your network.
I’m doing it daily and it’s the best decision ever.
There was a post with instructions by @rafale77, but it got deleted. I still use it, but I think it’s better if he posts it here :slight_smile:

1 Like

Hmm I woke up to find some homework to do. Thanks! :laughing:

I wonder why these posts were deleted… again without any notification. Since the content had no modification on the vera itself whatsoever, this is starting get out of hand.
Attached is the script to be put on a linux machine on your network. I have mine on my openLuup machine which is a VM but could be a rPi or anything else running linux.
Open the zipped file and put it somewhere you know and edit the destination folder of your backups. I would recommend to create a new folder somewhere and put the path in it. Also edit the IP of the vera.
Now remember where you put your script and copy the path into a crontab task. I run mine once a day. It is really equivalent to what the vera servers do through a constantly open tunnel and the process is the same as what happens when you hit the “backup zwave network” button followed by “create a backup” button but just from a different machine. This script also rotates the number of backups to be kept on your server and you can determine how many should be kept. The default is 30.

backupvera.sh.zip (1.1 KB)

2 Likes

I hate to say this, but I think there’s an error in this:

wget -O /dev/null "http://IP:3480/data_request?id=action&DeviceNum=1&serviceId=urn:micasaverde-com:serviceId:ZWaveNetwork1&action=BackupDongle&Restore="

vs

/usr/bin/wget -O "${BACKUP_NAME}" http://192.168.0.9/cgi-bin/cmh/backup.sh #?external=0

?

C

1 Like

Yeah you need to replace the IP in both locations. I wrote it for my own use and went a little too fast sharing it. Let me modify it and give a better version.

1 Like

I replaced the file. You have to edit the location and the IP address at the top of the file and if you want, the number of backups. It should work now.

FWIW I can’t use that absolute path to wget on OSx Catalina. But clearly modified to work perfectly, thanks.

I hate ‘correcting’ people that are way better at this ‘stuff’ than I, but it’s my skill spotting anomalies…

C

I see, indeed running it on various platform may require a different path to wget. ubuntu/debian have an environment path leading to the program. Thanks for notifying me!

No biggy! just ‘wget’ on my install of Catalina works fine.

Of course there’s another issue about getting the damned thing to run regularly but I’ll maybe sort that next week…

C

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules