Plugin: Bridge Vera with Ezlo: VeraBridge for Ezlo

Hi,

As I am finding more and more newer devices are not working on the Vera FW (especially S0 and S2), but are on the Ezlo FW, I am now in a situation that I have to use both. For most situations my EzloBridge on openLuup is working. However, I have some devices on the Ezlo that need to control devices on a Vera. Hence this plugin. VeraBridge for Ezlo is a simple way to replicate devices from your Veras or openLuup on an Ezlo Plus and include it in scenes on the Ezlo as trigger or action.

The files are on github : https://github.com/reneboer/ezlo-VeraBridge.

Let me know what you think and report any issues you may find.

Cheers Rene

4 Likes

Nice one Rene !

I just installed the plugin files and add my “Lounge Main Light” from the Vera Plus to the Ezlo Plus.

This is a Fibaro Dimmer 2 module.

I will add some more devices and have a play with it.

@Rene

We are able to create some other virtual devices on the Ezlo Plus like Window Covering, Blub RGB.

These are not currently supported by the VeraBridge for Ezlo ?

Thanks

Battery Powered - (FIXED)

Adding this line to the devices code in the JSON file to make a battery icon appear in the Vera mobile app.

"battery_powered": true,

Example:

},{
			"behavior": "dw_sensor",
			"device_id": 342,
			"battery_powered": true,
			"name": "Patio Door",
			"room": "Kitchen",
			"room_id": "5f4e2f68120bab1069c13c41"

However all the battery levels in the Vera app are showing as 100% not the actual current battery level values.

Dimmer Devices - (Bug?)

Appear to be working Ok, I can turn them on and off and dim them with the slider.

EDIT: Slight issue if you turn on a Dimmer device using its On button in the Ezlo hub, it correctly then shows as 100%.

However if you then look at the same light In Vera it shows as 99%.

If I randomly move the dimmer slider in the Ezlo to a percentage say 66% then that does work OK and also shows 66% in Vera.

Switch Devices - (FIXED)

Only appear to turn off. They do not turn on.

When I turn on a switch device on the Vera Mobile app connected to the Ezlo Plus, whilst looking at the UI7 of the Vera Plus I can see that it says “Success! Transmit OK” however the real switch on the Vera Plus doesn’t actually turn on.

As I said turning off works OK.

I am just testing with some Everspring Appliance plugs.

Temperature Sensor - (Working)

I just added an onboard Temperature Sensor off a Neo CoolCam motion sensor.

The device has been added in to the Ezlo Plus / Vera mobile app however the value hasn’t appeared its showing as 0.0 C.

EDIT: I took the battery out and back in now the temp is showing on the Ezlo Plus OK.

Light Sensor LUX - (FIXED)

I’ve added two light sensors and neither are showing a reading both say 0.0 Lux

Door / Windows Sensor - (Working - except no armed / disarmed status feedback)

Sensative Strip - Tripped / Not Tripped works OK.

However the Armed / Disarmed button doesn’t. No change is seen for this device on the Vera Plus.

Motion Sensor - (Working - except no armed / disarmed status feedback)

Motion sensors I’ve added two a Neo CoolCam and a Fibaro, both trip and un-trip OK.

However the Armed / Disarmed button doesn’t. No change is seen for these device on the Vera Plus.

Power Meter - (Working)

I’ve added two Power Meter devices which appear to be working. I am using a CurrentCost EnviR energy monitor and the old Vera CurrentCost plugin.

The devices created by the VeraBridge for Ezlo are showing Watt values OK. Would be nice to hide the other unused values from this device but I guess that is an Ezlo device thing rather than the VeraBridge itself.

Smoke Sensor - (Untested)

I was also able to add a Smoke Detector device using “smoke_sensor” I’ve not tested it however to see if it trips. Did you miss this device in your documentation?

Humidity Sensor - (Working)

Appears to be working OK.

UV Sensor - (Working)

Appears to be working OK.

FEATURE REQUESTS:

Wish list for supported devices:

  1. Generic IO Device - urn:schemas-micasaverde-com:device:GenericSensor:1

  2. Boiler Receiver Switch - urn:schemas-upnp-org:device:Heater:1
    device_file - D_Heater1.xml
    device_json - D_HeaterTempWithOnOffNoBatEvent1.json

  3. Thermostat - urn:schemas-upnp-org:device:Heater:1
    device_file - D_Heater1.xml
    device_json - D_HeaterTempNoOnOff1.json

  4. Roller Shutter - urn:schemas-micasaverde-com:device:WindowCovering:1

(ADDED but has some issues see here.)

  1. Siren - urn:schemas-micasaverde-com:device:Siren:1
    device_file - D_Siren1.xml
    device_json - D_Siren1.json

(ADDED but device doesn’t turn on of off in the app, see here.)

  1. Dimmable RGB - urn:schemas-upnp-org:device:DimmableRGBLight:2
    device_file - D_DimmableRGBLight2.xml
    device_json - D_DimmableRGBLight2.json

  2. Dimmable RGB - urn:schemas-upnp-org:device:DimmableRGBLight:1
    device_file - D_DimmableRGBLight1.xml
    device_json - D_DimmableRGBLight1.json

(ADDED dimmer_rgb but cannot change any colours, see here.)

Thanks.

Hi cw,

Thanks for the feedback. I’ll have a look. Also for window covering and RGB.

Cheers Rene

Hi

Thermostat is another virtual device we can add, along with Door Lock and Garage Door, they are all listed on that thread the ones I figured out from their documentation.

Found the problem with the switch. The armed is not so simple as it is a device attribute and all others are items of a device. The published API documentation does not specify how to change the armed status from Lua. Asking the developers.

Cheers Rene

Not sure if this helps or not? These commands were from the HTTP server API.

Example Armed Command:

https://192.168.0.11:17000/v1/method/hub.device.armed.set?_id=5f4e588c120bab1069c13c4f&armed_bool=true

Example Disarmed Command:

https://192.168.0.11:17000/v1/method/hub.device.armed.set?_id=5f4e588c120bab1069c13c4f&armed_bool=false

If a switch is turned on in the Vera Plus, and then that “same” switch on the Ezlo Plus also changes itself to be ON.

How are you updating that device on the Ezlo hub?

Presumably it polls the Vera Plus? How often? And then using LUA code to update that switch on the Ezlo hub.

Hi cw,

I am looking for the equivalent to use in the Ezlo FW Lua. Not sure it exists and that would mean you can only display the Armed status of a Vera security sensor on Ezlo, but not change it.

The Vera(s) are polled with a 5 seconds interval. Much like the VeraBridge works on openLuup. Only this is a much simpler version.

I may look at a way to bridge scenes so you can run a Vera scenes from Ezlo. That can also be a workaround for the Armed status.

Cheers Rene

So what’s the current functionality as is?

I have a motion sensor currently Armed in Vera.

But that sensor on the Ezlo isn’t showing as being Armed.

Thanks.

Just downloaded the files again from Github.

I can confirm that the switches now work OK and turn both on and off.

Thanks.

Just posted a new version. Has a fix for the light sensors. You can now also arm/disarm a Vera security sensor from the Ezlo. However, at this moment it is not possible to reflect a change made on the Vera. this is due to a limitation on the Ezlo FW side. I have asked to have this added.

The battery level is showing correctly for me. Make sure you only set battery_powered to true on the Vera device that shows the battery icon and not on the child devices.

Also note that the purpose of this plugin to allow (some) control on Vera devices from Ezlo, not for configuration or anything. I will add some of the ones you have listed, but locks i am not sure because of security.

Cheers Rene

I had to recreate my VeraBridge.json file as I accidently overwrote it LOL.

I can confirm that the battery levels are now showing correctly and the LUX sensors are now also showing values.

Thanks

Is it possible to change a switch icon (plug) to a bulb icon somehow?

Thanks

I can confirm this works, on the Ezlo hub in the Vera app, I can now arm and disarm security sensors OK that reside on the Vera hub…

However as you said we really need the armed / disarmed status of the security sensor to be reflected from the Vera hub into the Ezlo hub.

I do hope that they add this functionality in to the API for us !

Who did you ask at Ezlo about it ?

For now I am just looking at functionality and not appearance. I’ll add sub categories to the to-do list.

Cheers Rene

The development team.

The github version is updates and has the dimmer_rgb and window_cov added. The heater is added but I cannot get the controls to show, it now only displays the CurrentTemperature. Siren is added, but not tested.

Cheers Rene

Hi Rene

I’ve just added some Window Covering devices.

The percentage slider 0% to 100% works and opens and closes my curtains.

The up and down buttons work OK and change the percentage in 5% increments.

However the Stop button doesn’t seem to work at all and neither does the Open or Close buttons. I think this is an Ezlo problem however not with your bridge plugin.

Cheers.

I have edited the VeraBridge.json file and added a “Siren” device. Its added the device seemingly OK in to the Vera mobile app, however when I press the button to turn on / sound the siren, nothing happens the button in the GUI does not change to “ON”. The app does popup and say “Command Sent” however.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules