PLUGIN: Honeywell Total Connect Comfort Thermostats

I don’t think the plugin has anything to do with the actual unit. It interfaces directly with the Honeywell website.
For some stupid reason, Honeywell has different formats for different countries. I know that if you are in Australia it probably wont detect any thermostats as we are slightly different again for some reason. Most other devices that interface with the TCC website don’t work for Australia either. Last I checked IFTTT didn’t. You can register your thermostat as if you lived in the US but then your times and weather are wrong.

Mine works in Australia but only because ages ago the interface was different and Vera could detect it. If I do any searches now it doesn’t get discovered. I’m very grateful for backups otherwise I’d lose the functionality.[/quote]

Thanks for the reply. I’m in the U.S. so no idea why it’s not working. As I mentioned before, it says it connects successfully and “devices found”, but nothing shows up in the plugin. Ugh.

Hi Guys,

Long time lurker and contributor but cannot get access to my email so had to register a new account! I’ve said it before but… thanks for this plugin, it’s fantastic :-).

Question:

  1. Added a new radiator valve / zone to my system. Plugin has detected it (I can see it in the ‘Status’ tab) but for some reason it hasn’t created a device in the ‘Devices’ tab? Any ideas why or how I can get this to work?

I’ve disabled and re-enabled it in the status tab but still doesn’t seem to show. Hit refresh on the status tab too but still nothing. Any help appreciated! :slight_smile:

I’m considering to install zone heating in my home with Honeywell Evohome. Is this plugin still working without issues on most recent 7.30 or 7.31 beta firmware?
Who is still using it?
Thanks in advance!

I have this plugin working on 7.31. I can set temperature and set it to the “away” mode. That’s all I use it for.

I still use it too. Only thing to be aware of is if you’re in Australia it only has partial function.

This plugin still works fine for me, but make sure you download the newer Lua files found within this giant thread. Otherwise, you don’t get full functionality of the fan and circulate options.

So I can’t find the files associated with the newest version of this. It looks like it was supposed to be on post 683, but there are not attachments on this forum or the legacy forum anymore. Anyone want to post their unchanged versions that work with 7.31?

I can see the files can be downloaded from the old forum. Check this old page: http://forum.micasaverde.com/index.php/topic,30125.495.html it contains a link in post 504 to the plugin files. Problem is that have to browse all pages to find later updates if you need those. I’am actually not sure what parts I have installed/updated on my VeraPlus.

1 Like

Post 683 did contain the Lua file for fan control, but it is no longer attached. It still has the attachment icon in the old forum, though.
I’ll try to download a copy of mine and attach it here when I get a chance.

I think you need to login in the old forum to be able to download.

You are correct! Just logged in and was able to pull the file.
Unfortunately, can’t post a Lua file without it being zipped in this new forum. Can’t zip the file while I’m on mobile. If nobody else gets to it first, I’ll try to do it later today.

L_HoneywellTCC.zip (20.2 KB)

This is the file from post 683. I am not running the newest firmware or beta firmware due to all the problems there. This should still work, though.

Awesome, thanks!

The plugin stopped working for me few days ago. EMEA was my option and gives me error on login. User authentification failed.
everything is correct.
Is somebody else experiencing problems?
For me its been running for many years up to now

Yes, I also have a problem with the plug-in. And for me it has been running for many years so far
I use also EMEA

Status: Unsuccessful. Error code: 4

Same issue here, as of 2 days ago my plugin suddenly can’t login, I verified that the tcc login works for me on their website and can indeed control the thermostats, just the plugin can’t connect with the error code 4.

1 Like

Same here started 2 days ago

Same here – noticed this last night.

I tried deleting the plugin, re-creating the device, and even changing my credentials and nothing helped. At first I was seeing “Invalid Token” in the logs, but after I deleted the device and changed my password they just say “HNYWL TCC ERROR: TCC authentication error”. Honewell app and website both work fine.

I am having the authorisation error from the plugin. Running Beta2. Honeywell’s iPhone App is working.

It looks like this is a pretty easy fix. The last firmware updates provide a new version of LuaSec, the library that underlies the HTTP/SSL module the plugin uses (this is an important and necessary update, as the LuaSec module has been way out of date for a long time and is missing ciphers that are well on the way to becoming mandatory). This later version of LuaSec requires that the “protocol” option be set in requests, which the plugin is not doing (and thus causing an error).

I’ve patched up the plugin, and the file is attached below. Someone else needs to test and confirm the fix–it’s working for me, but one data point is worth very little. The author of the plugin needs to integrate these fixes throughout the code as needed for the new LuaSec. I’m happy to confer as needed.

Download, unzip, and send the one file up to your Vera via Apps > Develop apps > Luup files.

THIS PATCH SHOULD ONLY BE APPLIED TO SYSTEMS RUNNING 7.31 AND UP

EDIT: Updated file to include prototypical fixes for all platforms (EMEA, etc.–I can only test legacy/US)

L_HoneywellLib_legacy.zip (24.0 KB)

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules