PLUGIN: Honeywell Total Connect Comfort Thermostats

hopefully 7.31 goes to production soon

When you refer to systems running 7.31 and up, what are you referring to? The plugin stopped working for me and I am on firmware 1.7.4452. I tried the new files you uploaded but they don’t seem to help.

Thanks for your work on this!

No, they wouldn’t. I can take a pass at a more comprehensive fix that might also work on older firmware, but as my earlier message says, the old version of LuaSec on firmware 7.29 and prior is in danger of not having ciphers/features that some sites are now requiring as they enhance security. Give me a bit to make a new pass at this for that older firmware, and we’ll see where we end up.

What platform are you using (TCC, Euro, mobile, EMEA, etc.)?

I use TCC, personally. If you can implement the fix for that, I would be much appreciative.

Is the 7.x series of firmware for a different set of devices? I’m on the Vera Edge myself.

7.x applies to all legacy Vera devices (but not Atom or PlugHub). Stay tuned… updates coming…

1 Like

I am on 1.7.4453 on a Vera Plus and it stopped. If you can fix this @rigpapa, please add the updated Lua file floating around that I reposted in post 772. This fixed missing fan features.

Unfortunately, the original author and the 2nd author are both gone to my knowledge. I wish Ezlo would add native support for Honeywell thermostats like most competitors.

Edit: firmware is 7.0.29 to help clarify

OK. This ZIP file includes all API interfaces with adjustments for both LuaSec 0.5 (firmware 7.29 and below) and LuaSec > 0.5 (firmware 7.30 and .31 except Vera Edge). This also includes the fan-fixed version of the plugin implementation file referenced in the prior post by @Nameless, so this ZIP file contains a comprehensive update of everything (as far as I know) since the app store release. (24.4 KB)

If you all would test please and report back success or fail and your firmware version and hardware platform, that would help get the loop closed quickly.


Just tested this patch, works for me under 1.7.4832 (7.30)

Thank you very much!

Edit: oops, forgot to mention this is on a vera edge

1 Like

Working for me on Vera Edge with 1.7.4452 firmware.

Thank you thank you thank you!

1 Like

Working for me on VeraPlus firmware version 1.7.4453
I use: L_Honeywe
platform EMEA in The Netherlands (Europe)

@rigpapa Thank you !!
My wife is happy now that the heating goes on automatically

1 Like

I was too quick with the response. I get an error message after about 1 hour

Thanks for the fix, working now on Vera Plus 1.7.4453, in the US through updating the *_legacy.lua file. Thank you!

1 Like

It looks like there has been some changes in the EMEA/EU api. Hass, for example, now has a completely separate component for Honeywell EU. The URLs in the current Vera plugin don’t appear to work at all. Unfortunately, I have no way to develop or test for that locally, so it’s a non-starter, I’m afraid, unless someone in the EU with Honeywell devices wants to make the effort.

1 Like

I don’t know if I can help. Im in Europe but EMEA api as far as I know and if needed I can do some testing. :grinning:
For the time being I’m not able to connect with your new files .
I’m on Vera Edge with 1.7.4832 (7.30) firmware

here logs
08 02/16/20 2:00:01.784 JobHandler_LuaUPnP::HandleActionRequest device: 50 service: urn:joeyd-com:serviceId:HoneywellTCC1 action: SetUsernamePassword <0x72ee3520>
08 02/16/20 2:00:01.784 JobHandler_LuaUPnP::HandleActionRequest argument DeviceNum=50 <0x72ee3520>
08 02/16/20 2:00:01.785 JobHandler_LuaUPnP::HandleActionRequest argument serviceId=urn:joeyd-com:serviceId:HoneywellTCC1 <0x72ee3520>
08 02/16/20 2:00:01.785 JobHandler_LuaUPnP::HandleActionRequest argument action=SetUsernamePassword <0x72ee3520>
06 02/16/20 2:00:01.788 Device_Variable::m_szValue_set device: 50 service: urn:joeyd-com:serviceId:HoneywellTCC1 variable: credAuthorized was: now: #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:1 <0x773d5000>
06 02/16/20 2:00:01.789 Device_Variable::m_szValue_set device: 50 service: urn:joeyd-com:serviceId:HoneywellTCC1 variable: cookieRefreshTime was: Sun, Feb 16, 01:59:42 AM now: Sun, Feb 16, 02:00:01 AM #hooks: 0 upnp: 0 skip: 0 v:(nil)/NONE duplicate:0 <0x773d5000>
01 02/16/20 2:00:02.027 LuaInterface::CallFunction_Job device 50 function SHoneywellTCC1_HoneywellTCC1_SetUsernamePassword_job failed [string “module(“L_HoneywellLib_emea”, package.seeal…”]:187: attempt to concatenate local ‘code’ (a nil value) <0x773d5000>
01 02/16/20 2:00:02.028 Lua_Job::Run job#72 : dev:50 (0x1a65118) P:50 S:0 Id: 72 failed <0x773d5000>
04 02/16/20 2:00:02.029 <0x773d5000>
02 02/16/20 2:00:02.030 JobHandler::PurgeCompletedJobs purge job#72 : dev:50 (0x1a65118) P:50 S:2 Id: 72 status 2 <0x773d5000>
06 02/16/20 2:00:02.844 Device_Variable::m_szValue_set device: 787 service: urn:micasaverde-com:serviceId:EnergyMetering1 variable: KWH was: 36.9370 now: 36.9370 #hooks: 0 upnp: 0 skip: 0 v:0xeb0c28/NONE duplicate:1 <0x76bba520>

This is strange, I’m on 1.7.4903 (7.31 on VeraPlus) I run TCC using EMEA and never noticed any issue on the login. Just checked while reading this thread and it was still running OK. I might be lucky but the change described on the EMEA/EU api should affect all users, isn’t it?

maybe I have to upgrade to 7.31 to solve this issue. i don’t have the knowledge to adjust the api. I don’t know if 7.31 is stable enough to work with without getting into other problems

7.3x will not fix EMEA/EU. Changes are on the Honeywell side.

Edit: based on @ranneman 's comment, I suppose it’s worth trying 7.31, if you want. Without any way to really dig in and troubleshoot myself, since I don’t have EMEA/EU credentials and devices, I can’t be certain. But based on what others are doing (like Hass, as I mentioned), the API has been replaced, so if this one does somehow turn out to be working, who’s to say how long?

1 Like

Thank you rigpapa!
Was having same issue as above users with the Honeywell TCC Plugin over the last week: error code 4.
Vera Plus w version 1.7.4453.
Loaded the files that you posted. rebooted Vera.
All good since last nite!
Thank you!

the Honeywell wifi app seems to be having credential problems and tech support at Vera is not able to offer support on this. Does anyone have any input as too why this app just stopped?

@rigpapa I’m finally getting a chance to test this out and getting the same errors that others are, although I’m using TCC on 7.0.29 for Vera Plus. As I look through the list of Lua files in your attachment, I don’t see L_HoneywellTCC.lua in there. I’m wondering if one of your files is just named differently?

I thought I’d reach out before messing around any further.

Also, to those that are struggling in Europe, I’ve read some bits on other forums that Honeywell is in the process of separating out several of their services into different apps. This may cause repeated issues until they get it all settled.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy