PLUGIN: Honeywell Total Connect Comfort Thermostats

On my Plus running 1.7.4955 (7.31) EMEA interface, it works ok.

Version 2020-02-14 working on openLuup (no vera)
using TCC interface (USA)
Thanks!
C

OK.EMEA/EU running 7.29 firmware or lower ONLY, try this: L_Honeywell_rigpapa-2020-02-17.zip (42.7 KB)

1 Like

I just tested this patch on the following Vera’s that I have here in Canada, running the TCC (Legacy) Interface to Honeywell:
Vera Plus - Firmware Version: 1.7.4453
Vera Edge - Firmware Version: 1.7.4832

It works like a charm.
Everything is working 100% again at this point.
THANK YOU SO MUCH for this fix!!! I don’t what we would have done without you.

P.S. I would be nice if these updates could get into the plugin download or automatic updates so that both new and existing users would get the fix. I presume that isn’t possible since you are not the originator of this plugin. I wish Ezlo/Vera would find a way to make this happen.
Once again, a BIG THANK YOU for solving this issue for the community.

Hi,
I don’t think @rigpapa changed that file.
I was not in the zip and I replaced the 5 files he provided and problem was solved.
I am running version 2.4 of L_HoneywellTCC.lua from Nov 19, 2016 provided by mikee which fixed a problem with newFanMode vs newFanmode that caused ignored fan control.

I appreciate you confirming. I confirmed I have that same TCC lua version.

I decided to load the legacy file one more time. I had loaded all 5 at the same time before and never got the usual Luup reload, which I thought odd at the time. This time, reload occurred immediately and it’s working again! So that file must not have fully loaded or something.

Just want to give @rigpapa a shout out for breathing life into another plugin long abandoned. Without your help, Ezlo would be short a great deal of active users.

1 Like

I’ve been using the Honeywell TCC plugin for years without issues but recently, it stopped working. I’m not sure if the plugin was updated or not. The version of the plugin I have installed now is 2.4, which is the latest in the app store. I can still sucessfully login to TCC and control my Thermostats using the TCC app and the website, so I know that my UN/PW are correct and that my Redlink interface and Thermostats are communicating. Does anyone know what might have happened recently that would cause the TCC plugin to fail in this way?

Here is what I see
image

Actually, this is solved. I installed the files in the zip from rigpapa and everything appears to be working as expected again. Thanks @rigpapa

1 Like

Anybody in EMEA try yet with my latest attempt? Must be EMEA, must be firmware 7.29 or lower.

ok. i’m emea but firm 7.30 on vera edge. not really the one you were looking for. but, its not working for me.

Copied your files into my system and TCC started working again immediately after I ran a Reload Engine.

VeraPlus: Firmware = 1.7.4955 (7.31)
Honeywell WiFi Thermostats App version 2.4

I tried it on my Edge (1.7.4452) and it does not work

THIS APPLIES TO EMEA/EA USERS ONLY – OTHER ZONES DO NOT APPLY; DO NOT MAKE CHANGES BASED ON THIS POST IF YOU ARE NOT IN THE EMEA/EU ZONE

OK. So here is my assessment of the EMEA/EU situation:

  • Works for all Plus (and Secure?) users on 7.3x and up;
  • Fails for all firmware <= 7.29
  • Fails for Edge, even on 7.3x

That points pretty clearly to LuaSec. For some reason, in the 7.3x firmware upgrades, Plus and Secure got an upgrade to the LuaSec library from 0.5 to 0.8. The Edge, however, did not (I don’t know why the disparity, but it is, predictably, maddening). I have requested with Vera engineering that Edge receive the same upgrade ASAP; that request was made a while ago, but I don’t know if it made it into 7.31 beta 2 or not, and I cannot test at the moment. The older LuaSec library cannot handle the encryption requirements being published by the server, so the attempt to negotiate encryption on the request socket fails. This is likely because the server is requiring SNI, and LuaSec 0.5 doesn’t support it.

So:

  • If you are a Plus or Secure user on firmware < 7.30, you need to upgrade to 7.31 beta 2, or wait for its general release.
  • If you are an Edge user on any firmware, you might be able to upgrade to 7.31 beta 2 and it might work, which would indicate that the request to upgrade LuaSec on Edge was handled between beta 1 and beta 2; otherwise, there is no current option for you, you need to wait for a future Edge firmware to upgrade your LuaSec library.

Also please keep in mind that (a) this plugin has no maintainer, I’m just pitching in trying to solve a small (!) problem quickly, and (b) the EMEA/EU API endpoint it uses is being deprecated as we speak and could stop working for other reasons at any time. IMO, what this plugin needs to survive in the long term is that either a group of community developers comprising contributors in each API zone, or Vera themselves, pick it up for ongoing development and support.

3 Likes

Thanks @rigpapa voor your research en time !!

I will do the firmware upgrade to 7.31 beta 2 next week. Fingers crossed…

Just upgraded my test Edge to 1.7.4954 (7.31) Beta 2 and unfortunately it doesn’t work (EMEA). I hope Vera updates the LuaSec library in the official release.

I have a Vera Edge and it is running the latest firmware version 1.7.4954 (7.31) … and I have been using the TCC version … now it is giving me the error “HNYWL TCC: : Honeywell thermostat user authentication failed. Check Setup”

Is there a fix for this? It would be greatly appreciated. Thanks.

There’s a zip file about 30 posts ago for firmware 7.31 that should be applied. If you haven’t already, do that step. Make sure a Luup reload happens and then it should work again.

If you’ve already done that, reply back to let us all know.

After upgrading to firmware 7.31 it seems to work.Vera connect to Honeywell successful !

Okay that was it for EMEA/EU, Authorization fails as of today. I have installed the files you provided but that didn’t fix the issue instantly, after digging around a little I found the cause for this.

I’am on VeraPlus 1.7.4955 (7.31) and using EMEA. I have installed both your fixes (the one for only 7.31 and up and the one for 7.29 and 7.31). As this didn’t fix the authorization I started looking into the files installed on the VeraPlus and I found one strange file in there L_HoneywellLib_emea.lzo. I wondered if this would still be referred to and renamed it to check this. After the rename and another Reload the plugin works again.honeywell strange file

Thanks for your fixes much apprciated. I’m not a developer but really hope this plugin can be kept alive.

I feel like a bit of a dummy, but: how do I apply the patch in the zip file? I have 7.31 and a Vera Edge but I’m using TCC and/or Mobile interface (in the past, flipping between the two has seemed to resolve issues) so I’m hopeful that even without a LuaSec upgrade on the Edge, this will get me back in action.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules