Possible issue with iphone locator/ HouseModes

I’ve noticed that lately, my Housemode won’t switch to Away mode. I’ve confirmed that both my and my wife’s iPhone are checking in at the correct locations, but there seems to be an issue with its interaction with HouseModes. I believe there may have been a recent Vera firmware release that is causing this behavior. Has anyone else seen this?

The setting «Participates in House Mode » is properly set for both ?

Yes, first thing I checked.

I wrote Vera customer support directly:

My House Modes will not set my system to away since the last firmware update. I do not use the built-in Geofencing, because I’ve had too many issues with reliability in the past. I use the iPhone Locator plugin. The plugin is properly reporting my location. For the three instances of the plugin I use, all three have the variable Participates in House Mode is set properly (0 for not participating, 1 for participating). House Modes does work properly when I arrive home, and it changes the mode to Home, but when I leave, it does not change. This seems to be a bug in the current House Modes plugin.

We’ll see if they respond. I don’t think this is a problem with iPhone Locator, rather with House Modes. Since it’s Vera’s plug-in, they’ll need to fix it. I’m just curious if anyone else has seen the behavior.

3 instances? Do you mean you run 3 instances of iphone locator? One for each phone? You may be causing conflicts that way. Maybe try running 1 instance and add 3 phones to it (it would require all phones to be on the same icloud account.)
The house mode plugin is very simple. I actually don’t use it since the lua code it runs is simplistic enough that I can run lua code in scenes instead.

I am not having any issues. with mine.

Yes, there are three instances. 3 different devices being tracked. I’ve been running like this for quite a while, and never had an issue. I suspect there are quite a few users that do it this way.

Hmm… I think there will be housemode conflicts between the different instances since they don’t coordinate: one instance maybe leaving and setting the house away and another may be coming back setting it home and vice versa. I could be wrong but I don’t see how this could work.

Maybe it’s the wording, but there is 1 plugin, and 3 devices.

IPhone Locator Plugin

Uninstall

Additional Information

App id :

4686

Current Version:

2.51

Latest Version

2.51

Auto Update

This plugin has created the following devices:

#274 TimsIPhoneLocator

#275 JensIPhoneLocator

#282 GuestLocator

I’ve been running this for a few years, and never had an issue, aside when Google changed their API charging.

I don’t have this experience and it does look like you created 3 instances which I don’t see how it would work. The way I would do it is by installing only one instance and adding the three devices through the settings/icloud page. Only then will your iphone locator be toggling your housemode singlehandedly. That one instance will have child devices but only one master. Multiple instances should cause mode conflicts.

Not possible. The different devices have different iCloud logins. Even then, you wouldn’t be able to distinguish if one is home or away if they were all in the same device. Besides that, as I’ve said multiple times now, it worked for YEARS without issue.

I’m not sure why having multiple devices would be a problem. I have many devices that I have more than one of. I have multiple PLEG devices/instances off of a single plugin. The fact that the plug-in has a “Create Another” button, would indicate that this would be expected.

Hold on, I am rereading the plugin code, It could be smarter than I thought.

It has worked. I’m not going to argue the matter. I believe the HouseMode pariticpant works as an OR, not an AND operator. It would be the same if you used the built in Geofencing. It wouldn’t go into away mode if one user left, but the others didn’t.

You are right, it should work. Every instance runs a function on UI7 which scans through every parent and child devices for the participation and presence. I stand corrected.

I don’t think this is an issue with the iPhoneLocator instances. I think it’s something with the HouseModes plugin. Like I said in my email to Vera support, it works when coming home, just not when leaving. I’m just surprised no one else has seen it, or at least they haven’t reported it yet.

The iPhone locator does not use the house mode plugin… I also have a hard time understanding why they would be related. iPhone locator just sends a command directly to the vera to change house mode. Unless your house mode plugin changes it back… So no I have never seen any of these problems.

You are correct on that one. I’m not talking about the plug-in per say, I’m talking about the native House modes.

I confirm, IPhonelocators work in groups together ( only the devices for which the participate in house mode checkbox is selected ). so it should work;
to know more -> enable DEBUG and get the logs

I’ll put it in debug now, so I’ll have logs for tonight when I get home, and tomorrow morning when I leave.

Actually, it looks like it’s already in debug mode. How do I export the logs?

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules