Qubino Flush Relay 2 - absent children!

I installed a flush relay 2 a couple of months ago in a garden shed to control two lights. All went fine. This morning I discovered the lights were unexpectedly on and when I went to switch them off the master device was present in the Vera interface (Edge) but the children had disappeared. Any ideas as to why this might have happened (ir was quite cold last night but I doubt it went below freezing) and is there a quick solution or do I have to reset and re add the device to the system. I have a number of these devices and this has never happened before.

My first approach would be to restore from a known working point, so yesterday perhaps?

C

Thanks Catman. The fact is I don’t know when it last worked! I assumed it failed overnight because the lights were on but going back through the restores, they weren’t there two weeks ago and that’s as far as the auto restores go.

Yeah, that’s a sod. I have had a similar issue with some temperature sensors on a Fibaro universal. Just don’t notice they aren’t working properly.
Been trying to think of some Reactor logic that would tell me but so far, no dice.
Although, just had an idea…

Anyway I think you’ll probably have to exclude then re-include but you may want to wait for an expert.

Cheers

C

Thanks. I fear you’re right and excluding / reincluding is always a clog dance, it shouldn’t be but it always turns out that way. I’ll wait a while to see if something turns up. It’s not critical because I normally use vera to switch the lights off when I don’t want to go out to the shed (you know how it is) and I can do that by switching the parent - I’ve just lost the ability to control the two circuits indepoendently

@WokingWounded, before the children went absent, how did you control them, directly from the devices list in UI7, via a scene or some other method? If it was via a scene then it would be worth checking to see whether the scene still “knows” about them.

It is possible to list all the devices that your Vera knows about. It is a two stage process. Firstly go to “Apps”, “Develop apps”, “Test Luup code (Lua)” then copy and pasted the following code into the “Code: box”, then click on run. You should then get up a message saying “Success Code sent successfully”. There are several versions of the following lua code available on this forum some of which don’t include devices set to be hidden but this version does.

local file = io.open("/www/devlist.txt", "w")
file:write("[DeviceNo / id] device names on " .. os.date() .. "\n")
local idx = {}
for deviceNo in pairs(luup.devices) do
    idx[#idx+1] = deviceNo
end
table.sort (idx)
for _,deviceNo in ipairs(idx) do
    d = luup.devices[deviceNo]
    file:write(string.format('[%03d / %s] %s \n', deviceNo, d.id, d.description))
end
file:close()

The second stage is to open a new browser tab/window and put in the following url, with Your.Vera.IP.address modified appropriately.

http://Your.Vera>IP.address/devlist.txt

After you hit enter/return you should get a list off all your devices including any that are hiding (“invisible”). Child devices are identified in the list by having a [DeviceNo / id] of the form “### / e#”. When initially created child devices often have a device number following on from the corresponding parent device but if they have been modified either intentionally or unintentionally then they will not.

Do your errant children show up in this list?

Hi markfh,
Thanks for your interest and the luup code. I usually control my vera stuff with Imperihome and when I originally set up the unit it was assigned an id of 324 and the children 325 and 326 (e1 and e2). These were accepted by Imperihome and as I said, worked fine. It was only this morning I found the imperihome switches were not working and on further investigation the children had absconded. The only thing I have done to the system since installation of this item is run the firmware updat a couple of days ago… And no, having run your code I still can’t find the children!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy