Release Notes - UI7 - Vera Firmware Update - v.7.0.31 (1.7.4954/1.7.4955/1.7.4956) - February 19th, 2020

My system up date went fine. But I had 8 devices that showed “waiting to wake up to config” but could not do anything with them. The biggest problem was that it was so slow & sluggish if it function at all?
I ended up downgrading to 1.7.4453 & system is back to stable working system.
Plugin:
ImperiHome
VeraAlerts
Amazon Helper
Reactor
Sercomm IP Cam-Not Used
DarkSky
DelayLight
Harmony Hub
Switchboard
Google Home-Not Used
Support did get back to me after a couple of days, but I have not been home & will not be for a couple weeks & could not leave the Family Hanging. If I had left it on the 7.31 or shut it down I would have come Home to find the system in the trash can.

1 Like

The cameras shows Not connected… also my air conditioning with the Samsung App… and the Vera app on my iPhone is not connecting to anything

After update it shows this :

You are running the latest version 1.7.4970 (7.31)

And this :frowning:

System error : Device: 161. Fail to load implementation file D_FUP_uuid RINCON_5CAAFD77985401400_MS.xml
System error : Device: 162. Fail to load implementation file D_FUP_uuid RINCON_000E58F5621C01400.xml
System error : Device: 163. Fail to load implementation file D_FUP_uuid RINCON_000E58C62C1201400_MS.xml

I cannot reach my vera from outside and that’s very annoying… so disappointing :frowning:
I cannot use my Voice assistant or Imperihome :frowning:

After the latest firmware my device is just stop responding… You can see everything when you log in but when you try to switch on/off any device nothing happens. And it will stay like that till i restart vera… Then all will be working fine for a while then it stop again…!
Anybody facing the same issue?

I tried updating also with the same problems. I worked with Support to fix, but in the end ended up down grading to get it stable again.
Two weeks later & having to working from home (like a lot of people) I tried again. This time I let Support do the update which went fine & was stable enough for me to work with. After having support delete some devices that I could not do any thing with & not knowing where they came from (old?) Also had to uninstall several devices & reinstall to correct issues. The system is back to (Vera) normal. I am having issues with can’t detect devices again? Up to 3 this morning?

@hyzteric, at first glance, your “Failed to load” messages seem related to the Sonos plug-in. Have you updated to the latest revision 2.0 of that app?

If not, go here for guidance on getting it installed.

For some its a good clean update? That’s the part I am wondering about? Was my system buggy?
I am hoping 7.31 is stable because things do seem quicker & snappier? Time will tell?

Generally speaking there could be two reasons why it fails:

  1. Hardware related. Bad blocks on your storage drive corrupted/interrupted download which still passes CRC check and boom you end up with all kinds of problems. This is not new but it is worse with this firmware because the upgrade involves also a kernel and repartitioning of the flash memory.
  2. Software related. The user config and potentially plugins had accumulated some oddities which is fine by itself since they were running on the old firmware but… The vera has the nasty habit of wanting to correct things without telling you, believing it is smarter than you, installing all kinds of plugin files, ovewritting others, basically acting like a virus on your precious configuration information. So… it corrupted your data while scrubbing and maybe hanging itself due to some other bugs while trying.

Fundamentally, with all things being equal, this firmware is better and will prolong the life of your unit. The upgrade process… has not changed. It is as risky as it ever was if not worse because of what this firmware entails.

Well … fact is it’s not working fine anymore. I’ll have to spend god knows how many time to fix this…

Just tried a factory reset and load a backup… still same issue.
Aaaand most of my devices are gone. What a nigthmare. Pfff

These are not from any version of the Sonos plugin. These are logged by Vera itself because UPnP is enabled and the Vera is finding the Sonos devices as UPnP devices and doesn’t natively know what to do with them.

Turn off UPnP in Users & Account Info > Security and those messages will stop (and another time/process waster on your Vera will have been disabled).

2 Likes

@rigpapa
I do have Sonos speakers on my network.
I just did what you said and turned UPnP off.
Thank you for your tip!

2 Likes

To hell with it. I reset everything and will put all my devices on sale.
I can’t stand wasting hours fixing my configuration every time an update messes everything up.
How convinient is that to have to exclude all my devices and detect them all again, go through all my scenes and Pleg to fix everything…
How do you do when you need to reset then include your mounted door/window sensors that are glued but at the same time must be near the controller?
This is a waste of time and money. This has really pissed me off today. :face_with_symbols_over_mouth:

I’m sorry you are having this issue :frowning_face: but as other people are saying, not everybody has this issue. Yes, everyone should have a flawless experience and the teams that are constantly crawling these forums are doing just that, gathering info to improve your future experience. There are setup and setups, everyone is unique in terms of devices, number of plugins, and custom changes they did on their controllers in order to achieve what they want, and that’s OK. However depending on these factors you might be affected less, more, or not at all by a firmware upgrade. If you ARE affected, the Customer Care team will attempt to do whatever they can to make sure they bring you back on track at least temporary, until the possible reported issues are fixed in an upcoming firmware.

Thank you but the problem is that it is too frequent! I could not tell how many hours have been wasted by flawed updates or just pure random bugs (like you get up one morning and some devices are missing). Prior to my vera plus, I had the vera lite. It has been a constant pain.
I already reset my box and removed all devices from my house, I will sell them after we’re done with that virus…
Thanks to everyone that tries to help, but that is not enough if the base product is so badly designed.

1 Like

2 posts were merged into an existing topic: Ezlo Feedback

what’s frustrating is that things can work OK for months, then collapse with no apparent reasons (well, except the ones already mentioned by @rafale77 about too many automations, reload and data corruptions).

In the latest days, with no tinkering on my production unit, I got:

  • a scene’s code corrupted. I had to convert from a base64 encoded string the code back to LUA and fix it…
  • a device (neo cool cam plug, 100% supported) that lost its ability to report watts usage. I had to remove, plug, change zwave ID and restart.

Overall, we’re pretty frustrated by these type of things. We understand updates are complex, but here it’s complex day-by-day too…

3 Likes

Just want to thank everyone at the Vera supportdesk.
I had a lot of trouble after this upgrade. My Vera was completely gone. So it’s safe to say the upgrade was no succes for me.

But after several chats with the support desk they replaced my Vera Plus with a new unit which is now working fine again. (Did take some work though :grimacing:)

Hopefully things will stay good now. Next time a little more testing before the upgrade would probably be a good idea.

But thumbs up for the service guys :+1:

1 Like

How long did you have the Vera Plus?

just under two years. But they told me they would replace it before they knew how old it was…
So even if it was older they would have replaced it.

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules