Release Notes - UI7 - Vera Firmware Update - v.7.0.31 (1.7.4954/1.7.4955/1.7.4956) - February 19th, 2020

I do have Sonos speakers on my network.
I just did what you said and turned UPnP off.
Thank you for your tip!


To hell with it. I reset everything and will put all my devices on sale.
I can’t stand wasting hours fixing my configuration every time an update messes everything up.
How convinient is that to have to exclude all my devices and detect them all again, go through all my scenes and Pleg to fix everything…
How do you do when you need to reset then include your mounted door/window sensors that are glued but at the same time must be near the controller?
This is a waste of time and money. This has really pissed me off today. :face_with_symbols_over_mouth:

I’m sorry you are having this issue :frowning_face: but as other people are saying, not everybody has this issue. Yes, everyone should have a flawless experience and the teams that are constantly crawling these forums are doing just that, gathering info to improve your future experience. There are setup and setups, everyone is unique in terms of devices, number of plugins, and custom changes they did on their controllers in order to achieve what they want, and that’s OK. However depending on these factors you might be affected less, more, or not at all by a firmware upgrade. If you ARE affected, the Customer Care team will attempt to do whatever they can to make sure they bring you back on track at least temporary, until the possible reported issues are fixed in an upcoming firmware.

Thank you but the problem is that it is too frequent! I could not tell how many hours have been wasted by flawed updates or just pure random bugs (like you get up one morning and some devices are missing). Prior to my vera plus, I had the vera lite. It has been a constant pain.
I already reset my box and removed all devices from my house, I will sell them after we’re done with that virus…
Thanks to everyone that tries to help, but that is not enough if the base product is so badly designed.

1 Like

2 posts were merged into an existing topic: Ezlo Feedback

what’s frustrating is that things can work OK for months, then collapse with no apparent reasons (well, except the ones already mentioned by @rafale77 about too many automations, reload and data corruptions).

In the latest days, with no tinkering on my production unit, I got:

  • a scene’s code corrupted. I had to convert from a base64 encoded string the code back to LUA and fix it…
  • a device (neo cool cam plug, 100% supported) that lost its ability to report watts usage. I had to remove, plug, change zwave ID and restart.

Overall, we’re pretty frustrated by these type of things. We understand updates are complex, but here it’s complex day-by-day too…


Just want to thank everyone at the Vera supportdesk.
I had a lot of trouble after this upgrade. My Vera was completely gone. So it’s safe to say the upgrade was no succes for me.

But after several chats with the support desk they replaced my Vera Plus with a new unit which is now working fine again. (Did take some work though :grimacing:)

Hopefully things will stay good now. Next time a little more testing before the upgrade would probably be a good idea.

But thumbs up for the service guys :+1:

1 Like

How long did you have the Vera Plus?

just under two years. But they told me they would replace it before they knew how old it was…
So even if it was older they would have replaced it.

My hat off to Ezlo/Vera. That is a customer service. Wish the did the same for me when my Vera Edge bricked.

1 Like

Yes Support has been great. Its the firmware that is not making the cut.
I have a Vera Plus & updated my self. Did not go well, sluggish & could not keep running? (Reloads)
Support tried to fix but ended up back at 7.29.& that was a month ago.
So last week since I am Home I contacted Support & will give this a try again? This time they updated & it seem to go well. Then the next day was a different story. Random devices stopped working & others would show errors (waiting for wake to config). Also had very hard time removing devices & adding devices. If I could add a device it not get config correctly or show waiting for wake to config? So I am back on 7.29 & running stable?
For me I guess its time to move on & reinvest with something else?


1 Like

Maybe the “Your smarthome story” campaign isn’t launching at the best time…


Doesn’t seem to have caught the imagination, does it?


1 Like

Decided to finally try the upgrade… but didn’t factory reset it first. Now I can’t get it back up.

It does not respond to ping. The power flickers. I power cycled it after ~3 hrs, the power light came on solid and started flickering again.

Tried to reset following the instructions here But the reset button doesn’t seem to do anything.

For reference, the last time I updated, my Vera Plus took 1+ hr to come back alive on its own.

Any help will be appreciated.

Hi there, please log a ticket with our Customer Care team via this form or email at and make reference to this topic. We’ll get you back on track ASAP.

Exactly.It’s a good example of a typical situation which can lead to bad publicity when the idea was the opposite… :smile:


I have a pretty positive story regarding the update to 1.7.4970 (7.31) that I did yesterday. I read as much as I could absorb without scaring myself silly and decided to proceed. Thanks to Rigpapa and others for the process

  • ran the LUA code to prevent auto configuration of devices
  • did a Z-wave backup
  • did a full backup
  • did a reset to factory defaults
  • upgraded to the latest firmware
  • did a restore

Everything seems to be working perfectly at this time except for two LUA errors I have permanently at the top of my screen relating to device numbers that do not show on my list of devices when I do a dump

I have submitted a tech support case to have TS look at it and will see but overall, it seems very positive.

Those are Sonos devices. Have you tried reinstalling the app?

While those messages are Sonos-related, those messages have nothing to do with the Sonos plugin. They are the Vera detecting the Sonos zone players itself as UPnP devices and trying to figure out generic support for them. It doesn’t work.

Turn off UPnP in the controller’s device settings (Users & Account Info > Security)

1 Like

Hi there, UPnP discovery was already off. I used to have the Sono’s app installed months ago but had no use for it so I uninstalled it. Could it be something legacy hanging around ?

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules