Remote control not supported?

I know not all 433 devices are supported, but I also know some needs special procedures.

I got my KAKU connected very easy with the auto create option. But I have a electronic fireplace which can be controlled with a remote:

on the backside:
433,92MHz
Type: RC01-004

But google doesn’t know much about the contol. Also the led’s on the rfxcom won’t go on after pressing a button. But hey… they also don’t
when I use the remote of my Somfy. So… could this remote be used? Or should this be asked at rfxcom?

Yes there are many 433.92Mhz devices that are not supported so you should not be surprised if you have one that isn’t. I have several. It might help if you provided a bit more info. Does your fireplace remote have a manufacturer name? If it is sold in the US it should have an FCC ID right on the remote itself. But even knowing all that may not help. RFXCOM does monitor this forum so I don’t think it’s necessary to contact them.

The brand is Dimplex Cambridge deluxe. And that’s all I know.
There is no more info on the remote except

Battery: 3x1.5V AAA LR03

And a sticker with 0204

Got a tip from rfxcom to use RAW data. Hace to figure out how to do that.

You may be able to see if a message is being received by the transceiver by selecting the RFXtrx device in Vera and going to the Protocol settings tab. Note what you see below Last Received Message when you press the remote buttons.

Cool, have to try that this evening. An hour ago I was able with wirmware 1032 and protocol undec to read RAW data.
So it picks up the remote control. Would be cool if that could be put into a device.

What are you seeing with undec enabled?

I had contact with rfxcom support. I have this so far:

Pushing the ON/I button

25/11/2018 02:50:52:577
RAW Packet:
307F000601079B022F07BA023401C8081C07BE023C01C6081C07BE023A07B8023A01C8081C07BE023B07B6023701C60000
Packettype = RAW Packet
Packet Length = 48
subtype = RAW packet
Sequence nbr = 6
Repeat = 1
Nbr of pulses = 11
1947 559 1978 564 456 2076 1982 572 454 2076 1982 570 1976 570 456 2076 1982 571 1974 567 454 0

and the OFF/0 button:

25/11/2018 05:44:09:533
RAW Packet:
307F00090107BA022907C0022D01D0081207C8023101D1081207C7023107C1022E07C4023001D1081601D5080F01D60000
Packettype = RAW Packet
Packet Length = 48
subtype = RAW packet
Sequence nbr = 9
Repeat = 1
Nbr of pulses = 11
1978 553 1984 557 464 2066 1992 561 465 2066 1991 561 1985 558 1988 560 465 2070 469 2063 470 0

And I got this for the ON/I command from support:
0
5
1947
559
1978
564
456
2076
1982
572
454
2076
1982
570
1976
570
456
2076
1982
571
1974
567
454
10000

So, importing and thus excecuting the last part from a txt file will indeed turn on my fireplace!’

The next step will be to get it into a device in Vera to power on/off the fireplace.
BTW the ON button can be pressed 3 times: ON, 1000watt heater, 2000w heater.

Hmm tried that, even with only undec selected, but I don’t see the last message changing. But on the rfxcom I see the yellow led blinking!

Would it be possible to implement the option to add a device/switch with undec codes?

This post is really good i also faced this situation when i tried to change my ac temperature through remote control but my remote control did not work properly 24 hour ac repair so i want a solution how to remove this error.