Remotec ZTS-500 & Fan Cycling

Just setting up my brand new ZTS-500 thermostat and I’ve run into one or two issues. The most annoying is that there is is a deceptively convenient “Fan Cycle” button on the device (in the VERA interface) that does… NOTHING!

Now I was probably being naive by in my wild optimism to think that clicking on “Fan Cycle” would create/run some virtual scene to cycle the fan every hour for a few minutes. While it doesn’t throw an error, it just quietly goes back to AUTO. Now the ZTS-500 doesn’t actually have this setting (Unlike the ancient NOMA non-networked one that I retired, Booo…) however I crazily assumed that with a powerful home automation system I could at least emulate this…

Well after a poking around for half an hour I’m a bit stumped. As mentioned there is a “Fan Cycle” mode that does’t do anything (and should therefor not exist and be deleted) but very annoyingly there doesn’t seem to be an obvious way to set the fan mode with a scene, only setpoint and heating/cooling mode…

So what gives? Am I missing something obvious here??

I cycle my fan with it without any issues…
Know that to be as generic as possible the thermostat device on the UI is just a template (albeit not a very good one for a number of other reasons) but it works.

I actually created a custom plugin for the entire HVAC in my house taking into account all the temperature sensors, motion sensors, window sensors, the vents in each room and the thermostat…

To use this in a scene the action is SetMode and the newMode needs to be “On” to force the fan on and “auto” if not forced on (in that case it will turn on in case of heating or cooling). This action is under the service ID HVAC_FanOperatingMode1.

The “PeriodicOn” fan mode is a standard setting/value defined by the standard service. Vera has the ability to suppress items from their tstat UI that are standard for the services but not supported by the installed device, but apparently they missed that for this model. It should just be reported as a bug.

Hmm are your referring to using your custom plugin to cycle? If not then I’m missing something or there is another bug.

On the main Thermostat Device Panel there are settings for Fan Modes, Temperature Setpoint and Off/Auto/Cool/Heat Modes.

However when adding a scene there are no Fan Modes, only Temperature Setpoint and Off/Auto/Cool/Heat Modes.

I see what you are saying now. I don’t use the vera UI to do anything than including devices. Everything else I do on ALTUI these days and it appears indeed that the service for the fan is not declared so the UI7 scene wizard is not displaying it. This should not be unique to this device though and should be the same problem for every thermostat. It is one of the quirks of the vera UI thermostat support.

the best I can offer would be to show some snippets of luup code from my plugin which you could run in a scene:

local cycletime = **how long you want to cycle the fans in seconds**
local thermid = **id of your thermostat**
local fanid = "urn:upnp-org:serviceId:HVAC_FanOperatingMode1"

function setfanoff()
luup.call_action (fanid, "SetMode", {NewMode="Auto"},thermid)
end

function setfanon(period)
luup.call_action (fanid, "SetMode", {NewMode="On"},thermid)
luup.call_delay ("setfanoff",period)
end

setfanon(cycletime)

you could even load these functions in your startup lua and just use the setfanon in a number of scenes to trigger a cycle.

My CT101 UI7 device looks similar to your Remotec so I suspect it is a standard UI7 display as Rigpapa mentions.

While Rafael77 wrote a plug-in, and I find Scenes within Vera very limiting (like no AND logic, just OR), I have been using PLEG for years to change heating and cooling modes based on outside temperature, and heating and cooling setpoints based on house modes. I even have a Virtual Switch to tell me when the blower or fan is running, although with VeraMate, the icon tells me when the blower is operating.

So to emulate a cycling blower or fan, you may want to look into PLEG or Reactor to have it turn on a fan for a finite amount of time and turn it off when you want it off. I am not sure if this what Fan Cycle means to you, but PLEG/Reactor should be able to keep a fan on longer than on Fan Auto and less than on Fan On.

I hope that helps.

Yes, definitely generic. But at least the energy ones say “Thermostat does not support this mode” as opposed to the Cycle one which just appears to work and then quietly fails.

As for fan cycle, it’s such a simple thing it should really work out of the box for the ZTS-500. Many standalone programmable thermostats (like the 15 year old Noma this replaced) do it as a basic setting. Anyhow that’s an issue with Tstat. However it should also be trivial to use the VERA home automation to emulate it. It is somewhat down the rabbit hole to start playing with plugins, using PLEG, etc, etc.; I have other hobbies! :wink: All I would need is for that fan mode to be properly accessible and an interval scene with the a second, delayed action would work perfect.

You know VERA is almost but not quite useful much of the time. I would dearly love to pay a reasonable subscription fee to get them to do a bit more development and support more devices. As I grow older and gain other commitments I have less time and energy for too much hacking… Ah well I suppose I could have just bought into one of the other ecosystems.

OK, so the fairly simple solution to manually emulate fan cycling, at least when the Thermostat mode isn’t “OFF” (another issue that IMHO is a Remotec firmware bug), is to set Scene parameters in the ‘Advanced Editor’ and after a little digging to find the correct Fan Mode string I got it to work:

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy