Saved graphs time zone

Hi all,

Just found Datamine and it is perfect for what I want to do - getting graphs into ImperiHome. I had one issue where no matter what I did, in Graph Options “Display Local Times” kept going back to false after refreshing the page, it would not save - all other options in that same area saved fine? Anyway manually edited the config file and got it to stick now.

My main problem is graphs that i’ve saved and call directly do not display in my timezone. They show correct time scale when you look at them manually in the dm console but when you save them and call them via /dm/graph.html?ref= they do not obey the local timezone.

Has anyone seen this and have any ideas/fix?
Thanks!

I asked about this a long time ago. No answer and no fix.

Hi, thanks for the reply. I’m guessing the datamine project is no longer actively developed so basically there is nothing we can do about it? Shame if that is the case as it works really well and i’ve not found an equivalent even close?

Thanks!

Yeah that’s correct. You can try hundredgraphs that works with the Vera in the forum here. Lighter on features but easier set up and is web based for remote access.

Search for my last postings and you should see be able to find it.

1 Like

Ok, thanks for your help tomtcom!

Ok for anyone who is still using DataMine 2 and has this same issue, I spent some time trying to fix and found a workaround:

Graphs displayed in main “Graph Channels” -> Update graph do obey the setting “Display Local times” however any graphs called via /dm/graph.html?ref=<quickview_reference> do not.
NOTE - I found this setting was not saved when I made changes, in particular from false back to true. I fixed by manually setting the value for “graphOptionTime” in dataMineConfig.json to true

Inserting the code below into the updateChart() function in graph.html forces the graph to not use UTC time.
NOTE - it ignores the “Display Local times” setting above and just blanket forces non UTC times which is fine for me.

Open graph.html in /www/dm and then insert the code below - I inserted just after this line:
“chartOptions.yAxis[3].categories = chartOptions.yAxis[3].max = chartOptions.yAxis[3].min = null;”

Highcharts.setOptions({
global: {
useUTC: false
}
});

Now save this and replace both copies in:

  • /www/dm
  • /overlay/www/dm

No need to restart, refresh page and should be effecitive immediately

Its obviously an older project no longer getting development but it fit my purpose perfectly for getting graphs into ImperiHome, hopefully somebody gets some use from this.

Cheers!

2 Likes

Wish I would have had this back when I was using it but good hack either way. Thanks for posting it.

1 Like