Saving scene towards child device button saves only as last button

I’m using 2.19 with Vera 3 UI5. I’m having some sort of glitch on the child devices. I have created multiple buttons on each of my child devices, for example “Vol Up”, “Vol Down”, “Mute”, in that order. If I attempt to save a scene that click “Vol Up” or “Vol Down” Vera ends up assigning it to “Mute”.

Any ideas would be appreciated.

Thanks,
John

This is one of the best plugins for Vera I have worked with!!

I have worked on over comming this issues for hours, here are the steps to reproduce:

Downloaded dkjson.lua.lzo from http://dkolf.de/src/dkjson-lua.fsl/home
Uncompressed and copied dkjson.lua to /usr/lib/lua

Removed all Harmony Devices
Removed Harmony Plug-in
Removed all files that were created during Harmony Plug-in from /etc/cmh-ludl
Restored Vera backup from before Harmony Plug-in
Verified everything is running as expected on Vera 3 UI5
Verifed /usr/lib/lua/dkjson.lua still exists

Apps / Install Apps / Search by: Harmony
Installed “Harmony Hub Control” 2.19
Allowed Vera to re-load
F5 on IE

Open “Harmony Control” Device
Updated the following properties:
IP Address: {my harmoney hub ip}
Hub email: {my harmoney hub email}
Hub Password: {my harmoney hub ip}
Close “Harmony Control” Device
Click red SAVE button (UI5)
Allowed Vera to re-load
F5 on IE

Open “Harmony Control” Device
Verify Link Status: Ok
Click on Activities Tab (Allow Activities to Load)
Activity ID button 1: PowerOff / Label button 1: Power Off
Click “Save Changes” button
Allowed Vera to re-load
F5 on IE
Test “Power Off” activity - Working!

Open “Harmony Control” Device
Verify Link Status: Ok
Click on Devices Tab (Allow Devices to Load)
Select 5 of the possible 19 devices (Leaving "Create child device enbedded: No)
Click “Save Changes” button
Allowed Vera to re-load
F5 on IE

Open “Harmony Control” Device
Verify Link Status: Ok
Click on Devices Tab (Allow Devices to Load)
Select 5 of the possible 19 devices (Leaving "Create child device enbedded: No)
Click “Save Changes” button
Allowed Vera to re-load
F5 on IE

Open “HRM: Living Room Onkyo” Child Device
Click on Settings
Button 1 Command: Volume Up / Label: “Vol Up” / Press: 1 Sec
Button 2 Command: Volume Up / Label: “Vol Down” / Press: 1 Sec
Button 3 Command: Volume Up / Label: “Mute” / Press: 1 Sec
Click “Save Changes” button
Allowed Vera to re-load
F5 on IE

Test “Vol Up” button - Working!
Test “Vol Down” button - Working!
Test “Mute” button - Working!

Create “New Scene”
Navigate to “HRM: Living Room Onkyo” Child Device
Click “Vol Up” button (Turns blue, it looks like it’s going to save it, Example1.jpg)
Click “Confirm changes” (UI5)
Click red SAVE button (UI5)
Allowed Vera to re-load
F5 on IE

Open “New Scene”
Navigate to “HRM: Living Room Onkyo” Child Device
Notice that the “Mute” button is active (Example2.jpg)

Note: I have tried other child devices as well, same issue. I did have this working at one point with a single child device, this issue started after I added some additional child devices.

Please Help! Really Appreciate the help and this plugin!!

I have attached the results of the log file for the Scene Creation with debug logging on

I figured out a workaround:

Instead of using the UI5 GUI, I created 3 scenes using LUUP:

luup.call_action(“urn:rboer-com:serviceId:HarmonyDevice1”, “SendDeviceCommand”, {Command = “Mute”}, 294)
luup.call_action(“urn:rboer-com:serviceId:HarmonyDevice1”, “SendDeviceCommand”, {Command = “VolumeUp”, Duration=1} ,294)
luup.call_action(“urn:rboer-com:serviceId:HarmonyDevice1”, “SendDeviceCommand”, {Command = “VolumeDown”, Duration=1} ,294)

Note: the command it the actual name in Harmony, not the button.

John

Hi jepjr,

I would have to fire up my old UI5 test box and see what is going on. I will let you know.

Cheers Rene

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules