Schlage BE469 "Getting Secure Classes"

I have this lock and kept getting stuck at “Getting Secure Classes.” I have finally SOLVED this problem! The process to include this lock is: 1. Exclude the lock by putting the Vera in exclude mode and entering the six-digit code followed by zero “0” on the lock. 2. Include the lock by putting the Vera in include mode and entering the six-digit code followed by zero “0” on the lock. 3. When the Vera shows “Getting Secure Classes,” enter the six-digit code followed by zero “0” on the lock AGAIN. The lock will error out with a red X, but the Vera will continue and pair the lock successfully.

2 Likes

I think this might just be a coincidence. How close was the Vera to the lock when you were doing the pairing process?

I have tried this and every other fix for the secure classes problem I could find on this forum. No luck. I have two locks that I setup years ago that work fine. They are years old but working. I have another old lock that will not get past this error. Has anyone found a fix for this? I am running a vera lite on the latest firmware and trying to add (another) BE369. I don’t want to reset the Vera and lose the working locks I have and most have said reset was not a fix anyway! I se references to using older firmware with the PLUS but the firmware versions in the thread do not match my lite versions. Any suggestions?

Ok. So I decided to call support after not being able to fix this. I had tried the exclude/include cycle dozens of times yesterday. Support had me add a remote account and “enable support” on my Vera and then we went through EXACTLY the same steps I went through yesterday. Worked the first time!!! The only difference was that they did ran the gui remotely and I had added their account and enabled support. I am not sure how this made a difference. So my advice is to call support immediately instead of wasting hours/days like I did.

Amazingly this worked for me tonight.
I have a Vera2 and a Vera Plus and when I added a GE Outdoor Switch for holiday lights it sent the Plus in to a LUUP cyclic reboot. I had to put the Plus back to factory defaults. Everything came back ok except for three of my Schlage BE469 deadbolts. They were constantly stuck at Please await! Getting Secure Classes. Re-entering the programming code and pressing 0 pushed it past that step ON ALL THREE LOCKS. The FW version on the locks are all ?Main_5.8?. Amazing.
Thank you OP!

Marc

Went and bought a Smart Things hub, and was also thinking about connecting it with the Schlage Dead Bolt Lock. They connect to each other. Would be perfect to do…

I followed this procedure. While it did get me past the secure classes message, it then went to getting the manufacturer. This never completed. Even entering in Schlage (taken from another lock that paired succdessfully) in the Advanced section didn’t resolve.
Now its back to “Please wait! Getting secure classes”.

I’ve tried excluding/including several times. Each time the pairing is made, but the process never completes and the device is unresponsive to commands while the messages are being displayed.

I would be interested in any other suggestions…

2 suggestions.
Get a long ethernet cable and move your Vera next to the lock then play the excluding/including game again. Give it plenty of time to pair.
USE FRESH BATTIERS in your lock.

based on my experience
take the battery out and put it back in the lock, it needs to exchange secure keys and sometime while doing so the lock zwave chil goes to sleep

engdahl - thanks very much for this tidbit. It worked for me.

Yep. And I’ve got eight of these locks! Took an awful lot of tinkering to get them all working!

Engdahl

Best Home Automation shopping experience. Shop at getvera!

© 2020 Vera Control Ltd., All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules