Sending "raw" data

we have some gates that in undec mode the RFXcom433 will detect. I understand this means that data could be sent as a raw file. Has anyone got this to work and able to fire a raw data file in a vera scene ?.

i was hoping to set something up so that we can open / close gates using a scene.

You can test if using the data seen in undec mode will work. You might try this from the Vera Apps -> Develop Apps -> Test Luup code (Lua) dialog:
luup.call_action(“urn:upnp-rfxcom-com:serviceId:rfxtrx1”, “SendMessage”, {[“Message”] = “XXXXXXXXXXXXXX”}, yyyy)
Where XXXXXXXXXXXXXXXX is the hexidecimal data (which is quite long) reported by the undec mode and yyyy is the device number of your RFXtrx transceiver.
Let me know if this works to open and close your gates. I’ll try to come up with a way to work those into a scene.

Ok great, Thank you. I’ll give that a go and let you know if that works!.

I’ve tried this but I get the “failed to test code” message. hmm.

Two suggestions: can you turn on logging in the RFXtrx and try again? See what shows up in the log.
Can you post exactly what you entered in the Test Lua dialog?

Ok lets try with logging on.

Below is the syntax entered
luup.call_action(“urn:upnp-rfxcom-com:serviceId:rfxtrx1”, “SendMessage”, {[“Message”] = “387F000001024005D7026905D8026905D7026905DA02650319051C05DB02640319051C05D902650318051C05DA0263031C051805D802660000 ”}, #245)

Do not enter the # with the device number.

I tried that when I was looking at what might be wrong, still gives me the error. Daft question but the device number is the ID shown in Vera yes ?

Yes - it’s the value of the ‘Id’ that appears in the advanced tab for the RFXtrx.

OK - I’ve tried it on my own RFXtrx and I see an error reported by Vera. I’ll look into this.

Ok great thanks, really do appreciate your help. If I get this to work it will be really useful.

Well, I tried a couple of times. I did get some errors reported but I also had some success (I think). Without having your actual gate to witness a response it’s had to tell. I did notice an extra space character at the end of the hex data but that would not be noticed by Vera. Your quote characters look different too ( “ vs " not sure if that matters). Here’s what I sent successfully (my device number was different of course):
luup.call_action(“urn:upnp-rfxcom-com:serviceId:rfxtrx1”, “SendMessage”, {[“Message”] = “387F000001024005D7026905D8026905D7026905DA02650319051C05DB02640319051C05D902650318051C05DA0263031C051805D802660000”}, 245)
Here is what I see in the log in an instance that I think was successful:
08 04/13/19 9:48:10.193 JobHandler_LuaUPnP::HandleActionRequest device: 0 service: urn:micasaverde-com:serviceId:HomeAutomationGateway1 action: e[36;1mRunLuae[0m <0x74c17520>
08 04/13/19 9:48:10.193 JobHandler_LuaUPnP::HandleActionRequest argument id=lu_action <0x74c17520>
08 04/13/19 9:48:10.193 JobHandler_LuaUPnP::HandleActionRequest argument serviceId=urn:micasaverde-com:serviceId:HomeAutomationGateway1 <0x74c17520>
08 04/13/19 9:48:10.193 JobHandler_LuaUPnP::HandleActionRequest argument action=RunLua <0x74c17520>
08 04/13/19 9:48:10.194 JobHandler_LuaUPnP::HandleActionRequest argument Code=luup.call_action(“urn:upnp-rfxcom-com:serviceId:rfxtrx1”, “SendMessage”, {[“Message”] = “387F000001024005D7026905D8026905D7026905DA02650319051C05DB02640319051C05D902650318051C05DA0263031C051805D802660000”}, 1471)
<0x74c17520>
08 04/13/19 9:48:10.195 JobHandler_LuaUPnP::HandleActionRequest device: 1471 service: urn:upnp-rfxcom-com:serviceId:rfxtrx1 action: e[36;1mSendMessagee[0m <0x74c17520>
08 04/13/19 9:48:10.195 JobHandler_LuaUPnP::HandleActionRequest argument Message=387F000001024005D7026905D8026905D7026905DA02650319051C05DB02640319051C05D902650318051C05DA0263031C051805D802660000 <0x74c17520>
50 04/13/19 9:48:10.196 luup_log:1471: RFXtrx: dbg: Action SendMessage: message to send: 387F000001024005D7026905D8026905D7026905DA02650319051C05DB02640319051C05D902650318051C05DA0263031C051805D802660000 <0x74c17520>
50 04/13/19 9:48:10.198 luup_log:1471: RFXtrx: dbg: Sending command: 38 7F 00 02 01 02 40 05 D7 02 69 05 D8 02 69 05 D7 02 69 05 DA 02 65 03 19 05 1C 05 DB 02 64 03 19 05 1C 05 D9 02 65 03 18 05 1C 05 DA 02 63 03 1C 05 18 05 D8 02 66 00 00 <0x74c17520>
01 04/13/19 9:48:10.199 e[31;1mLuaInterface::StartEngine returned false: 0e[0m <0x74c17520>
01 04/13/19 9:48:10.199 e[31;1mJobHandler_LuaUPnP::RunLua failed: luup.call_action(“urn:upnp-rfxcom-com:serviceId:rfxtrx1”, “SendMessage”, {[“Message”] = “387F000001024005D7026905D8026905D7026905DA02650319051C05DB02640319051C05D902650318051C05DA0263031C051805D802660000”}, 1471)
e[0m <0x74c17520>
02 04/13/19 9:48:10.200 e[33;1mJobHandler_LuaUPnP::RunAction device -1 action urn:micasaverde-com:serviceId:HomeAutomationGateway1/RunLua failed with 401/Code failede[0m <0x74c17520>

Vera thinks it failed but I believe that the RFXtrx transmitted the data.

OK great I’ll give it another go and see what happens. I did think of actually going out and looking at the gate just to see, but as it rejected it I thought it probably had not sent anything. Of course after all these years using Vera (we’ve been using it since V2 hardware and UI2 I should have known to actually go and check rather than rely on the message!. I’ll let you know how I get on!.

If you’re not seeing any action from your gate you might try this change: the string of data ends with ‘0000’. Try changing that to ‘2710’. Also, the 5th byte of data is ‘01’. Try changing that to ‘02’ and then send the command again.
When you’re using RFXmngr to see the message data and you’re controlling your gate normally, how many ‘undec’ messages do you see for each time you trigger your gate?

I was wondering if I should use the other data that was picked up as reading a little around this it sounds like it might work instead of the hexdata. There are between 2 - 6 pulses sent (more if you hold the button down longer). i’ve sent some information off to the mfr of RXFCOM and they have looked at the data and sent me back some data to try so will give that a go at the weekend when back home. I’ll let you know how I get on. I’ll try firing it from the rfxcom first, if I can get that to work then I’ll try it again in Vera. It would be useful to be able to do this as could then add in some further automation. Ideally i’d just change the gate to be zwave however we’re not the only house in the street and the other few residents have no interest in moving away from the current way the gate is controlled (they also dont want to put in decent broadband but that’s a different story (they are all retired hence have different requirements to us).

I did that for emulating an X10 alarm module…

Have a look here as well:

I did notice that to keep the “sensors” active, I had to resend the ‘closed’ message again about every 10 minutes, but that seems to be an X10 specific thing…

Just an update on this as I’ve not been able to spend any real time on it over the last few weeks. The guys at RFXCOM kindly offered to take a look at the raw data I sent them, they sent me back some data extracted from that which they thought would probably activate the gate if I fired it off in raw mode (that’s a good starting point). I was unable to get that to do anything hence for now I’ve parked trying to get vera to fire the data.

When I’ve got a little more time I’m going to go through the data and try and find a sequence that will operate the gates when the command is fired directly from the RFXCOM unit. once I’ve got that sorted I’ll return to trying to get vera to fire that data to give some “automation” over the gates.

If they were our own gates I’d just get the control system in the gate changed, however as its a shared gate and noone else in the street has any interest at all in upgrading / changing things then I’m stuck with having to go the long way around.

Thanks for your help so far, it’s really much appreciated.